Table of Contents

OVERVIEW OF PIVOTTABLE AND PIVOTCHART REPORTS ......................................................................................... 4
  WHAT IS A PIVOTTABLE REPORT? .......................................................................................................................... 4
  Ways to work with a PivotTable report .................................................................................................................. 5
  WHAT IS A PIVOTCHART REPORT? ....................................................................................................................... 6
  Differences between a PivotChart and a standard chart .......................................................................................... 6
  COMPARING A PIVOTTABLE REPORT AND A PIVOTCHART REPORT .............................................................. 6
  WORKING WITH THE SOURCE DATA OF A PIVOTTABLE OR PIVOTCHART REPORT ...................................... 7
  Creating a PivotTable or PivotChart from worksheet data ...................................................................................... 7
  Using an external data source to create a PivotTable or PivotChart ...................................................................... 7
  Using another PivotTable report as the data source ............................................................................................... 8
  Changing the source data of an existing PivotTable report ..................................................................................... 8

CREATE A PIVOTTABLE REPORT ............................................................................................................................ 9
  DEFINE THE DATA SOURCE FOR THE PIVOTTABLE REPORT ............................................................................. 9
  CREATE THE PIVOTTABLE REPORT ..................................................................................................................... 9
  ADD FIELDS TO THE PIVOTTABLE REPORT ......................................................................................................... 10
  Copy fields in a PivotTable report ......................................................................................................................... 11
  CREATE A PIVOTTABLE FROM AN EXTERNAL DATA SOURCE ............................................................................ 11
  SWITCH BETWEEN AUTOMATIC AND MANUAL UPDATING OF THE REPORT LAYOUT ........................................ 12
  REFRESH PIVOTTABLE DATA ................................................................................................................................ 13
  Refresh PivotTable data manually .......................................................................................................................... 13
  View the refresh status or cancel the refresh ......................................................................................................... 13
  Refresh PivotTable data automatically when opening the workbook ................................................................ 13
  DELETE A PIVOTTABLE REPORT .......................................................................................................................... 13

CREATE A PIVOTCHART REPORT FROM AN EXISTING PIVOTTABLE REPORT ............................................... 14
  CREATE A STANDARD CHART FROM SOME OR ALL DATA IN A PIVOTTABLE REPORT ................................ 14
  CONVERT A PIVOTCHART REPORT TO A STANDARD CHART .......................................................................... 15
  DELETE A PIVOTCHART REPORT .......................................................................................................................... 15

WORKING WITH THE PIVOTTABLE FIELD LIST .............................................................................................. 15
  HOW THE PIVOTTABLE FIELD LIST WORKS ..................................................................................................... 16
  GUIDELINES FOR MOVING FIELDS IN THE PIVOTTABLE FIELD LIST .......................................................... 17
  CHANGING THE PIVOTTABLE FIELD LIST VIEW ................................................................................................. 17
  ADD FIELDS TO A PIVOTTABLE OR PIVOTCHART .............................................................................................. 17
  Add the fields you want to display .......................................................................................................................... 18
  Add multiple copies of a field in the Values area .................................................................................................... 18
  Filter data before you add fields ............................................................................................................................ 18

CHANGE THE LAYOUT AND FORMAT OF A PIVOTTABLE REPORT ................................................................. 19
  REARRANGE FIELDS IN THE PIVOTTABLE OR PIVOTCHART .......................................................................... 19
  Remove fields from a PivotTable report ................................................................................................................ 20
  CHANGE THE LAYOUT FORM OF A PIVOTTABLE REPORT ................................................................................ 20
  Change a PivotTable report to compact, outline, or tabular form ......................................................................... 21
FILTER ITEMS IN A PIVOT TABLE REPORT .......................................................... 23
Repeat item labels in rows .................................................................................. 23
Repeat item labels in columns ............................................................................ 24
Turn repeated item labels on or off for all fields .................................................. 24
Change the way item labels are displayed in a layout form ............................... 24

EXPAND, COLLAPSE, OR SHOW DETAILS IN A PIVOT TABLE REPORT OR PIVOT CHART REPORT .......................................................... 25
Expand or collapse to different levels of detail ...................................................... 25
Expand or collapse levels in a PivotTable .......................................................... 25
Expand or collapse levels in a PivotChart ......................................................... 25
Show or hide the expand and collapse buttons in a PivotTable ............................ 26
Show or hide details for a value field in a PivotTable .......................................... 26
Show value field details ...................................................................................... 26
Disable or enable the option to show value field details ................................. 26

CHANGE THE DISPLAY OF BLANK CELLS, BLANK LINES, AND ERRORS .............. 26
Change how errors and empty cells are displayed ............................................. 26
Display or hide blank lines after rows or items ................................................. 26

CHANGE OR REMOVE FORMATTING ................................................................. 27
Apply a style to format a PivotTable report ....................................................... 27
Apply banding to change the format of a PivotTable report ............................... 27
Remove a style or banding format from a PivotTable report ............................. 28
Change the number format for a field .............................................................. 28

GROUP ITEMS IN A PIVOT TABLE REPORT ....................................................... 29
Group numbers in numeric fields ..................................................................... 30
Group dates or times .......................................................................................... 30
Group selected items .......................................................................................... 31
Ungroup grouped items ...................................................................................... 31

SORT DATA IN A PIVOT TABLE OR A PIVOT CHART REPORT .......................... 31
LEARN MORE ABOUT SORTING .......................................................................... 31
SORT ROW OR COLUMN LABEL DATA IN A PIVOT TABLE REPORT ................. 32
SORT DATA IN THE VALUES AREA ..................................................................... 33
SORT DATA IN A PIVOT CHART REPORT .......................................................... 33

FILTER ITEMS IN A PIVOT TABLE REPORT ....................................................... 33
LEARN ABOUT FILTERING ................................................................................. 34
SPECIFY FILTER OPTIONS .................................................................................. 34
Allow multiple filters per field ........................................................................... 34
Display or hide field captions and filter drop downs ........................................ 34
USE A REPORT FILTER TO FILTER ITEMS ....................................................... 35
Add a report filter to the PivotTable report ....................................................... 35
Select items in the report filter ......................................................................... 35
Display report filter pages on separate worksheets ......................................... 35

FILTER ITEMS MANUALLY BY SELECTING ROW OR COLUMN LABEL FIELDS 36
FORMATTING SLICERS

WHAT ARE SLICERS?

USING SLICERS...

FORMATTING SLICERS FOR A CONSISTENT LOOK

SHARING SLICERS BETWEEN PIVOT TABLES

CREATE A SLICER IN AN EXISTING PIVOT TABLE

FORMAT A SLICER

SHARE A SLICER BY CONNECTING TO ANOTHER PIVOT TABLE

MAKE A SLICER AVAILABLE FOR USE IN ANOTHER PIVOT TABLE

USE A SLICER FROM ANOTHER PIVOT TABLE

DISCONNECT OR DELETE A SLICER

DISCONNECT A SLICER

DELETE A SLICER

CALCULATE VALUES IN A PIVOT TABLE REPORT

AVAILABLE CALCULATION METHODS

SUMMARY FUNCTIONS IN VALUE FIELDS

FUNCTIONS THAT YOU CAN USE AS A SUBTOTAL

CUSTOM CALCULATIONS

FUNCTIONS AVAILABLE FOR CUSTOM CALCULATIONS IN VALUE FIELDS

FORMULAS

HOW THE TYPE OF SOURCE DATA AFFECTS CALCULATIONS

USING FORMULAS IN PIVOT TABLE REPORTS

CREATE FORMULAS IN A PIVOT TABLE REPORT

ADD A CALculated FIELD

ADD A CALCULATED ITEM TO A FIELD

ENTER DIFFERENT FORMULAS CELL BY CELL FOR CALCULATED ITEMS

ADJUST THE ORDER OF CALCULATION FOR MULTIPLE CALCULATED ITEMS OR FORMULAS

EDIT A PIVOT TABLE FORMULA

DETERMINE WHETHER A FORMULA IS IN A CALCULATED FIELD OR A CALCULATED ITEM

EDIT A CALCULATED FIELD FORMULA

EDIT A SINGLE FORMULA FOR A CALCULATED ITEM

EDIT AN INDIVIDUAL FORMULA FOR A SPECIFIC CELL OF A CALCULATED ITEM

DELETE A PIVOT TABLE FORMULA

VIEW ALL FORMULAS THAT ARE USED IN A PIVOT TABLE REPORT

subtotal and total fields in a pivot table report

subtotal row and column fields

DISPLAY OR HIDE GRAND TOTALS FOR THE ENTIRE REPORT

DISPLAY OR HIDE GRAND TOTALS

Change the default behavior for displaying or hiding grand totals

CALCULATE THE SUBTOTALS AND GRAND TOTALS WITH OR WITHOUT FILTERED ITEMS

SHOW DIFFERENT CALCULATIONS IN PIVOT TABLE VALUE FIELDS
Overview of PivotTable and PivotChart reports

A PivotTable report is useful to summarize, analyze, explore, and present summary data. A PivotChart report can help you visualize PivotTable report summary data so that you can easily see comparisons, patterns, and trends. Both reports enable you to make informed decisions about critical data in your enterprise.

What is a PivotTable Report?

A PivotTable report is an interactive way to quickly summarize large amounts of data. Use a PivotTable report to analyze numerical data in detail and to answer unanticipated questions about your data. A PivotTable report is especially designed for:

- Querying large amounts of data in many user-friendly ways.
- Subtotaling and aggregating numeric data, summarizing data by categories and subcategories, and creating custom calculations and formulas.
- Expanding and collapsing levels of data to focus your results, and drilling down to details from the summary data for areas of interest to you.
- Moving rows to columns or columns to rows (or "pivoting") to see different summaries of the source data.
- Filtering, sorting, grouping, and conditionally formatting the most useful and interesting subset of data to enable you to focus on the information that you want.
- Presenting concise, attractive, and annotated online or printed reports.

![Diagram of a PivotTable report]

You often use a PivotTable report when you want to analyze related totals, especially when you have a long list of figures to sum and you want to compare several facts about each figure.

In the PivotTable report example, you can easily see how the third-quarter golf sales in cell F3 compare to sales for another sport, or quarter, or to the total sales.

1. Source data, in this case, from a worksheet
2. The source values for Qtr3 Golf summary in the PivotTable report
3. The entire PivotTable report
4. The summary of the source values in C2 and C8 from the source data

In a PivotTable report, each column or field in your source data becomes a PivotTable field that summarizes multiple rows of information. In the preceding example, the Sport column becomes the Sport field, and each record for Golf is summarized in a single Golf item.

A value field, such as Sum of Sales, provides the values to be summarized. Cell F3 in the preceding report contains the sum of the Sales value from every row in the source data for which the Sport column contains...
Golf and the Quarter column contains Qtr3. By default, data in the Values area summarize the underlying source data in the PivotChart report in the following way: numeric values use the SUM function, and text values use the COUNT function.

To create a PivotTable report, you must define its source data, specify a location in the workbook, and lay out the fields.

**Ways to work with a PivotTable report**

After you create the initial PivotTable report by defining the data source, arranging fields in the PivotTable field List, and choosing an initial layout, you can perform the following tasks as you work with a PivotTable report:

**Explore the data:**
- Expand and collapse data, and show the underlying details that pertain to the values.
- Sort, filter, and group fields and items.
- Change summary functions, and add custom calculations and formulas.

**Change the form layout and field arrangement:**
- Change the PivotTable report form: compact, outline, or tabular.
- Add, rearrange, and remove fields.
- Change the order of fields or items.

**Change the layout of columns, rows, and subtotals:**
- Turn column and row field headers on or off, or display or hide blank lines.
- Display subtotals above or below their rows.
- Adjust column widths on refresh.
- Move a column field to the row area or a row field to the column area.
- Merge or unmerge cells for outer row and column items.

**Change the display of blanks and errors:**
- Change how errors and empty cells are displayed.
- Change how items and labels without data are shown.
- Display or hide blank lines

**Change the format:**
- Manually and conditionally format cells and ranges.
- Change the overall PivotTable format style.
- Change the number format for fields.
What is a PivotChart report?
A PivotChart report provides a graphical representation of the data in a PivotTable report, which in this case is called the associated PivotTable report. Like a PivotTable report, a PivotChart report is interactive. When you create a PivotChart report, PivotChart report filters are displayed in the chart area so that you can sort and filter the underlying data of the PivotChart report. Changes that you make to the field layout and data in the associated PivotTable report are immediately reflected in the PivotChart report.

A PivotChart report displays data series, categories, data markers, and axes just as standard charts do. You can also change the chart type and other options such as the titles, the legend placement, the data labels, and the chart location.

You can automatically create a PivotChart report when you first create a PivotTable report, or you can create a PivotChart report from an existing PivotTable report.

Differences between a PivotChart and a standard chart
If you are familiar with standard charts, you will find that most operations are the same in PivotChart reports. However, there are some differences:

Row/Column orientation: Unlike a standard chart, you cannot switch the row/column orientation of a PivotChart report by using the Select Data Source dialog box. However, you can pivot the Row and Column labels of the associated PivotTable report to achieve the same effect.

Chart types: You can change a PivotChart report to any chart type except an xy (scatter), stock, or bubble chart.

Source data: Standard charts are linked directly to worksheet cells. PivotChart reports are based on the data source of the associated PivotTable report. Unlike a standard chart, you cannot change the chart data range in the Select Data Source dialog box of a PivotChart report.

Formatting: Most formatting — including chart elements that you add, layout, and style — is preserved when you refresh a PivotChart report. However, trendlines, data labels, error bars, and other changes to data sets are not preserved. Standard charts do not lose this formatting once it is applied.

Although you cannot directly resize the data labels in a PivotChart report, you can increase the font size of the text to effectively resize the labels.

Comparing a PivotTable report and a PivotChart report
When you create a PivotChart report from a PivotTable report, the layout of the PivotChart report, that is, the position of its fields is determined initially by the layout of the PivotTable report. When you create the PivotChart report first, you determine the chart layout by dragging fields from the PivotTable Field List to specific areas on the chart sheet.

Note: The Totals and Subtotals of an associated PivotTable report are ignored in a PivotChart report.
The PivotTable and PivotChart reports of sales data illustrate the relationship between the two.

1. A row label corresponds to a category
2. A column label corresponds to a data series

Working with the source data of a PivotTable or PivotChart report
When you create a PivotTable or a PivotChart report, you can use any of several different types of source data.

Creating a PivotTable or PivotChart from worksheet data
You can use data from a Microsoft Excel worksheet as the basis for a report. The data should be in list format, with column labels in the first row. Each cell in subsequent rows should contain data appropriate to its column heading. There should not be any blank rows or columns within the data of interest. Excel uses your column labels for the field names in the report. The worksheet data becomes the source data for the PivotTable report.

Using a named range: To make the report easier to update, name the source range, and then use the name when you create the report. If the named range expands to include more data, you can refresh the report to include the new data.

Excel tables: Excel tables are already in list format and are good candidates for PivotTable source data. When you refresh the PivotTable report, new and updated data from the Excel table is automatically included in the refresh operation.

Including totals: Excel automatically creates subtotals and grand totals in a PivotTable report. If the source data contains automatic subtotals and grand totals that you created by using the Subtotals command in the Outline group on the Data tab, use that same command to remove the subtotals and grand totals before you create the report.

Using an external data source to create a PivotTable or PivotChart
You can retrieve data from a source that is external to Excel such as a database, an Online Analytical Processing (OLAP) cube (A database technology that has been optimized for querying and reporting, instead of processing transactions. OLAP data is organized hierarchically and stored in cubes instead of tables.), or a text file. For example, you might maintain a database of sales records you want to summarize and analyze.

Office Data Connection files: If you use an Office Data Connection (ODC) file (.odc) to retrieve external data for your report, you can input the data directly into a PivotTable report. We recommend that you retrieve external data for your reports by using ODC files.
OLAP source data: When you retrieve source data from an OLAP database or a cube file (An OLAP data structure. A cube contains dimensions, like Country/Region/City, and data fields, like Sales Amount. Dimensions organize types of data into hierarchies with levels of detail, and data fields measure quantities.), the data is returned to Excel only as a PivotTable report or a PivotTable report that has been converted to worksheet functions.

Non-OLAP source data: This is the underlying data for a PivotTable report or a PivotChart report that comes from a source other than an OLAP database. For example, data from relational databases or text files.

Using another PivotTable report as the data source

The PivotTable cache: Each time that you create a new PivotTable report or PivotChart report, Excel stores a copy of the data for the report in memory, and saves this storage area as part of the workbook file. Thus, each new report requires additional memory and disk space. However, when you use an existing PivotTable report as the source for a new report in the same workbook, both reports share the same copy of the data. Because you reuse the same storage area, the size of the workbook file is reduced and less data is kept in memory.

Location requirements: To use a PivotTable report as the source for another report, both reports must be in the same workbook. If the source PivotTable report is in a different workbook, copy the source report to the workbook location where you want the new report to appear. PivotTable reports and PivotChart reports in different workbooks are separate, each with its own copy of the data in memory and in the workbook files.

Changes affect both reports: When you refresh the data in the new report, Excel also updates the data in the source report, and vice versa. When you group or ungroup items in one report, both reports are affected. When you create calculated fields or calculated items in one report, both reports are affected.

PivotChart reports: You can base a new PivotTable report or PivotChart report on another PivotTable report, but you cannot base it directly on another PivotChart report. However, Excel creates an associated PivotTable report from the same data whenever you create a PivotChart report; therefore, you can base a new report on the associated report. Changes to a PivotChart report affect the associated PivotTable report, and vice versa.

Changing the source data of an existing PivotTable report

Changes in the source data can result in different data being available for analysis. For example, you may want to conveniently switch from a test database to a production database. You can update a PivotTable report or a PivotChart report with new data that is similar to the original data connection information by refreshing the report.

To include additional data or different data, you can redefine the source data for the report. If the data is substantially different with many new or additional fields, it may be easier to create a new report.

Displaying new data brought in by refresh: Refreshing a report can also change the data that is available for display. For reports based on worksheet lists, Excel retrieves new fields within the source range or named range that you specified. For reports based on external data, Excel retrieves new data that meets the criteria for the underlying query. You can view any new fields in the Field List and add the fields to the report.
Create a PivotTable report

Define the data source for the PivotTable report

- To use worksheet data as the data source, click a cell in the range of cells that contains the data.
- To use data in a Microsoft Excel table as the data source, click a cell inside the Excel table.

Note: Make sure that the range has column headings or that headers are displayed in the table, and that there are no blank rows in the range or table.

Create the PivotTable report

1) On the Insert tab, in the Tables group, click PivotTable.
   a) Excel displays the Create Pivot Table dialog box.
   Tip: To create a PivotChart that is based on the PivotTable report at the same time, click the arrow below PivotTable, and then click PivotChart.

2) In the Create PivotTable dialog box, under Choose the data that you want to analyze, make sure that Select a table or range is selected, and then in the Table/Range box, verify the range of cells that you want to use as the underlying data.
   a) Excel automatically determines the range for the PivotTable report, but you can replace it by typing a different range or a name that you defined for the range.
   b) For data in another worksheet or workbook, include the workbook and worksheet name by using the following syntax [workbookname]sheetname!range.
   Tip: You can also click Collapse Dialog to temporarily hide the dialog box, select the range on the worksheet, and then click Expand Dialog.

3) Under Choose where you want the PivotTable report to be placed, specify a location by doing one of the following:
   a) To place the PivotTable report in a new worksheet starting at cell A1, click New Worksheet.
   b) To place the PivotTable report at a specific location in an existing worksheet, select Existing Worksheet, and then in the Location box, specify the first cell in the range of cells where you want to position the PivotTable report.

4) Click OK.
   a) Excel adds an empty PivotTable report to the specified location and displays the PivotTable Field List so that you can add fields, create a layout, and customize the PivotTable report.

Note: If you created a PivotChart at the same time, it is displayed on top of the associated PivotTable report. A PivotChart and its associated PivotTable report must always be in the same workbook.
Add fields to the PivotTable report

In the PivotTable Field List, do one or more of the following:

1) To place a field in the default area of the layout section, select the check box next to the field name in the field section.
   a) By default, nonnumeric fields are added to the Row Labels area, and numeric fields are added to the Values area.

2) To place a field in a specific area of the layout section, right-click the field name in the field section, and then select Add to Report Filter, Add to Column Label, Add to Row Label, or Add to Values.

3) To drag a field to the area that you want, click and hold the field name in the field section, and then drag it to an area in the layout section.

Tips:

- You can use the PivotTable Field List to rearrange the fields at any time by right-clicking the fields in the layout section and then selecting the area that you want, or by dragging the fields between the areas in the layout section.

- Changes that you make to the source data after you create the PivotTable report are reflected in the report when you refresh the selected PivotTable report (PivotTable Tools, Options tab, Data group, Refresh button).

- If you add rows to the range of source data, you can include those rows in the PivotTable report by changing the source data (PivotTable Tools, Options tab, Data group, Change Source Data button). If the source data is in an Excel table, additional rows are automatically displayed when you refresh the PivotTable report.

1 The field section contains the field names of the fields you can add to the Layout section

2 The layout section contains the Report Filter area, the Column Labels area, the Row Labels area, and the Values area.
Copy fields in a PivotTable report

In a PivotTable report you may want to add the same field more than once to the **Values** area so that you can display different calculations by using the **Show Values As** feature. For example, you may want to compare calculations side-by-side, such as gross and net profit margins, minimum and maximum sales, or customer counts and percentage of total customers.

1) Click and hold a field name in the field section, and then drag the field to the **Values** area in the layout section.
2) Repeat step 1 as many times as you want to copy the field.
3) In each copied field, change the summary function or custom calculation the way you want.

Notes:
- When you add two or more fields to the Values area, whether they are copies of the same field or different fields, the Field List automatically adds a Values Column label to the **Values** area. You can use this field to move the field positions up and down within the **Values** area. You can even move the Values Column label to the **Column Labels** area or **Row Labels** areas. However, you can’t move the Values Column label to the Report Filters area.
- You can add a field only once to either the **Report Filter**, **Row Labels**, or **Column Labels** areas, whether the data type is numeric or non-numeric. If you try to add the same field more than once — for example to the **Row Labels** and the **Column Labels** areas in the layout section — the field is automatically removed from the original area and put in the new area.
- Another way to add the same field to the **Values** area is by using a formula (also called a calculated column) that uses that same field in the formula.

Create a PivotTable from an external data source

When you create a PivotTable report from external data, you are creating a connection to source data that is stored outside Excel, for example in a database program (such as Microsoft Access or Microsoft SQL Server) or an Online Analytical Processing (OLAP) cube.

1) Click a cell on the worksheet.
2) On the **Insert** tab, in the **Tables** group, click **PivotTable**, or click the arrow below **PivotTable**, and then click **PivotTable**.
   a) Excel displays the **Create PivotTable** dialog box.
   Tip: To create a PivotTable and PivotChart report at the same time, on the **Insert** tab, in the **Tables** group, click the arrow below **PivotTable**, and then click **PivotChart**. Excel displays the **Create PivotTable with PivotChart** dialog box.
3) Under **Choose the data that you want to analyze**, click **Use an external data source**.
4) Click **Choose Connection**.
   a) In the **Show** box at the top of the **Existing Connections** dialog box, select the category of connections for which you want to specify a connection or select **All Connections** (which is the default).
5) Under Select a Connection, select a connection, and then click Open.

Note: If you select a connection from the Connections in this Workbook category, you will be reusing or sharing an existing connection. If you select a connection from the Connection files on the network or Connection files on this computer categories, Excel copies the connection file into the workbook as a new workbook connection, and then uses that file (an .odc file) as the new connection for the PivotTable report.

6) Under Choose where you want the PivotTable report to be placed, specify a location by doing one of the following:
   a) To place the PivotTable report in a new worksheet starting at cell A1, click New Worksheet.
   b) To place the PivotTable report in an existing worksheet, select Existing Worksheet, and then in the Location box, specify the first cell in the range of cells where you want to position the PivotTable report.

7) Click OK.
   a) Excel adds an empty PivotTable report to the specified location and displays the PivotTable Field List so that you can add fields, create a layout, and customize the PivotTable report.

   Note: If you create a PivotChart report at the same time that you create a PivotTable report, Excel displays the chart on top of the associated PivotTable. A PivotChart report and its associated PivotTable report must always be in the same workbook.

8) To add fields to the report, do one or more of the following:
   a) Select the check box next to each field name in the field section. The field is placed in a default area of the layout section, but you can rearrange the fields if you want.
      • By default, nonnumeric fields are added to the Row Labels area, numeric fields are added to the Values area, and Online Analytical Processing (OLAP) date and time hierarchies are added to the Column Labels area.
   b) Right-click the field name and then select the appropriate command, Add to Report Filter, Add to Column Label, Add to Row Label, and Add to Values, to place the field in a specific area of the layout section.

   Tip: You can also click and hold a field name, and then drag the field between the field section and an area in the layout section.

Switch between automatic and manual updating of the report layout

By default, changes you make in the PivotTable Field List are automatically updated in the report layout. To improve performance when you are accessing a large amount of external data, you can temporarily switch to manual updating mode. Manual updating mode allows you to quickly add, move, and remove fields in the PivotTable Field List. However, you cannot use the report until you switch back to automatic updating mode.

1) To enable manual updating of the PivotTable report, at the bottom of the PivotTable Field List, select the Defer layout update check box.

   Caution: After you set the report layout to manual updating, closing the PivotTable Field List, changing to Fields only view, or exiting Excel discards all layout changes that you have made to the PivotTable report without confirmation.

2) In the PivotTable Field List, make the field layout changes, and then click Update to manually update the layout in the PivotTable report.
3) To return to automatic updating after you finish changing the report layout in the Field List, clear the **Defer layout update** check box.

**Note:** A PivotTable report starts with automatic updating each time that you open the workbook.

**Refresh PivotTable data**

When a PivotTable report is connected to another PivotTable in the same workbook or in another workbook, or to another external data source, such as a Microsoft Access or SQL Server database, or an Online Analytical Processing (OLAP) cube, you can perform a refresh operation to retrieve any data updates. Each time you refresh the PivotTable data, you’ll see the most recent version of the data, including changes that were made to the data since it was last refreshed.

By default, PivotTables are not refreshed automatically, but you can specify that the PivotTable is automatically refreshed when you open the workbook that contains the PivotTable.

**Refresh PivotTable data manually**

1) Click anywhere in the PivotTable report.
   a) This displays the **PivotTable Tools**, adding an **Options** and a **Design** tab.

2) On the **Options** tab, in the **Data** group, do one of the following:
   a) To update the information to match the data source, click the **Refresh** button, or press ALT+F5.
   b) To refresh all PivotTables in the workbook, click the **Refresh** button arrow, and then click **Refresh All**.

**Note:** If you experience display or formatting changes when you refresh the PivotTable report, make sure that the **Autofit column width on update** and **Preserve cell formatting on update** check boxes are selected on the **Layout & Format** tab in the **PivotTable Options** dialog box (**PivotTable Tools**, **Options** tab, **PivotTable** group, **Options** command).

**View the refresh status or cancel the refresh**

After starting a refresh, you can review the status or cancel it at any time.

1) On the **Options** tab, in the **Data** group, click the **Refresh** button arrow, and then click **Refresh Status** to view the status or **Cancel Refresh** to stop refreshing.

**Refresh PivotTable data automatically when opening the workbook**

1) Click anywhere in the PivotTable report.
   a) This displays the **PivotTable Tools**, adding an **Options** and a **Design** tab.

2) On the **Options** tab, in the **PivotTable** group, click **Options**.

3) In the **PivotTable Options** dialog box, on the **Data** tab, select the **Refresh data when opening the file** check box.

**Delete a PivotTable report**

1) Click anywhere in the PivotTable report that you want to delete.
   a) This displays the **PivotTable Tools**, adding the **Options** and **Design** tabs.

2) On the **Options** tab, in the **Actions** group, click the arrow below **Select**, and then click ** Entire PivotTable**.

3) Press DELETE.
Note: Deleting a PivotTable report that is associated with a PivotChart report turns that PivotChart report into a standard chart that you can no longer pivot or update.

Create a PivotChart report from an existing PivotTable report
1) Click the PivotTable report.
   a) This displays the PivotTable Tools, adding the Options and Design tab.
2) On the Options tab, in the Tools group, click PivotChart.
3) In the Insert Chart dialog box, click the chart type and chart subtype that you want. You can use any chart type except an xy (scatter), bubble, or stock chart.
4) Click OK.
   a) The PivotChart report that appears has PivotChart report filters that you can use to change the data that is displayed in the chart.

Create a standard chart from some or all data in a PivotTable report
1) Select the data in the PivotTable report that you want to use in your chart.
   Tip: To include field buttons and data in the first row and column of the report, start dragging from the lower-right corner of the data that you select.
2) On the Home tab, in the Clipboard group, click Copy.
3) Click a blank cell outside the PivotTable report.
4) On the Home tab, in the Clipboard group, click the arrow below Paste, and then under Paste Values, click Values, Values & Number Formatting, or Values & Source Formatting.
5) On the Insert tab, in the Charts group, click the chart type that you want, and then click a chart subtype.
Convert a PivotChart report to a standard chart

You can convert a PivotChart report to a standard chart by deleting its associated PivotTable report. If you have multiple PivotTable reports and PivotChart reports in your workbook, you may first have to find the associated PivotTable report that has the same name as the PivotChart report.

1) Do one of the following:
   a) If you know which PivotTable report is associated with the PivotChart report that you want to change, click that PivotTable report.
   b) If you do not know which PivotTable report is associated with the PivotChart report that you want to change, do the following:
      • Click the PivotChart report that you want to change.
        (1) This displays the PivotChart Tools, adding the Design, Layout, Format, and Analyze tab.
      • To find the name of the associated PivotTable report, do the following:
        (1) On the Design tab, in the Data group, click Select Data.
        (2) In the Select Data Source dialog box, in the Chart data range box, note the associated PivotTable name, which is the text that follows the (!) exclamation point, and then click OK.
      • To find the associated PivotTable report, do the following:
        (1) Click a PivotTable report in the workbook.
        (2) On the Options tab, in the PivotTable group, click Options, and then click Options.
        (3) In the Name box, note whether the name matches the name of the associated PivotTable report.
        (4) Repeat steps 1 through 3 of this procedure for each PivotTable report in the workbook until you find the same name in the Name box.
        (5) Click OK, and then select the associated PivotTable report that has the same name as the PivotChart report that you want to change.

2) On the Options tab, in the Actions group, click Select, and then click Entire PivotTable.

3) Press DELETE.

Delete a PivotChart report

1) Click anywhere in the PivotChart that you want to delete.

2) Press DELETE.

Note: Deleting a PivotChart report does not delete the associated PivotTable report.

Working with the PivotTable Field List

By using the PivotTable Field List, you can add, rearrange, or remove fields to show data in a PivotTable or PivotChart exactly the way that you want.

By default, changes you make in the PivotTable Field List are automatically updated in the report layout. To improve performance when you are accessing a large amount of external data, you can temporarily switch to manual updating.
When you create a PivotTable, Excel displays the PivotTable Field List so that you can add fields to the PivotTable, rearrange and reposition them as needed, or remove them from the PivotTable. By default, the PivotTable Field List displays two sections:

- A field section at the top for adding fields to and removing fields from the PivotTable
- A layout section at the bottom for rearranging and repositioning fields

You can dock the PivotTable Field List to either side of the Excel window and horizontally resize it. You can also undock the PivotTable Field List, in which case, you can resize it both vertically and horizontally.

If you don’t see the PivotTable Field List, make sure that you click anywhere in the PivotTable.

If you close the PivotTable Field List, you can display it again. Right-click the PivotTable, and then click Show Field List. You can also click Field List on the Ribbon (PivotTable Tools, Options tab, Show group for a PivotTable; PivotChart Tools, Analyze tab, Show/Hide group for a PivotChart).

If you don’t see the fields that you want to use in the PivotTable Field List, refresh the PivotTable or PivotChart report to display any new fields, calculated fields, measures, calculated measures, or dimensions that you have added since the last operation (PivotTable Tools, Options tab, Data group).

**How the PivotTable Field List works**

It's important to understand how the PivotTable field List works and the ways that you can arrange different types of fields so that you can achieve the results that you want when you create the field layout of a PivotTable or PivotChart report.

1. A data source contains structured data organized as one or more fields (also called columns) that are displayed in the Field List.

2. Move a field to the Report Filter area in the Field List, which simultaneously moves the field to the Report Filter area in the PivotTable report.

3. Move a field to the Column Label area in the Field List, which simultaneously moves the field to the Column Label area in the PivotTable report.

4. Move a field to the Row Label area in the Field List, which simultaneously moves the field to the Row Label area in the PivotTable report.

5. Move a field to the Values area in the Field List, which simultaneously moves the field to the Values area in the PivotTable report.
Guidelines for moving fields in the PivotTable Field List
To create a field layout, use the following guidelines for moving Value, Name, and Dimension fields from the field section to the four report areas in the layout section.

- **Value fields**: If you select a check box only for a numeric field, by default, it is moved to the Values area.
- **Row and Column fields**: You can add a field only once to either the Report Filter, Row Labels, or Column Labels areas, whether the data type is numeric or non-numeric. If you try to add the same field more than once — for example, to the Row Labels and the Column Labels areas in the layout section — the field is automatically removed from the original area and put in the new area.

Changing the PivotTable Field List view
The PivotTable Field List has five different views that are designed and optimized for different types of PivotTable tasks.

1) To change the view, click the Field List views button at the top of the PivotTable Field List.
2) In the list, select one of the following views:

<table>
<thead>
<tr>
<th>View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fields Section and Areas Section Stacked</td>
<td>This is the default view, and it is designed for a small number of fields.</td>
</tr>
<tr>
<td>Fields Section and Areas Section Side-By-Side</td>
<td>This view is designed for adding and removing fields when you have more than four fields in each area.</td>
</tr>
<tr>
<td>Fields Section Only</td>
<td>This view is designed for just adding and removing many fields.</td>
</tr>
<tr>
<td>Areas Section Only (2 by 2)</td>
<td>This view is designed for just rearranging many fields.</td>
</tr>
<tr>
<td>Areas Section Only (1 by 4)</td>
<td>This view is designed for just rearranging many fields.</td>
</tr>
</tbody>
</table>

Tip: In the Fields Section and Areas Section Stacked and Fields Section and Areas Section Side-By-Side views, you can adjust the width and height of each section by resting the pointer on the section divider until the pointer changes to a vertical double arrow ↑ or horizontal double arrow ←, by dragging the double arrow up or down or left or right to where you want it, and then either clicking the double arrow or pressing ENTER.

Add fields to a PivotTable or PivotChart
After you create a PivotTable or PivotChart report, you are ready to add the fields that contain the data you want to display in the report. You typically select one field for each area in the layout section. However, to see different values for a specific field, you can also add multiple copies of a field to the Values area.

If the PivotTable report is connected to an external data source that contains a lot of data, you can filter one or more fields before you add fields to the report, which can help reduce the time it takes to update the report.
Add the fields you want to display
In the PivotTable Field List, you can add fields to the PivotTable or PivotChart by doing one or more of the following:

- To place a field in a designated area of the layout section, in the Choose fields to add to report box, select the check box of the field that you want. You can then rearrange fields later if you want.

  Note: By default, nonnumeric fields are added to the Row Labels area, and numeric fields are added to the Values area.

- To place a field in a specific area of the layout section, in the Choose fields to add to report box, right-click the field name, and then click Add to Report Filter, Add to Column Label, Add to Row Label, or Add to Values.

- To drag a field to an area in the layout section, in the Choose fields to add to report box, click and hold a field, and then drag it from the field section to the layout section that you want.

Add multiple copies of a field in the Values area
In a PivotTable report you may want to add the same field more than once to the Values area. You can do this whether the data type is numeric or non-numeric. For example, you may want to compare calculations side-by-side, such as gross and net profit margins, minimum and maximum sales, or customer counts and percentage of total customers.

1) In the PivotTable Field List, in the Choose fields to add to report box, click and hold a field, and then drag it to the Values area in the layout section.
2) Repeat step 1 to create as many copies of that field that you want to display in the Value area.
3) In the PivotTable, change the summary function or custom calculation the way you want in each copy of the field.

  Tip: In the PivotTable, you can also change the name of the copied fields as needed.

Notes:
- When you add two or more fields to the Values area, whether they are copies of the same field or different fields, the Field List automatically adds a Values Column label to the Values area. You can use this field to move the field positions up and down in the Values area. You can even move the Values Column Label to the Column Labels area or Row Labels areas. However, you cannot move the Values Column label to the Report Filters area.
- You can add a field only once to either the Report Filter, Row Labels, or Column Labels areas, whether the data type is numeric or non-numeric. If you try to add the same field more than once — for example, to the Row Labels and the Column Labels areas in the layout section — the field is automatically removed from the original area and put in the new area.
- Another way to add the same field to the Values area is by using a formula (also called a calculated column) that uses that same field in the formula.

Filter data before you add fields
1) In the PivotTable Field List, in the Choose fields to add to report box, rest the pointer on a field name, and then click the filter drop-down arrow next to the field name.
2) On the Filter menu, select the filter options that you want.
Change the layout and format of a PivotTable report

After creating a PivotTable report and adding the fields that you want to analyze, you may want to enhance the report layout and format it to make the data easier to read and scan for details. To change the layout of a PivotTable report, you can change the PivotTable form and the way that fields, columns, rows, subtotals, empty cells and lines are displayed. To change the format of the PivotTable report, you can apply a predefined style, banded rows, and conditional formatting.

Rearrange fields in the PivotTable or PivotChart

In the PivotTable Field List, you can rearrange existing fields or reposition those fields by using one of the four areas at the bottom of the layout section:

<table>
<thead>
<tr>
<th>PivotTable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Values</td>
<td>Use to display summary numeric data.</td>
</tr>
<tr>
<td>Row Labels</td>
<td>Use to display summary numeric data.</td>
</tr>
<tr>
<td>Column Labels</td>
<td>Use to display fields as columns at the top of the report. A column lower in position is nested within another column immediately above it.</td>
</tr>
<tr>
<td>Report Filter</td>
<td>Use to filter the entire report based on the selected item in the report filter.</td>
</tr>
<tr>
<td>Values</td>
<td>Use to display summary numeric data.</td>
</tr>
<tr>
<td>Axis Field (Categories)</td>
<td>Use to display fields as an axis in the chart.</td>
</tr>
<tr>
<td>Legend Fields (Series)</td>
<td>Use to display fields in the legend of the chart.</td>
</tr>
<tr>
<td>Report Filter</td>
<td>Use to filter the entire report based on the selected item in the report filter.</td>
</tr>
</tbody>
</table>

To rearrange fields in a PivotTable report, click the field name in one of the areas, and then select one of the following commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move Up</td>
<td>Moves the field up one position in the area.</td>
</tr>
<tr>
<td>Move Down</td>
<td>Moves the field down position in the area.</td>
</tr>
<tr>
<td>Move to Beginning</td>
<td>Moves the field to the beginning of the area.</td>
</tr>
<tr>
<td>Move to End</td>
<td>Moves the field to the end of the area.</td>
</tr>
<tr>
<td>Move to Report Filter</td>
<td>Moves the field to the Report Filter area.</td>
</tr>
<tr>
<td>Move to Row Labels</td>
<td>Moves the field to the Row Labels area.</td>
</tr>
<tr>
<td>Move to Column Labels</td>
<td>Moves the field to the Column Labels area.</td>
</tr>
<tr>
<td>Move to Values</td>
<td>Moves the field to the Values area.</td>
</tr>
<tr>
<td>Value Field Settings, Field Settings</td>
<td>Displays the Field Settings or Value Field Settings dialog boxes. For more information about each setting, click the Help button ? at the top of the dialog box.</td>
</tr>
</tbody>
</table>
Tip: You can also click and hold a field name, and then drag the field between the field and layout sections, and between the different areas.

**Remove fields from a PivotTable report**

1) Click the PivotTable report.
   a) This displays the **PivotTable Tools**, adding an **Options** tab and a **Design** tab.

2) To display the PivotTable Field List, if necessary, on the **Options** tab, in the **Show** group, click **Field List**.

3) To remove a field, in the PivotTable Field List, do one of the following:
   a) In the PivotTable Field List, clear the check box next to the field name.
      **Note:** Clearing a check box in the Field List removes all instances of the field from the report.
   b) In a Layout area, click the field name, and then click **Remove Field**.
   c) Click and hold a field name in the layout section, and then drag it outside the PivotTable Field List.

**Change the layout form of a PivotTable report**

To make substantial layout changes to a PivotTable report or its various fields, you can use one of three forms:

- **Compact form**: displays items from different row area fields in one column and uses indentation to distinguish between the items from different fields. Row labels take up less space in compact form, which leaves more room for numeric data. **Expand** and **Collapse** buttons are displayed so that you can display or hide details in compact form. Compact form saves space and makes the PivotTable report more readable and is therefore specified as the default layout form for PivotTables.

- **Tabular form**: displays one column per field and provides space for field headers.

- **Outline form**: is similar to tabular form but it can display subtotals at the top of every group because items in the next column are displayed one row below the current item.
Change a PivotTable report to compact, outline, or tabular form

1) Click anywhere in the PivotTable report.
   a) This displays the PivotTable Tools, adding an Options and a Design tab.

2) On the Design tab, in the Layout group, click Report Layout, and then do one of the following:
   a) To keep related data from spreading horizontally off of the screen and to help minimize scrolling, click Show in Compact Form.
      - In compact form, fields are contained in one column and indented to show the nested column relationship.
   b) To outline the data in the classic PivotTable style, click Show in Outline Form.
   c) To see all data in a traditional table format and to easily copy cells to another worksheet, click Show in Tabular Form.

Change the layout of columns, rows, and subtotals
To further refine the layout of a PivotTable report, you can make changes that affect the layout of columns, rows, and subtotals, such as displaying subtotals above rows or turning column headers off. You can also rearrange individual items within a row or column.

Turn column and row field headers on or off

1) Click the PivotTable report.
   a) This displays the PivotTable Tools, adding an Options tab and a Design tab.

2) To switch between showing and hiding field headers, on the Options tab, in the Show group, click Field Headers.

Display subtotals above or below their rows

1) In the PivotTable report, select the row field for which you want to display subtotals.
   a) This displays the PivotTable Tools, adding an Options tab and a Design tab.
      Tip: In outline or tabular form, you can also double-click the row field, and then continue with step 3.

2) On the Options tab, in the Active Field group, click Field Settings.

3) In the Field Settings dialog box, on the Subtotals & Filters tab, under the Subtotals, click Automatic or Custom.
   Note: If None is selected, subtotals are turned off.

4) On the Layout & Print tab, under Layout, click Show item labels in outline form, and then do one of the following:
   a) To display subtotals above the subtotaled rows, select the Display subtotals at the top of each group check box. This option is selected by default.
   b) To display subtotals below the subtotaled rows, clear the Display subtotals at the top of each group check box.
Change the order of row or column items
Do any of the following:
- In the PivotTable report, right-click the row or column label or the item in a label, point to Move, and then use one of the commands on the Move menu to move the item to another location.
- Select the row or column label item that you want to move, and then point to the bottom border of the cell. When the pointer becomes a four-headed pointer, drag the item to a new position. The illustration shows how to move a row item by dragging.

Adjust column widths on refresh
1) Click anywhere in the PivotTable report.
   a) This displays the PivotTable Tools, adding an Options tab and a Design tab.
2) On the Options tab, in the PivotTable group, click Options.
3) In the PivotTable Options dialog box, on the Layout & Format tab, under Format, do one of the following:
   a) To automatically fit the PivotTable report columns to the size of the widest text or number value, select the Autofit column widths on update check box.
   b) To keep the current PivotTable report column width, clear the Autofit column widths on update check box.

Move a column to the row labels area or a row to the column labels area
You might want to move a column field to the row labels area or a row field to the column labels area to optimize the layout and readability of the PivotTable report. When you move a column to a row or a row to a column, you are transposing the vertical or horizontal orientation of the field. This operation is also called "pivoting" a row or column.

Do any of the following:
- Right-click a row field, point to Move <field name>, and then click Move <field name> To Columns.
- Right-click a column field, and then click Move <field name> to Rows.
- Drag a row or column field to a different area. The illustration shows how to move a column field to the row labels area.

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Sales</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Region</td>
<td>Sport</td>
</tr>
<tr>
<td>3</td>
<td>East</td>
<td>Golf</td>
</tr>
<tr>
<td>4</td>
<td>West</td>
<td>Tennis</td>
</tr>
<tr>
<td>5</td>
<td>Grand Total</td>
<td>27,520</td>
</tr>
</tbody>
</table>

1 Click a column field
2 Drag it to the row area
3 Sport becomes a row field like Region

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Sales</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Region</td>
<td>Sport</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>East</td>
<td>Golf</td>
<td>10,500</td>
</tr>
<tr>
<td>4</td>
<td>West</td>
<td>Tennis</td>
<td>18,270</td>
</tr>
<tr>
<td>5</td>
<td>Grand Total</td>
<td>35,290</td>
<td>49,890</td>
</tr>
</tbody>
</table>
Merge or unmerge cells for outer row and column items
You can merge cells for row and column items in order to center the items horizontally and vertically, or to unmerge cells in order to left-justify items in the outer row and column fields at the top of the item group.

1) Click anywhere in the PivotTable report.
   a) This displays the PivotTable Tools, adding an Options tab and a Design tab.
2) On the Options tab, in the PivotTable group, click Options.
3) In the PivotTable Options dialog box, click the Layout & Format tab, and then under Layout, select or clear the Merge and center cells with labels check box.
   Note: You cannot use the Merge Cells check box under the Alignment tab in a PivotTable report.

Repeat item labels in a PivotTable report
In Excel 2010, you can repeat item and field labels in a PivotTable report to make a PivotTable easier to read. You can repeat labels for nested items per field in rows or columns. You can also turn the option to repeat labels on or off for all fields in the PivotTable at the same time.

For example, repeated labels are useful in a PivotTable report that has value fields in columns and grand totals and subtotals turned off for all fields on rows.

Repeat item labels in rows
1) In the PivotTable report, click the row label that you want to repeat.
   a) This displays the PivotTable Tools, adding an Options and a Design tab.
2) On the Options tab, in the Active Field group, click Field Settings.
   Tip: You can also right-click the row label that you want to repeat, and then click Field Settings.
3) Click the Layout & Print tab, and then select the Repeat item labels check box.
   Tip: To remove the repeated labels, clear the Repeat item labels check box.
4) To show the repeated labels in the PivotTable, make sure that Show item labels in tabular form is selected.

Notes
- When you edit any of the repeated labels, the changes you make are automatically applied to all other cells with the same label.
- When you change the format of all repeated labels by selecting the item label in the summary row or all repeated labels, the format is automatically applied to all other cells with the same label. However, you can also change the format of individual repeated labels without applying the same formatting to other cells with the same label.
- Repeated labels are shown in tabular form only. They are not shown when compact form or outline form are applied.
Repeat item labels in columns

1) In the PivotTable report, click the column label that you want to repeat.
   a) This displays the PivotTable Tools, adding an Options and a Design tab.
2) On the Options tab, in the Active Field group, click Field Settings.
   Tip: You can also right-click the column label that you want to repeat, and then click Field Settings.
3) Click the Layout & Print tab, and then select the Repeat item labels check box.

Notes
• When you edit any of the repeated labels, the changes you make are automatically applied to all other cells with the same label.
• When you change the format of all repeated labels by selecting the item label in the summary row or all repeated labels, the format is automatically applied to all other cells with the same label. However, you can also change the format of individual repeated labels without applying the same formatting to other cells with the same label.
• Repeated labels are shown in compact form for outer fields only. Repeated labels are not shown when outline form is applied.

Turn repeated item labels on or off for all fields

1) Click anywhere in the PivotTable for which you want to repeat labels.
   a) This displays the PivotTable Tools, adding an Options and a Design tab.
3) Do one of the following:
   a) To display repeated item labels, click Repeat All Item Labels.
   b) To remove repeated item labels, click Do Not Repeat Item Labels.

Change the way item labels are displayed in a layout form

1) In the PivotTable report, select a row field.
   a) This displays the PivotTable Tools, adding an Options and a Design tab.
      Tip: You can also double-click the row field in outline or tabular form, and continue with step 3.
2) On the Options tab, in the Active Field group, click Field Settings.
3) In the Field Settings dialog box, click the Layout & Print tab, and then under Layout, do one of the following:
   a) To show field items in outline form, click Show item labels in outline form.
   b) To display or hide labels from the next field in the same column in compact form, click Show item labels in outline form, and then select Display labels from the next field in the same column (compact form).
   c) To show field items in table-like form, click Show item labels in tabular form.

Expand, collapse, or show details in a PivotTable or PivotChart report

To show or hide additional data in a PivotTable report or PivotChart report, you can expand or collapse fields that have detail data to any level of data detail.

You can also show or hide the details that are used to aggregate the value in a value field.
Expand or collapse to different levels of detail
In a PivotTable report or PivotChart report, you can expand or collapse to any level of detail, and even for all levels of detail in one operation. You can also expand or collapse to a level of detail beyond the next level. For example, starting at a country/region level, you can expand to a city level which expands both the state/province and city level. This can be a time-saving operation when you work with many levels of detail. In addition, you can expand or collapse all members for each field in an Online Analytical Processing (OLAP) data source.

Expand or collapse levels in a PivotTable
In a PivotTable, do one of the following:

- Click the expand or collapse button next to the item that you want to expand or collapse.
- Double-click the item that you want to expand or collapse.
- Right-click the item, click Expand/Collapse, and then do one of the following:
  - To see the details for the current item, click Expand.
  - To hide the details for the current item, click Collapse.
  - To hide the details for all items in a field, click Collapse Entire Field.
  - To see the details for all items in a field, click Expand Entire Field.
  - To see a level of detail beyond the next level, click Expand To "<Field name>".
  - To hide a level of detail beyond the next level, click Collapse To "<Field name>".

Expand or collapse levels in a PivotChart
In a PivotChart, right-click the category label for which you want to show or hide level details, click Expand/Collapse, and then do one of the following:

- To see the details for the current item, click Expand.
- To hide the details for the current item, click Collapse.
- To hide the details for all items in a field, click Collapse Entire Field.
- To see the details for all items in a field, click Expand Entire Field.
- To see a level of detail beyond the next level, click Expand To "<Field name>".
- To hide a level of detail beyond the next level, click Collapse To "<Field name>".

Show or hide the expand and collapse buttons in a PivotTable
The expand and collapse buttons are displayed by default, but you may have hidden them (for example, when you don't want them to appear in a printed report). To use these buttons to expand or collapse levels of detail in the report, you must make sure that they are displayed.

- On the Options tab, in the Show group, click +/- Buttons to show or hide the expand and collapse buttons.

Note: Expand and collapse buttons are available only for fields that have detail data.
Show or hide details for a value field in a PivotTable
By default, the option to display details for a value field in a PivotTable is turned on. To protect others from seeing this data, you can turn it off.

Show value field details
1) In a PivotTable, do one of the following:
   a) Right-click a field in the values area of the PivotTable, and then click **Show Details**.
   b) Double-click a field in the values area of the PivotTable.
2) The detail data that the value field is based on is placed on a new worksheet.

Disable or enable the option to show value field details
1) Click anywhere in the PivotTable.
   a) This displays the **PivotTable Tools**, adding the **Options** and **Design** tabs.
2) On the **Options** tab, in the **PivotTable** group, click **Options**.
3) In the **PivotTable Options** dialog box, click the **Data** tab.
4) Under **PivotTable Data**, clear or select the **Enable show details** check box to disable or enable this option.

Change the display of blank cells, blank lines, and errors
There may be times when your PivotTable data contains blank cells, blank lines, or errors, and you want to change the way they are displayed.

Change how errors and empty cells are displayed
1) Click anywhere in the PivotTable report.
   a) This displays the **PivotTable Tools**, adding an **Options** tab and a **Design** tab.
2) On the **Options** tab, in the **PivotTable** group, click **Options**.
3) In the **PivotTable Options** dialog box, click the **Layout & Format** tab, and then under **Format**, do one or more of the following:
   a) To change the error display, select the **For error values show** check box. In the box, type the value that you want to display instead of errors. To display errors as blank cells, delete any characters in the box.
   b) To change the display of empty cells, select the **For empty cells show** check box, and then type the value that you want to display in empty cells in the text box.

   **Tip:** To display blank cells, delete any characters in the box. To display zeros, clear the check box.

Display or hide blank lines after rows or items
Do any of the following:
- **For rows**, do the following:
  1) In the PivotTable report, select a row field.
  2) This displays the **PivotTable Tools**, adding an **Options** tab and a **Design** tab.

      **Tip:** In outline or tabular form, you can also double-click the row field, and then continue with step 3.
  3) On the **Options** tab, in the **Active Field** group, click **Field Settings**.
4) In the **Field Settings** dialog box, on the **Layout & Print** tab, under **Layout**, select or clear the **Insert blank line after each item label** check box.

- **For items**, do the following:
  1) In the PivotTable report, select the item you want.
     a) This displays the **PivotTable Tools**, adding an **Options** tab and a **Design** tab.
  2) On the **Design** tab, in the **Layout** group, click **Blank Rows**, and then select the **Insert Blank Line after Each Item Label** or **Remove Blank Line after Each Item Label** check box.

**Note:** You can apply character and cell formatting to the blank lines, but you cannot enter data in them.

**Change or remove formatting**
You can choose from a wide variety of PivotTable styles in the gallery. In addition, you can control the banding behavior of a report. Changing the number format of a field is a quick way to apply a consistent format throughout a report. You can also add or remove banding (alternating a darker and lighter background) of rows and columns. Banding can make it easier to read and scan data.

**Apply a style to format a PivotTable report**
You can quickly change the look and format of a PivotTable report by using one of numerous predefined PivotTable styles (or quick styles).

1) Click anywhere in the PivotTable report.
   a) This displays the **PivotTable Tools**, adding an **Options** tab and a **Design** tab.
2) On the **Design** tab, in the **PivotTable Styles** group, do any of the following:
   a) Click a visible PivotTable style or scroll through the gallery to see additional styles.
   b) To see all of the available styles, click the **More** button at the bottom of the scroll bar.
   c) If you want to create your own custom PivotTable report style, click **New PivotTable Style** at the bottom of the gallery to display the **New PivotTable Style** dialog box.

**Apply banding to change the format of a PivotTable report**

1) Click anywhere in the PivotTable report.
   a) This displays the **PivotTable Tools**, adding an **Options** tab and a **Design** tab.
2) On the **Design** tab, in the **PivotTable Style Options** group, do one of the following:
   a) To alternate each row with a lighter and darker color format, click **Banded Rows.**
   b) To alternate each column with a lighter and darker color format, click **Banded Columns.**
   c) To include row headers in the banding style, click **Row Headers.**
   d) To include column headers in the banding style, click **Column Headers.**
Remove a style or banding format from a PivotTable report

1) Click anywhere in the PivotTable report.
   a) This displays the PivotTable Tools, adding an Options tab and a Design tab.
2) On the Design tab, in the PivotTable Styles group, click the More button at the bottom of the scroll bar to see all of the available styles, and then click Clear at the bottom of the gallery.

Change the number format for a field

1) In the PivotTable report, select the field of interest.
   a) This displays the PivotTable Tools, adding an Options tab and a Design tab.
2) On the Options tab in the Active Field group, click Field Settings.
   a) The Field Settings dialog box displays labels and report filters; the Values Field Settings dialog box displays values.
3) Click Number Format at the bottom of the dialog box.
4) In the Format Cells dialog box, in the Category list, click the number format that you want to use.
5) Select the options that you prefer, and then click OK twice.
   Tip: You can also right-click a value field, and then click Number Format.
**Group items in a PivotTable report**

In the row and column label areas of a PivotTable report, you can group the items in a field in a custom way. Grouping the data can help you to isolate a subset of data that satisfies your specific needs, and that cannot be easily grouped in other ways, such as sorting and filtering. To isolate a subset of items for more refined analysis of your data, you can group numeric, date, and time fields, and even a selection of specific items. The following are common examples of grouping items:

**Example of grouping by date items**

1. Before grouping, the orders for each salesperson are listed by date.
2. After grouping, the orders are grouped and summarized by month for easier analysis and display.

**Example of grouping by numeric items**

1. Before grouping, the orders for each salesperson are listed by the order number.
2. After grouping, the orders are grouped and summarized in ranges of 100 orders for easier analysis and display.

**Example of grouping by selected items**

1. Before grouping, the salespersons in each country are listed.
2. After grouping, the salespersons are now grouped by the top two in sales and the bottom in sales in each country for easier analysis and display.

When you group items by selection, you create a new field based on the field whose items you are grouping. For example when you group the SalesPerson field by specific names, you create a new field SalesPerson1 that is added to the PivotTable Field List. You can work with this new field in many ways, for example, move it to different areas of the PivotTable report, rearrange it with other fields in an area, rename the field by using the Field Settings dialog box, and filter the field it is based on by using the new group name and values.

**Note:** You cannot add a calculated item to a grouped field. You must first ungroup the items, add the calculated item, and then regroup the items.
Group numbers in numeric fields

1) In the PivotTable report, do one of the following:
   a) Click any number in the numeric field that you want to group, and then on the Options tab, in the Group group, click Group Field.
   b) Right-click any number in the numeric field that you want to group, and then click Group.

2) In the Starting at box, enter the smallest number to group by.
   a) This clears the Starting at check box. To quickly return to the default start number, select the check box.

3) In the Ending at box, enter the highest number to group by.
   a) This clears the Ending at check box. To quickly return to the default end number, select the check box.
   
   Note: The end number must be greater than the start number.

4) In the By box, enter the number that represents the size of the interval included in each group.

Group dates or times

1) In the PivotTable report, do one of the following:
   a) Click any date or time in the date or time field, and then on the Options tab, in the Group group, click Group Field.
   b) Right-click any number in the numeric field that you want to group, and then click Group.

2) In the Starting at box, enter the first date or time to group by.
   a) This clears the Starting at check box. Selecting the check box does not return to the default date or time.

3) In the Ending at box, enter the last date or time to group by.
   a) This clears the Ending at check box. Selecting the check box does not return to the default date or time.

   Note: The end date or time must be later than the start date or time.

4) In the By box, click one or more date or time periods for the groups. Group by Months is selected by default, but you can click it to deselect it.
   a) To group items by weeks, in the By box, make sure that Days is the only time period selected, and then in the Number of days box, click 7. You can then click additional time periods to group by, such as Months.
   b) Date and time groups are labeled in the PivotTable report, such as Apr for dates in the month of April. To change the group label, click the label, press F2, and then type the name that you want.
Group selected items

1) In the PivotTable report, select two or more items that you want to group together, either by clicking and dragging, or by holding down CTRL or SHIFT while you click the items.

2) On the Options tab, in the Group group, click Group Selection.
   a) Groups that are based on a selection are added to the Field List.
      • For example when you group the SalesPerson field by specific names, you create a new field SalesPerson1 that is added to the PivotTable Field List. In the PivotTable report, they display group labels, such as Group1 for the first group you create. To change a group label to something more meaningful, click the label, press F2, and then type the name that you want.

   Tip: For a more compact PivotTable report, you might want to create another group for all the other ungrouped items in the field.

   Note: For fields that are organized in levels, you can only group items that all have the same next-level item. For example, if the field has levels Country and City, you can't group cities from different countries.

Ungroup grouped items

1) In the PivotTable report, select the group of items that you want to ungroup.

2) On the Options tab, in the Group group, click Ungroup.
   a) For a numeric or date and time field, all groups for the field are ungrouped. For a group of selected items, only the selected items are ungrouped, and the group field is not removed from the PivotTable Field List until all groups for the field are removed.

Sort data in a PivotTable or a PivotChart report

Sorting data is an integral part of data analysis. You might want to put a list of names in alphabetical order or compile a list of product inventory levels from highest to lowest. Sorting data enables you to quickly visualize and understand your data better, organize and find the data that you want, and ultimately make more effective decisions.

Tip: To quickly find the top or bottom values in a set of data, such as top 10 grades or bottom 5 sales amounts, you might want to filter the data by using the Top 10 Filter dialog box or apply conditional formatting instead or in addition to sorting the data.

Learn more about sorting

To help you locate the data that you want to analyze in a PivotTable or PivotChart more easily, you can sort text entries (from A to Z or Z to A), numbers (from smallest to largest or largest to smallest), and dates and times (from oldest to newest or newest to oldest).

When sorting data in a PivotTable report, you should be aware that:

• Data such as text entries may have leading spaces that affect the sort results. For optimal sort results, you should remove any spaces before you sort the data.

• Unlike sorting data in a range of cells on a worksheet or in an Excel table, you cannot sort case-sensitive text entries.

• You cannot sort data by format, such as cell or font color, or by conditional formatting indicators, such as icon sets.
Sort row or column label data in a PivotTable report

1) In the PivotTable report, click any field in the row or column that contains the items you want to sort.

2) On the Options tab, in the Sort group, do one or more of the following:
   a) To quickly sort data in ascending or descending order, click the A to Z or Z to A buttons.
      - Text entries will be sorted from a to z or from z to a, numbers will be sorted from smallest to largest or from largest to smallest, and dates or times will be sorted from oldest to newest or newest to oldest.
   b) To customize the sort operation, click Sort and then in the Sort <Field name> dialog box, select the type of sort that you want:
   c) To return items to their original order, click Data source order. This option is only available for OLAP source data.
   d) To drag and arrange items the way that you want, click Manual.
   e) To select a field to sort by in ascending or descending sort order, select Ascending (A to Z) by or Descending (A to Z) by, and then select the field from the drop-down list.
   f) To continue customizing the sort operation, click More Options, and then in the More Sort Options dialog box, do one or more of the following:
      - To enable or disable the sort operation each time that the PivotTable report is updated, under AutoSort, select or clear the Sort automatically every time the report is updated check box.
      - To sort in a user-defined sort order by using a custom list, under First key sort order, select the custom list that you want to sort by in the drop-down list. This option is only available when the check box under AutoSort has been cleared.

(1) Microsoft Excel provides built-in, day-of-the-week, and month-of-the-year custom lists. You can also create your own custom list.

Notes
- Custom lists are enabled by default. To disable them, you can clear the Use Custom Lists when sorting check box on the Totals & Filters tab in the PivotTable Options dialog box (PivotTable Tools, Options tab, PivotTable group, Options command). Clearing this check box may improve performance when you sort large amounts of data.
- A custom list sort order is not retained when you refresh the PivotTable report.
- The Summary box displays the selection you make.

Tip: To sort data in row and column labels, you can also click the arrow ▼ on Row Labels or Column Labels, and then click the sort option that you want.
Sort data in the values area

1) In a PivotTable report or associated PivotTable of a PivotChart report, select a value field.
2) On the Options tab, in the Sort group, do one or more of the following:
   a) To sort in ascending or descending, click the A to Z or Z to A buttons.
      - Numbers are sorted smallest to largest or largest to smallest.
   b) To customize the sort operation, click Sort and then in the Sort By Value dialog box, do one or more of the following:
      - To sort numbers in ascending or descending order, under Sort options, select Smallest to Largest or Largest to Smallest.
      - To sort values vertically or horizontally, under Sort direction, select Top to bottom or Left to right.

Sort data in a PivotChart report

1) In the PivotChart, click the arrow on any Axis Fields (Categories) or Legend Fields (Series) filtering controls that are displayed in the chart, and then do one of the following:
   a) To quickly sort data in ascending or descending order, click Sort A to Z or Sort Z to A.
      - Text entries will be sorted from a to z or from z to a, numbers will be sorted from smallest to largest or from largest to smallest, and dates or times will be sorted from oldest to newest or newest to oldest.
   b) To customize the sort operation, click More Sort Options, and then in the Sort <Field name> dialog box, select the type of sort that you want:
   c) To return items to their original order, click Data source order. This option is only available for OLAP source data.
   d) To drag and arrange items the way that you want, click Manual.
   e) To select a field to sort by in ascending or descending sort order, select Ascending (A to Z) by or Descending (A to Z) by, and then select the field from the drop-down list.
   f) To continue customizing the sort operation, click More Options, and then in the More Sort Options dialog box, do one or more of the following:
      - To enable or disable the sort operation each time that the PivotTable report is updated, under AutoSort, select or clear the Sort automatically every time the report is updated check box.
      - To sort in a user-defined sort order by using a custom list, under First key sort order, select the custom list that you want to sort by in the drop-down list. This option is only available when the check box under AutoSort has been cleared.

(1) Microsoft Excel provides built-in, day-of-the-week, and month-of-the-year custom lists. You can also create your own custom list.

Filter items in a PivotTable report

Filtering enables in-depth analysis of large amounts of data in a PivotTable report. There are different ways to filter PivotTable items. You can use report filters to quickly display a subset of data, such as a product line, a time span, or a geographic region. For easy access, report filters that you add are conveniently placed above the PivotTable report.
In addition to or instead of using report filters, you can apply label, value, or date filters to filter by specific text-based labels, specific values, or a specific date and time frame that you want to analyze. You can also apply filters that instantly show the top or bottom 10 values, or that meet the criteria that you specify. If needed, you can specify filter options to determine what filters display or hide. And when you no longer need a filter applied, you can remove it.

Learn about filtering
Filtered data displays only the subset of data that meet the criteria that you specify and hides data that you do not want displayed. Unlike filtering a cell range or table, you do not need to reapply a filter. Filters are automatically reapplied every time the PivotTable is refreshed or updated.

PivotTable filters are additive, which means that each additional filter is based on the current filter and further reduces the subset of data. In a subset of data, you can create up to three types of filters at the same time: manual, label or date, and value, and they are evaluated in that order. However, if you want to allow multiple filters per field, you must turn this option on before you get started. The option is turned off by default.

Filter buttons are displayed by default. However, you can turn them on or off as needed.

When filtering in a PivotTable report, be aware that you:

- Cannot filter by color, font color, or icon set.
- Cannot filter by label, date or time, value, or top or bottom numbers if the PivotTable data source is an OLAP database that does not support the Multidimensional Expressions (MDX) expression subselect syntax.
- Can only do manual filtering in a report filter.

Specify filter options

Allow multiple filters per field
1) Click anywhere in the PivotTable report.
2) On the Options tab, in the PivotTable group, click Options.
3) In the PivotTable Options dialog box, click the Totals & Filters tab.
4) Under Filters, select or clear the Allow multiple filters per field check box to allow or prevent the use of multiple filters per field.

Display or hide field captions and filter drop downs
1) Click anywhere in the PivotTable report.
2) On the Options tab, in the PivotTable group, click Options.
3) In the PivotTable Options dialog box, click the Display tab.
4) To display or hide the field captions and filter drop downs, select or clear the Display field captions and filter drop downs check box.

Tip: You can also click the Field Headers button on the ribbon (PivotTable Tools, Options tab, Show group).
**Use a report filter to filter items**

By using a report filter, you can quickly display a different set of values in the PivotTable report. By default report filters are displayed in rows above the PivotTable, but you can display multiple report filters in columns instead. Items you select in the report filter are displayed in the PivotTable, and items that are not selected will be hidden. If you want to display report filter pages (the set of values that match the selected report filter items) on separate worksheets, you can specify that option.

**Add a report filter to the PivotTable report**

1) In the PivotTable Field List, drag the field that you want to use as a report filter to the Report Filter area.

   a) You can repeat this step to create more than one report filter. Report filters are displayed above the PivotTable report for easy access.

2) To change the order of the fields, in the Report Filter area, drag the fields to the position that you want. The order of the report filters will be reflected above the PivotTable report.

**Select items in the report filter**

1) In the PivotTable report, click the arrow in the report filter.

2) To display a check box for all items so that you can clear or select them as needed, select the Select Multiple Items check box.

3) To hide or display items in the PivotTable report, do any of the following:
   a) Clear the check boxes of items that you do not want to display in the PivotTable report.
   b) Clear the check box of (All) to clear all currently selected check boxes, and then select the check boxes of items that you want to display in the PivotTable report.
   c) Select the check box of (All) to display all items.
   d) If items have hierarchical levels, you can display or hide the lower-level items by clicking or beside a level.

4) Click OK.

5) The report filter clearly shows that items are filtered.

   a) At least one check box should be selected for this button to be enabled.

**Display report filter pages on separate worksheets**

1) Click anywhere in the PivotTable report (or the associated PivotTable report of a PivotChart report) that has one or more report filters.

2) On the Options tab, in the PivotTable group, click the arrow next to Options, and then click Show Report Filter Pages.

3) In the Show Report Filter Pages dialog box, select a report filter field, and then click OK.
Filter items manually by selecting row or column label fields

Depending of the layout of the PivotTable report, the list of row and column labels may contain text labels such as names or geographic regions, dates or times, or numbers, such as order IDs or amounts.

1) In the PivotTable report, click the arrow on Row Labels or Column Labels.

2) In the list of row or column labels, select or clear the check boxes of the labels of fields that you want to display or hide in the PivotTable report.
   a) If the list is large, clear the (Select All) check box at the top, and then select the check boxes of the fields that you want to display.

   Tip: To enlarge the Row or Column Label filter list, click and drag the sizing handle at the bottom right of the list.

3) Click OK.

4) The report filter clearly shows that items are filtered.

Filter items by applying a label filter

1) In the PivotTable report, do one of the following:
   a) Click the arrow on Row Labels or Column Labels, click Label Filters, and then click the comparison operator command that you want to use.
   b) Right-click any text field label, click Filter, and then click Label Filters. In the Label Filter <Field name> dialog box, in the Show items for which the label box, click the comparison operator command that you want to use.

   For example, to filter by text that begins with a specific character, select Begins With, or to filter by text that has specific characters anywhere in the text, select Contains.

   Note: Label Filters is not available when row label or column label fields do not contain text-based labels.

2) In the Label Filter <Field name> dialog box, in the box on the right, enter the data that you want to use as criteria in the comparison.
   a) For example, to filter by text that begins with the letter "J", enter J, or to filter by text that has "bell" anywhere in the text, enter bell.

   In a non-OLAP data source, if you need to find data that shares some characters but not others, use a wildcard character.

   **How to use wildcard characters**

   The following wildcard characters can be used as comparison criteria for text filters.

<table>
<thead>
<tr>
<th>Use</th>
<th>To find</th>
</tr>
</thead>
</table>
   | ? (question mark) | Any single character  
     For example, sm?th finds "smith" and "smyth" |
   | * (asterisk)    | Any number of characters   
     For example, *east finds "Northeast" and "Southeast" |
   | ~ (tilde) followed by ?, *, or ~ | A question mark, asterisk, or tilde   
     For example, fy06~? finds "fy06?" |
Filter items by applying a value filter

1) In the PivotTable report, do one of the following:
   a) Click the arrow ▼ on Row Labels or Column Labels, click Value Filters, and then click the
      comparison operator command that you want to use.
   b) Right-click any value field label, click Filter, and then click Value Filters. In the Value Filter <Field name> dialog box, in the Show items for which the label box, click the comparison operator command that you want to use.

2) In the Value Filter <Field name> dialog box, under Show items for which do the following:
   a) In the first box, select the field you that you want to filter.
   b) In the second box, click the comparison operator command that you want to use.
      For example, to filter by a lower and upper number limit, select Between.
   c) In the third box, enter the number that you want to use in the comparison.
      • If a comparison, such as Between, provides a fourth box, enter another number in that box.
      For example, to filter by a lower number of 25 and an upper number of 50, enter 25 and 50.

Filter items by applying a date filter

1) In the PivotTable report, do one of the following:
   a) Click the arrow ▼ on Row Labels or Column Labels, click Date Filters, and then click the
      comparison operator command or any predefined date format that you want to use.
      When you select a comparison operator such as Before or After, you create a common date filter.
      When you select a predefined date format such as Today or Next Week, you create a dynamic date filter, where the filter results can change when you reapply the filter.

   Notes:
   • The commands under the All Dates in the Period menu, such as January or Quarter 2, filter by
     the period no matter what the year. This can be useful, for example, to compare sales by a period
     across several years.
   • This Year and Year to Date are different in the way that future dates are handled. This Year can
     return dates in the future for the current year, whereas Year to Date only returns dates up to and
     including the current date.
   • Right-click any date field label, click Filter, and then click Date Filters. In the Date Filter <Field name> dialog box, in the Show items for which the label box, click the comparison operator command that you want to use.
      Note: This method does not provide dynamic date filters. You can only apply a common date filter.

2) In the Date Filter <Field name> dialog box, do the following:
   a) In the first box, verify or select a comparison operator.
      For example, to filter by a lower and upper date or time, select is between.
   b) In the second box, enter a date or time. You can also click the Calendar button to find and enter a date
      If a comparison, such as Between, provides a fourth box, enter another date or time in that box.
      For example, to filter by an earlier date of "3/1/2006" and a later date of "6/1/2006", enter 3/1/2006 and
      6/1/2006. Or, to filter by an earlier time of "8:00 AM" and a later time of "12:00 PM", enter 8:00 AM
      and 12:00 PM.
Apply a filter to display the top or bottom 10 items

1) In the PivotTable report, do one of the following:
   a) Click the arrow on Row Labels or Column Labels, click Value Filters, and then click Top 10.
   b) Right-click a value field, click Filter, and then click Top 10.
2) In the Top 10 Filter <Field Name> dialog box, do the following.
   a) In the first box, click Top or Bottom.
   b) In the second box, enter a number.
   c) In the third box, do one of the following:
      • To filter by number of items, click Items.
      • To filter by percentage, click Percent.
      • To filter by sum, click Sum.
   d) In the fourth box, select the field that you want to use from the drop-down list.

Filter by selection to display or hide selected items only

1) In a PivotTable report, select one or more items in the field that you want to filter by selection.
   a) You can make a discontinuous selection by holding down CTRL when you select items.
2) Right-click an item in the selection, and then click Filter.
3) Do one of the following:
   a) To display the selected items, click Keep Only Selected Items.
   b) To hide the selected items, click Hide Selected Items.
   Tip: You can display hidden items again by removing the filter. Right-click another item in the same field, click Filter, and then click Clear Filter.

Remove filters
To remove filtering in a PivotTable report, do one of the following:

• To remove a report filter, click the arrow in the report filter, and then select the (All) check box.
• To remove all filtering, click anywhere in the PivotTable, and then on the Options tab, in the Actions group, click Clear, and then click Clear Filters.

• To remove filtering from a row or column label field, click the arrow in the row or column label, and then click Clear Filter from <Field Name>.
• To remove a label, date, or value filter, click the arrow in the row or column label, click Label Filter, Date Filter, or Value Filter, and then click Clear Filter.

Use slicers to filter PivotTable data
In earlier versions of Microsoft Excel, you can use report filters to filter data in a PivotTable report, but it is not easy to see the current filtering state when you filter on multiple items. In Microsoft Excel 2010, you have the option to use slicers to filter the data. Slicers provide buttons that you can click to filter PivotTable data. In addition to quick filtering, slicers also indicate the current filtering state, which makes it easy to understand what exactly is shown in a filtered PivotTable report.
When you select an item, that item is included in the filter and the data for that item will be displayed in the report. For example, when you select Callahan in the Salespersons field, only data that includes Callahan in that field are displayed.

**What are slicers?**

Slicers are easy-to-use filtering components that contain a set of buttons that enable you to quickly filter the data in a PivotTable report, without the need to open drop-down lists to find the items that you want to filter.

When you use a regular PivotTable report filter to filter on multiple items, the filter indicates only that multiple items are filtered, and you have to open a drop-down list to find the filtering details. However, a slicer clearly labels the filter that is applied and provides details so that you can easily understand the data that is displayed in the filtered PivotTable report.

Slicers are typically associated with the PivotTable in which they are created. However, you can also create stand-alone slicers that are referenced from Online Analytical Processing (OLAP) Cube functions, or that can be associated with any PivotTable at a later time.

A slicer typically displays the following elements:

1. A slicer header indicates the category of the items in the slicer.
2. A filtering button that is not selected indicates that the item is not included in the filter.
3. A filtering button that is selected indicates that the item is included in the filter.
4. A **Clear Filter** button removes the filter by selecting all items in the slicer.
5. A scroll bar enables scrolling when there are more items than are currently visible in the slicer.
6. Border moving and resizing controls allow you to change the size and location of the slicer.

**Using slicers**

There are several ways to create slicers to filter your PivotTable data. In an existing PivotTable, you can:

- Create a slicer that is associated with the PivotTable.
- Create a copy of a slicer that is associated with the PivotTable.
- Use an existing slicer that is associated with another PivotTable.

In addition to or instead of creating slicers in an existing PivotTable, you can also create a stand-alone slicer that can be referenced by Online Analytical Processing (OLAP) Cube functions or that you can associate with any PivotTable at a later time.

Because each slicer that you create is designed to filter on a specific PivotTable field, it is likely that you will create more than one slicer to filter a PivotTable report.
After you create a slicer, it appears on the worksheet alongside the PivotTable, in a layered display if you have more than one slicer. You can move a slicer to another location on the worksheet, and resize it as needed.

To filter the PivotTable data, you simply click one or more of the buttons in the slicer.

Formatting slicers for a consistent look
To create professional looking reports or simply to match the format of a slicer to the format of the associated PivotTable report, you can apply slicer styles for a consistent look. By applying one of the various predefined styles that are available for slicers, you can closely match the color theme that is applied to a PivotTable. For a custom look, you can even create your own slicer styles, just as you create custom PivotTable styles.

Sharing slicers between PivotTables
When you have many different PivotTables in one report it is likely that you will want to apply the same filter to some or all of those PivotTables. You can share a slicer that you created in one PivotTable with other PivotTables. No need to duplicate the filter for each PivotTable!

When you share a slicer, you are creating a connection to another PivotTable that contains the slicer that you want to use. Any changes that you make to a shared slicer are immediately reflected in all PivotTables that are connected to that slicer.

Slicers that are connected to and used in more than one PivotTable are called shared slicers. Slicers that are used in one PivotTable only are called local slicers. A PivotTable can have both local and shared slicers.

Create a slicer in an existing PivotTable
1) Click anywhere in the PivotTable report for which you want to create a slicer.
   a) This displays the PivotTable Tools, adding an Options and a Design tab.
2) On the Options tab, in the Sort & Filter group, click Insert Slicer.
3) In the Insert Slicers dialog box, select the check box of the PivotTable fields for which you want to create a slicer.
4) Click OK.
   a) A slicer is displayed for every field that you selected.
5) In each slicer, click the items on which you want to filter.
   a) To select more than one item, hold down CTRL, and then click the items on which you want to filter.
Format a slicer
1) Click the slicer that you want to format.
   a) This displays the Slicer Tools, adding an Options tab.
2) On the Options tab, in the Slicer Styles group, click the style that you want.
3) To see all available styles, click the More button.

Share a slicer by connecting to another PivotTable
You can share a slicer with another PivotTable by connecting it to that PivotTable. You can also insert a slicer from another PivotTable by connecting to that PivotTable.

Make a slicer available for use in another PivotTable
1) Click the slicer that you want to share in another PivotTable.
   a) This displays the Slicer Tools, adding an Options tab.
2) On the Options tab, in the Slicer group, click PivotTable Connections.
3) In the PivotTable Connections dialog box, select the check box of the PivotTables in which you want the slicer to be available.

Use a slicer from another PivotTable
1) Click anywhere in the PivotTable report for which you want to insert a slicer from another PivotTable.
   a) This displays the PivotTable Tools, adding an Options and a Design tab.
2) On the Options tab, in the Sort & Filter group, click the Insert Slicer arrow, and then click Slicer Connections.
3) In the Slicer Connections dialog box, select the check box of the slicers that you want to use.
4) Click OK.
5) In each slicer, click the items on which you want to filter.
   a) To select more than one item, hold down CTRL, and then click the items that you want to filter.
      Note: All PivotTables that share the slicer will instantly display the same filtering state.

Disconnect or delete a slicer
If you no longer need a slicer, you can disconnect it from the PivotTable report, or you can delete it.

Disconnect a slicer
1) Click anywhere in the PivotTable report for which you want to disconnect a slicer.
   a) This displays the PivotTable Tools, adding an Options and a Design tab.
2) On the Options tab, in the Sort & Filter group, click the Insert Slicer arrow, and then click Slicer Connections.
3) In the Slicer Connections dialog box, clear the check box of any PivotTable fields for which you want to disconnect a slicer.
Delete a slicer
Do one of the following:
- Click the slicer, and then press DELETE.
- Right-click the slicer, and then click Remove <Name of slicer>.

Calculate values in a PivotTable report
In PivotTable, you can use summary functions in value fields to combine values from the underlying source data. If summary functions and custom calculations do not provide the results that you want, you can create your own formulas in calculated fields and calculated items. For example, you could add a calculated item with the formula for the sales commission, which could be different for each region. The PivotTable report would then automatically include the commission in the subtotals and grand totals.

Available calculation methods
To calculate values in a PivotTable report, you can use any or all of the following types of calculation methods:

Summary functions in value fields: The data in the values area summarize the underlying source data in the PivotTable report. For example, the source data on the right:

- Produces the following PivotTable and PivotChart reports. If you create a PivotChart report from the data in a PivotTable report, the values in that PivotChart report reflect the calculations in the associated PivotTable report.

<table>
<thead>
<tr>
<th>Region</th>
<th>Month</th>
<th>Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>South</td>
<td>May</td>
<td>8677</td>
</tr>
<tr>
<td>South</td>
<td>Apr</td>
<td>450</td>
</tr>
<tr>
<td>North</td>
<td>Apr</td>
<td>1500</td>
</tr>
<tr>
<td>South</td>
<td>May</td>
<td>3802</td>
</tr>
<tr>
<td>East</td>
<td>Mar</td>
<td>2741</td>
</tr>
<tr>
<td>North</td>
<td>Apr</td>
<td>9291</td>
</tr>
<tr>
<td>West</td>
<td>May</td>
<td>5477</td>
</tr>
<tr>
<td>East</td>
<td>May</td>
<td>5416</td>
</tr>
<tr>
<td>East</td>
<td>Apr</td>
<td>9136</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Region</th>
<th>Month</th>
<th>Sum of Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>North</td>
<td>May</td>
<td>12720</td>
</tr>
<tr>
<td>South</td>
<td>May</td>
<td>13047</td>
</tr>
<tr>
<td>East</td>
<td>Mar</td>
<td>11075</td>
</tr>
<tr>
<td>West</td>
<td>May</td>
<td>18900</td>
</tr>
<tr>
<td>Grand Total</td>
<td></td>
<td>56092</td>
</tr>
</tbody>
</table>

Functions that you can use as a subtotal

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>The sum of the values. This is the default function for numeric data.</td>
<td></td>
</tr>
<tr>
<td>Count</td>
<td>The number of data values. The Count summary function works the same as the COUNTA function. Count is the default function for data other than numbers.</td>
<td></td>
</tr>
<tr>
<td>Average</td>
<td>The average of the values.</td>
<td></td>
</tr>
<tr>
<td>Max</td>
<td>The largest value.</td>
<td></td>
</tr>
<tr>
<td>Function</td>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
<td></td>
</tr>
<tr>
<td>Min</td>
<td>The smallest value.</td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>The product of the values.</td>
<td></td>
</tr>
<tr>
<td>Count Numbers</td>
<td>The number of data values that are numbers. The Count Numbers summary function works the same as the worksheet COUNT function.</td>
<td></td>
</tr>
<tr>
<td>StDev</td>
<td>An estimate of the standard deviation of a population, where the sample is a subset of the entire population.</td>
<td></td>
</tr>
<tr>
<td>StDevp</td>
<td>The standard deviation of a population, where the population is all of the data to be summarized.</td>
<td></td>
</tr>
<tr>
<td>Var</td>
<td>An estimate of the variance of a population, where the sample is a subset of the entire population.</td>
<td></td>
</tr>
<tr>
<td>Varp</td>
<td>The variance of a population, where the population is all of the data to be summarized.</td>
<td></td>
</tr>
</tbody>
</table>

**Custom calculations**: A custom calculation shows values based on other items or cells in the data area. For example, you could display values in the **Sum of Sales** data field as a percentage of **March** sales, or as a running total of the items in the **Month** field.

**Functions available for custom calculations in value fields.**

<table>
<thead>
<tr>
<th>Calculation option</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Calculation</td>
<td>Displays the value that is entered in the field.</td>
</tr>
<tr>
<td>% of Grand Total</td>
<td>Displays values as a percentage of the grand total of all the values or data points in the report.</td>
</tr>
<tr>
<td>% of Column Total</td>
<td>Displays all the values in each column or series as a percentage of the total for the column or series.</td>
</tr>
<tr>
<td>% of Row Total</td>
<td>Displays the value in each row or category as a percentage of the total for the row or category.</td>
</tr>
<tr>
<td>% Of</td>
<td>Displays values as a percentage of the value of the Base item in the Base field.</td>
</tr>
<tr>
<td>% of Parent Row Total</td>
<td>Calculates values as follows:</td>
</tr>
<tr>
<td></td>
<td>(value for the item) / (value for the parent item on rows)</td>
</tr>
<tr>
<td>% of Parent Column Total</td>
<td>Calculates values as follows:</td>
</tr>
<tr>
<td></td>
<td>(value for the item) / (value for the parent item on columns)</td>
</tr>
<tr>
<td>% of Parent Total</td>
<td>Calculates values as follows:</td>
</tr>
<tr>
<td>Calculation option</td>
<td>Result</td>
</tr>
<tr>
<td>----------------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>(value for the item) / (value for the parent item of the selected Base field)</td>
</tr>
<tr>
<td>Difference From</td>
<td>Displays values as the difference from the value of the Base item in the Base field.</td>
</tr>
<tr>
<td>% Difference From</td>
<td>Displays values as the percentage difference from the value of the Base item in the Base field.</td>
</tr>
<tr>
<td>Running Total in</td>
<td>Displays the value for successive items in the Base field as a running total.</td>
</tr>
<tr>
<td>% Running Total in</td>
<td>Calculates the value as a percentage for successive items in the Base field that are displayed as a running total.</td>
</tr>
<tr>
<td>Rank Smallest to Largest</td>
<td>Displays the rank of selected values in a specific field, listing the smallest item in the field as 1, and each larger value with a higher rank value.</td>
</tr>
<tr>
<td>Rank Largest to Smallest</td>
<td>Displays the rank of selected values in a specific field, listing the largest item in the field as 1, and each smaller value with a higher rank value.</td>
</tr>
<tr>
<td>Index</td>
<td>Calculates values as follows:</td>
</tr>
<tr>
<td></td>
<td>((value in cell) x (Grand Total of Grand Totals)) / ((Grand Row Total) x (Grand Column Total))</td>
</tr>
</tbody>
</table>

**Formulas:** If summary functions and custom calculations do not provide the results that you want, you can create your own formulas in calculated fields and calculated items. For example, you could add a calculated item with the formula for the sales commission, which could be different for each region. The report would then automatically include the commission in the subtotals and grand totals.

**How the type of source data affects calculations**

Calculations and options that are available in a report depend on whether the source data came from an OLAP database or a non-OLAP data source.

- **Calculations based on OLAP source data:** For PivotTable reports that are created from OLAP cubes, the summarized values are precalculated on the OLAP server before Excel displays the results. You cannot change how these precalculated values are calculated in the PivotTable report. For example, you cannot change the summary function that is used to calculate data fields or subtotals, or add calculated fields or calculated items.

  Also, if the OLAP server provides calculated fields, known as calculated members, you will see these fields in the PivotTable Field List. You will also see any calculated fields and calculated items that are created by macros that were written in Visual Basic for Applications (VBA) and stored in your workbook, but you won't be able to change these fields or items. If you need additional types of calculations, contact your OLAP database administrator.

  For OLAP source data, you can include or exclude the values for hidden items when calculating subtotals and grand totals.
• **Calculations based on non-OLAP source data:** In PivotTable reports that are based on other types of external data or on worksheet data, Excel uses the Sum summary function to calculate value fields that contain numeric data, and the Count summary function to calculate data fields that contain text. You can choose a different summary function, such as, Average, Max, or Min, to further analyze and customize your data. You can also create your own formulas that use elements of the report or other worksheet data by creating a calculated field or a calculated item within a field.

**Using formulas in PivotTable reports**

You can create formulas only in reports that are based on a non-OLAP source data. You cannot use formulas in reports that are based on an OLAP database. When you use formulas in PivotTable reports, you should know about the following formula syntax rules and formula behavior:

• **PivotTable formula elements:** In formulas that you create for calculated fields and calculated items, you can use operators and expressions as you do in other worksheet formulas. You can use constants and refer to data from the report, but you cannot use cell references or defined names. You cannot use worksheet functions that require cell references or defined names as arguments, and you cannot use array functions.

• **Field and item names:** Excel uses field and item names to identify those elements of a report in your formulas. In the example, the data in range C3:C9 is using the field name Dairy. A calculated item in the Type field that estimates sales for a new product based on Dairy sales could use a formula such as =Dairy * 115%.

• **Formulas operate on sum totals, not individual records:** Formulas for calculated fields operate on the sum of the underlying data for any fields in the formula. For example, the calculated field formula =Sales * 1.2 multiplies the sum of the sales for each type and region by 1.2; it does not multiply each individual sale by 1.2 and then sum the multiplied amounts.

Formulas for calculated items operate on the individual records. For example, the calculated item formula =Dairy * 115% multiplies each individual sale of Dairy times 115%, after which the multiplied amounts are summarized together in the Values area.

• **Spaces, numbers, and symbols in names:** In a name that includes more than one field, the fields can be in any order. In the previous example, cells C6:D6 can be 'April North' or 'North April'. Use single quotation marks around names that are more than one word or that include numbers or symbols.

• **Totals:** Formulas cannot refer to totals (such as, March Total, April Total, and Grand Total in the example).

• **Field names in item references:** You can include the field name in a reference to an item. The item name must be in square brackets — for example, Region[North]. Use this format to avoid #NAME? errors when two items in two different fields in a report have the same name. For example, if a report has an item named Meat in the Type field and another item named Meat in the Category field, you can prevent #NAME? errors by referring to the items as Type[Meat] and Category[Meat].

• **Referring to items by position:** You can refer to an item by its position in the report as currently sorted and displayed. Type[1] is Dairy, and Type[2] is Seafood. The item referred to in this way can change whenever the positions of items change or different items are displayed or hidden. Hidden items are not counted in this index.
You can use relative positions to refer to items. The positions are determined relative to the calculated item that contains the formula. If South is the current region, Region[-1] is North; if North is the current region, Region[+1] is South. For example, a calculated item could use the formula =Region[-1] * 3%. If the position that you give is before the first item or after the last item in the field, the formula results in a #REF! error.

Create formulas in a PivotTable report
Important: You cannot create formulas in a PivotTable report that is connected to an Online Analytical Processing (OLAP) data source.

Before you start, decide whether you want a calculated field or a calculated item within a field. Use a calculated field when you want to use the data from another field in your formula. Use a calculated item when you want your formula to use data from one or more specific items within a field.

For calculated items, you can enter different formulas cell by cell. For example, if a calculated item named OrangeCounty has a formula of =Oranges * .25 across all months, you can change the formula to =Oranges * .5 for June, July, and August.

If you have multiple calculated items or formulas, you can adjust the order of calculation.

Add a calculated field
1) Click the PivotTable report.
   a) This displays the PivotTable Tools, adding the Options and Design tabs.
2) On the Options tab, in the Calculations group, click Fields, Items, & Sets, and then click Calculated Field.
3) In the Name box, type a name for the field.
4) In the Formula box, enter the formula for the field.
   a) To use the data from another field in the formula, click the field in the Fields box, and then click Insert Field. For example, to calculate a 15% commission on each value in the Sales field, you could enter =Sales * 15%.
5) Click Add.

Add a calculated item to a field
1) Click the PivotTable report.
   a) This displays the PivotTable Tools, adding the Options and Design tabs.
2) If items in the field are grouped, on the Options tab, in the Group group, click Ungroup.
3) Click the field where you want to add the calculated item.
4) On the Options tab, in the Calculations group, click Fields, Items, & Sets, and then click Calculated Item.
5) In the Name box, type a name for the calculated item.
6) In the Formula box, enter the formula for the item.
   a) To use the data from an item in the formula, click the item in the Items list, and then click Insert Item (the item must be from the same field as the calculated item).
7) Click Add.
Enter different formulas cell by cell for calculated items
1) Click a cell for which you want to change the formula.
   a) To change the formula for several cells, hold down CTRL and click the additional cells.
2) In the formula bar, type the changes to the formula.

Adjust the order of calculation for multiple calculated items or formulas
1) Click the PivotTable report.
   a) This displays the PivotTable Tools, adding the Options and Design tabs.
2) On the Options tab, in the Calculations group, click Fields, Items, & Sets, and then click Solve Order.
3) Click a formula, and then click Move Up or Move Down.
4) Continue until the formulas are in the order that you want them to be calculated.

Edit a PivotTable formula
Before you edit a formula, determine whether that formula is in a calculated field or a calculated item. If the formula is in a calculated item, also determine whether the formula is the only one for the calculated item.

Determine whether a formula is in a calculated field or a calculated item
1) Click the PivotTable report.
   a) This displays the PivotTable Tools, adding the Options and Design tabs.
2) On the Options tab, in the Calculations group, click Fields, Items, & Sets, and then click List Formulas.
3) In the list of formulas, find the formula that you want to change listed under Calculated Field or Calculated Item.
   a) When there are multiple formulas for a calculated item, the default formula that was entered when the item was created has the calculated item name in column B. For additional formulas for a calculated item, column B contains both the calculated item name and the names of intersecting items.
      • For example, you might have a default formula for a calculated item named MyItem, and another formula for this item identified as MyItem January Sales. In the PivotTable report, you would find this formula in the Sales cell for the MyItem row and January column.
4) Continue by using one of the following editing methods.

Edit a calculated field formula
1) Click the PivotTable report.
   a) This displays the PivotTable Tools, adding the Options and Design tabs.
2) On the Options tab, in the Calculations group, click Fields, Items, & Sets, and then click Calculated Field.
3) In the Name box, select the calculated field for which you want to change the formula.
4) In the Formula box, edit the formula.
5) Click Modify.
**Edit a single formula for a calculated item**

1) Click the field that contains the calculated item.
2) On the **Options** tab, in the **Calculations** group, click **Fields, Items, & Sets**, and then click **Calculated Item**.
3) In the **Name** box, select the calculated item.
4) In the **Formula** box, edit the formula.
5) Click **Modify**.

**Edit an individual formula for a specific cell of a calculated item**

1) Click a cell for which you want to change the formula.
   a) To change the formula for several cells, hold down CTRL and click the additional cells.
2) In the formula bar, type the changes to the formula.
   **Tip:** If you have multiple calculated items or formulas, you can adjust the order of calculation.

**Delete a PivotTable formula**

**Note:** Deleting a PivotTable formula removes it permanently. If you do not want to remove a formula permanently, you can hide the field or item instead by dragging it out of the PivotTable report.

1) Determine whether the formula is in a calculated field or a calculated item.
   a) Calculated fields appear in the PivotTable Field List. Calculated items appear as items within other fields.
2) Do one of the following:
   a) To delete a calculated field, click anywhere in the PivotTable report.
   b) To delete a calculated item, in the PivotTable, click the field that contains the item that you want to delete.
      - This displays the PivotTable Tools, adding the **Options** and **Design** tabs.
3) On the **Options** tab, in the **Calculations** group, click **Fields, Items, & Sets**, and then click **Calculated Field** or **Calculated Item**.
4) In the **Name** box, select the field or item that you want to delete.
5) Click **Delete**.

**View all formulas that are used in a PivotTable report**

You can display a list of all the formulas that are used in the current PivotTable report.

1) Click the PivotTable report.
   a) This displays the PivotTable Tools, adding the **Options** and **Design** tabs.
2) On the **Options** tab, in the **Calculations** group, click **Fields, Items, & Sets**, and then click **List Formulas**.
Subtotal and total fields in a PivotTable report
When working with a PivotTable report, you can display or hide subtotals for individual column and row fields, display or hide column and row grand totals for the entire report, and calculate the subtotals and grand totals with or without filtered items.

Subtotal row and column fields
1) In a PivotTable, select an item of a row or column field.
   a) This displays the PivotTable Tools, adding the Options and Design tabs.
2) On the Options tab, in the Active Field group, click Field Settings.
3) In the Field Settings dialog box, under Subtotals, do one of the following:
   a) To subtotal an outer row or column label using the default summary function, click Automatic.
   b) To use a different function, to display more than one type of subtotal, or to subtotal an inner row or column label, click Custom (if this option is available), and then select a function.
   Note: You cannot use a custom function that uses an Online Analytical Processing (OLAP) data source.
   c) To remove subtotals, click None.
      Note: If a field contains a calculated item, you can't change the subtotal summary function.
   d) To include or exclude new items when applying a filter in which you have selected specific items in the Filter menu, select or clear the Include new items in manual filter check box.

Tips
- To quickly display or hide the current subtotal, right-click the item of the field, and then select or clear the check box next to Subtotal "<Label name>".
- For outer row labels in compact or outline form, you can display subtotals above or below their items, or hide the subtotals, by doing the following:
  1) On the Design tab, in the Layout group, click Subtotals.
  2) Do one of the following:
     a) Select Do Not Show Subtotals.
     b) Select Show all Subtotals at Bottom of Group.
     c) Select Show all Subtotals at Top of Group.

Display or hide grand totals for the entire report
You can display or hide the grand totals for the current PivotTable. You can also specify default settings for displaying and hiding grand totals

Display or hide grand totals
1) Click anywhere in the PivotTable report.
   a) This displays the PivotTable Tools, adding the Options and Design tabs.
2) On the Design tab, in the Layout group, click Grand Totals, and then select the grand total display option that you want.
Change the default behavior for displaying or hiding grand totals

1) Click the PivotTable report.
   a) This displays the PivotTable Tools, adding the Options and Design tabs.
2) On the Options tab, in the PivotTable group, click Options.
3) In the PivotTable Options dialog box, on the Totals & Filters tab, do one of the following:
   a) To display grand totals, select the Show grand totals for columns check box, the Show grand totals for rows check box, or both.
   b) To hide grand totals, clear the Show grand totals for columns check box, the Show grand totals for rows check box, or both.

Calculate the subtotals and grand totals with or without filtered items

1) Click anywhere in the PivotTable report.
   a) This displays the PivotTable Tools, adding the Options and Design tabs.
2) On the Options tab, in the PivotTable group, click Options.
3) In the PivotTable Options dialog box, on the Total & Filters tab, do one of the following:
   a) For Online Analytical Processing (OLAP) source data, do one of the following:
      - Select or clear the Subtotal filtered page items check box to include or exclude report filter items.
        Note: The OLAP data source must support the MDX expression subselect syntax.
      - Select or clear the Mark totals with * check box to display or hide an asterisk next to totals. The asterisk indicates that the visible values that are displayed and that are used when Excel calculates the total are not the only values that are used in the calculation.
        Note: This option is only available if the OLAP data source does not support the MDX expression subselect syntax.
   b) For non-OLAP source data, select or clear the Allow multiple filters per field check box to include or exclude filtered items in totals.
Show different calculations in PivotTable value fields

Instead of writing your own formulas in calculated fields, you can use Show Values As to quickly present values in different ways. Show Values As is not a new feature but in Excel 2010, it’s much easier to find and use. It also provides several new calculation options, such as % of Parent Total or % Running Total In.

Tip: You can use this feature to try different calculations in a value field. However, because you can add the same value fields to a PivotTable more than once, you can also use this feature to show the actual value and other calculations, such as a running total calculation, side by side.

1) To add two or more of the same value fields to the PivotTable so that you can display different calculations in addition to the actual value of a specific field, do the following:
   a) In the Field List, drag the value field that you want to add to the Values area that already contains that value field, and then place it right below that field.

   Note: The value field is added to the PivotTable and a version number is appended to its field name. You can edit the field name as needed.

   b) Repeat step 1 until you have displayed all the value fields you want to calculate by using Show Values As.

2) In the PivotTable, do one of the following:
   a) Click the value field that you want to calculate by using Show Values As. Continue with step 3.
   b) Right-click the value field, and then click Show Values As. Continue with step 4.

3) On the Options tab, in the Calculations group, click Show Values As.

4) Click the calculation option that you want to use.