Excel 2011: Data Validation

Table of Contents

OVERVIEW OF DATA VALIDATION .............................................................................................................. 1
WHEN IS DATA VALIDATION USEFUL? ........................................................................................................... 2
DATA VALIDATION MESSAGES ......................................................................................................................... 2
TIPS FOR WORKING WITH DATA VALIDATION .................................................................................................. 3
HOW TO HANDLE A DATA VALIDATION ALERT ............................................................................................... 4

ADD DATA VALIDATION TO A CELL OR RANGE ................................................................................................. 4
TIPS ........................................................................................................................................................................ 4
Data Validation command is not available ............................................................................................................ 4
Data Validation Styles........................................................................................................................................... 5

RESTRICT DATA ENTRY TO VALUES IN A DROP-DOWN LIST ............................................................................. 5
Create a drop-down list from a range of cells ...................................................................................................... 6
Edit an existing drop-down list ............................................................................................................................. 7
Add or remove items from a drop-down list that is based on a range of cells ..................................................... 7
Add or remove items from a drop-down list that is based on a named range ..................................................... 7

RESTRICT DATA ENTRY TO A WHOLE NUMBER WITHIN LIMITS .................................................................... 8
Restrict data entry to a decimal number within limits ......................................................................................... 8

RESTRICT DATA ENTRY TO A DATE WITHIN A TIME FRAME ........................................................................... 9
Restrict data entry to a time within a time frame ................................................................................................. 10

RESTRICT DATA ENTRY TO TEXT OF A SPECIFIED LENGTH ....................................................................... 11

REMOVE DATA VALIDATION ............................................................................................................................ 11

COPY DATA VALIDATION SETTINGS ................................................................................................................ 12

DISPLAY OR HIDE CIRCLES AROUND INVALID DATA ..................................................................................... 12
CIRCLE INVALID CELLS ....................................................................................................................................... 12
HIDE VALIDATION CIRCLES ................................................................................................................................. 12

Overview of data validation

You use data validation to control the type of data or the values that users enter into a cell. For example, you may want to restrict data entry to a certain range of dates, limit choices by using a list, or make sure that only positive whole numbers are entered. This handout describes how data validation works in Excel and outlines the different data validation techniques available to you.

Data validation is an Excel feature that you can use to define restrictions on what data can or should be entered in a cell. You can configure data validation to prevent users from entering data that is not valid. If you prefer, you can allow users to enter invalid data but warn them when they try to type it in the cell. You can also provide messages to define what input you expect for the cell, and instructions to help users correct any errors. For example, in a marketing workbook, you can set up a cell to allow only account numbers that are exactly three characters long. When users select the cell, you can show them a message like the one in the illustration.

---

Employee Costs

<table>
<thead>
<tr>
<th>5</th>
<th>110 Payroll</th>
</tr>
</thead>
<tbody>
<tr>
<td>6</td>
<td>120 IRS/PITC/VA comp/state/SDI</td>
</tr>
<tr>
<td>7</td>
<td>140 Retirement Plan</td>
</tr>
</tbody>
</table>

Account Number

Enter a three-digit account number from the chart of accounts, which you can find at http://Finance/doctype on the intranet.
Data validation options are located on the **Data** tab, in the **Data Tools** group.

You configure data validation in the **Data Validation** dialog box.

---

**When is data validation useful?**

Data validation is invaluable when you want to share a workbook with others in your organization, and you want the data entered in the workbook to be accurate and consistent.

Among other things, you can use data validation to do the following:

- Restrict data to predefined items in a list
- Restrict numbers outside a specified range
- Restrict dates outside a certain time frame
- Restrict times outside a certain time frame
- Limit the number of text characters
- Validate data based on formulas or values in other cells

**Data validation messages**

What users see when they enter invalid data into a cell depends on how you have configured the data validation. You can choose to show an *input message* when the user selects the cell. Input messages are generally used to offer users guidance about the type of data that you want entered in the cell. This type of message appears near the cell. You can move this message, if you want to, and it remains until you move to another cell or press ESC.

Input messages are generally used to offer users guidance about the type of data that you want entered in the cell.

You can also choose to show an *error alert* that appears only after users enter invalid data.

You can customize the text that users see in an error alert message. If you choose not to do so, users see a default message.
You can choose from three types of error alerts:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Type</th>
<th>Use to</th>
</tr>
</thead>
<tbody>
<tr>
<td>✗</td>
<td>Stop</td>
<td>Prevent users from entering invalid data in a cell. A Stop alert message has two options: Retry or Cancel.</td>
</tr>
<tr>
<td>🚨</td>
<td>Warning</td>
<td>Warn users that the data they entered is invalid, without preventing them from entering it. When a Warning alert message appears, users can click Yes to accept the invalid entry, No to edit the invalid entry, or Cancel to remove the invalid entry.</td>
</tr>
<tr>
<td>📩</td>
<td>Information</td>
<td>Inform users that the data they entered is invalid, without preventing them from entering it. This type of error alert is the most flexible. When an Information alert message appears, users can click OK to accept the invalid value or Cancel to reject it.</td>
</tr>
</tbody>
</table>

Input messages and error alerts appear only when data is typed directly into the cells. They do not appear under the following conditions:

- **Users are not copying or filling data**: Data validation is designed to show messages and prevent invalid entries only when users type data directly in a cell. When data is copied or filled, the messages do not appear. To prevent users from copying and filling data by dragging and dropping cells, clear the Enable fill handle and cell drag-and-drop check box (Excel Options dialog box, Advanced options), and then protect the worksheet.

- **Manual recalculation is turned off**: If manual recalculation is turned on, uncalculated cells can prevent data from being validated correctly. To turn off manual recalculation, on the Formulas tab, in the Calculation group, click Calculation Options, and then click Automatic.

- **Formulas are error free**: Make sure that formulas in validated cells do not cause errors, such as #REF! or #DIV/0!. Excel ignores the data validation until you correct the error.

- **Cells referenced in formulas are correct**: If a referenced cell changes so that a formula in a validated cell calculates an invalid result, the validation message for the cell won’t appear.

**Tips for working with data validation**

In the following list, you will find tips and tricks for working with data validation in Excel.

- If you plan to protect the worksheet or workbook, protect it after you have finished specifying any validation settings. Make sure that you unlock any validated cells before you protect the worksheet. Otherwise, users will not be able to type any data in the cells.

- If you plan to share the workbook, share it only after you have finished specifying data validation and protection settings. After you share a workbook, you won't be able to change the validation settings unless you stop sharing. However, Excel will continue to validate the cells that you have designated while the workbook is being shared.
You can apply data validation to cells that already have data entered in them. However, Excel does not automatically notify you that the existing cells contain invalid data. In this scenario, you can highlight invalid data by instructing Excel to circle it on the worksheet. Once you have identified the invalid data, you can hide the circles again. If you correct an invalid entry, the circle disappears automatically.

To quickly remove data validation for a cell, select it, and then open the Data Validation dialog box (Data tab, Data Tools group). On the Settings tab, click Clear All.

To find the cells on the worksheet that have data validation, on the Home tab, in the Editing group, click Find & Select, and then click Data Validation. After you have found the cells that have data validation, you can change, copy, or remove validation settings.

When creating a drop-down list, you can use the Define Name command (Formulas tab, Defined Names group) to define a name for the range that contains the list. After you create the list on another worksheet, you can hide the worksheet that contains the list and then protect the workbook so that users won’t have access to the list.

How to handle a data validation alert
When you try to enter or change data in a worksheet cell, you see a data validation error alert. This alert signifies that the owner of the workbook applied data validation to the cell to prevent users from entering invalid data, and implemented the error alert to let you know that the data you entered is invalid.

You can enter only valid data in cells that have data validation applied. If you are not clear about the validity of the data that you can enter, you should contact the owner of the workbook.

If you inherited the workbook, you can modify or remove the data validation unless the worksheet is protected with a password that you do not know. If possible, you can contact the previous owner to help you unprotect the worksheet. You can also copy the data to another worksheet, and then remove the data validation.

Add data validation to a cell or range
Tips
You use the Data Validation command, found under the Data tab, in the Data Tools group of the Ribbon to apply validation to cells.

Data Validation command is not available
If the Data Validation command is unavailable, check the following:
• An Excel table might be linked to a SharePoint site: You cannot add data validation to an Excel table that is linked to a SharePoint site. To add data validation, you must unlink the Excel table or convert the Excel table to a range.
• You might currently be entering data: The Data Validation command is not available on the Data tab while you are entering data in a cell. To finish entering data, press ENTER or ESC.
• The worksheet might be protected or shared: You cannot change data validation settings if your workbook is shared or protected.
**Data Validation Styles**
For each type of validation you apply to cells, you can choose one of three ways (styles) to handle invalid data entry:

- To display an information message that does not prevent entry of invalid data, select **Information**.
- To display a warning message that does not prevent entry of invalid data, select **Warning**.
- To prevent entry of invalid data, select **Stop**.

**Restrict data entry to values in a drop-down list**
It is not possible to change the font or font size for items in a list.

1) Select one or more cells to validate.
2) On the **Data** tab, in the **Data Tools** group, click **Data Validation**.
3) In the **Data Validation** dialog box, click the **Settings** tab.
4) In the **Allow** box, select **List**.
5) Click the **Source** box and then type the list values separated commas.
   a) For example:
      - To limit entry to a question, such as "Do you have children?", to two choices, type **Yes, No**
      - To limit a vendor's quality reputation to three ratings, type **Low, Average, High**
      - You can also create the list entries by referring to a range of cells elsewhere in the workbook.
      **Note:** The width of the drop-down list is determined by the width of the cell that has the data validation. You might need to adjust the width of that cell to prevent truncating the width of valid entries that are wider than the width of the drop-down list.

6) Make sure that the **In-cell dropdown** check box is selected. Otherwise, you won't be able to see the drop-down arrow next to the cell.
7) To specify how you want to handle blank (null) values, select or clear the **Ignore blank** check box.
   **Note:** If your allowed values are based on a cell range that has a defined name and there is a blank cell anywhere in that range, selecting the **Ignore blank** check box allows any value to be entered in the validated cell. This is also true for any cells that are referenced by validation formulas. If any referenced cell is blank, selecting the **Ignore blank** check box allows any value to be entered in the validated cell.
8) Optionally, display an input message when the cell is clicked:
   a) Click the **Input Message** tab.
   b) Make sure the **Show input message when cell is selected** check box is selected.
   c) Fill in the title and text for the message.
9) Specify how you want Microsoft Office Excel to respond when invalid data is entered:
   a) Click the **Error Alert** tab, and make sure that the **Show error alert after invalid data is entered** check box is selected.
      **Note:** If you want to allow users to type entries that are not in the list, clear the **Show error alert after invalid data is entered** check box instead.
   b) Select one of the options for the **Style** box.
   c) Fill in the title and text for the message (up to 225 characters).
10) Click **OK**.
11) Test the data validation to make sure that it is working correctly.
   a) Try entering both valid and invalid data in the cells to make sure that your settings are working as you intended and your messages are appearing when you expect.

**Tip:** If you change the validation settings for a cell, you can automatically apply your changes to all other cells that have the same settings. To do so, open the **Data Validation** dialog box, and then select the **Apply these changes to all other cells with the same settings** check box on the **Settings** tab.

**Create a drop-down list from a range of cells**

To make data entry easier in Excel, or to limit entries to certain items that you define, you can create a drop-down list of valid entries that is compiled from cells elsewhere in the workbook. When you create a drop-down list for a cell, it displays an arrow in that cell. To enter information in that cell, click the arrow, and then click the entry that you want.

1) To create a list of valid entries for the drop-down list, type the entries in a single column or row without blank cells. For example:

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Sales</td>
</tr>
<tr>
<td>2</td>
<td>Finance</td>
</tr>
<tr>
<td>3</td>
<td>R&amp;D</td>
</tr>
<tr>
<td>4</td>
<td>IT</td>
</tr>
</tbody>
</table>

**Note:** You may want to sort the data in the order that you want it to appear in the drop-down list.

2) If you want to use another worksheet, type the list on that worksheet, and then define a name for the list.
   a) How?
      - Select the cell, range of cells, or nonadjacent selections that you want to name.
      - Click the **Name** box at the left end of the formula bar.
      - Type the name for the cells.
      - Press **ENTER**.

3) Select the cell where you want the drop-down list.
4) On the **Data** tab, in the **Data Tools** group, click **Data Validation**.
5) In the **Data Validation** dialog box, click the **Settings** tab.
6) In the **Allow** box, click **List**.
7) To specify the location of the list of valid entries, do one of the following (in both cases, make sure that the reference or name is preceded with an equal sign =):
   a) If the list is in the current worksheet, enter a reference to your list in the **Source** box or click in the **Source** box and then select your list in the current spreadsheet to populate the reference automatically.
   b) If the list is on a different worksheet, enter the name that you defined for your list in the **Source** box.
8) Make sure that the **In-cell dropdown** check box is selected.
9) To specify whether the cell can be left blank, select or clear the **Ignore blank** check box.
10) Optionally, display an input message when the cell is clicked.
11) Specify how you want Excel to respond when invalid data is entered, by doing the following:
   a) Click the Error Alert tab, and make sure that the Show error alert after invalid data is entered check box is selected.
   b) Select one of the options for the Style box.
   c) Type the title and text for the message (up to 225 characters).

Notes
- To delete a drop down list, select the cell with the list. Click the Data tab, and then in the Data Group, click Data Validation. In the Data Validation dialog box, click the Settings tab, and then click Clear All.
- The width of the drop-down list is determined by the width of the cell that has the data validation. You may need to adjust the width of that cell to prevent truncating the width of valid entries that are wider than the width of the drop-down list.
- The maximum number of entries that you can have in a drop-down list is 32,767.
- If the validation list is on another worksheet and you want to prevent users from seeing it or making changes, consider hiding and protecting that worksheet.

Edit an existing drop-down list
After you use Data Validation to create a drop-down list, you may want to edit the list. Changes you make to individual items are immediately displayed in the drop-down list. But you may also want to edit a drop-down list by adding or removing items.

Add or remove items from a drop-down list that is based on a range of cells
1) On the worksheet that contains the list of items that you used for the drop-down list, do one of the following:
   a) To add an item, go to the end of the list, and then type the name of a new item.
   b) To remove an item, select it in the list, and then press DELETE.
   Note: You may want to sort the data in the order that you want it to appear in the drop-down list.
2) On the Data tab, in the Data Tools group, click Data Validation.
3) Select the first cell that contains the drop-down list.
4) In the Data Validation dialog box, click the Settings tab.
5) On the Settings tab, in the Source box, type the cell reference of the new range.
   Tip: You can also click the Collapse Dialog Box button in the Source box, and then select your list in the current worksheet to populate the reference automatically.

Add or remove items from a drop-down list that is based on a named range
1) On the worksheet that contains the named range that you used for the drop-down list, do one of the following:
   a) To add an item, go to the end of the named range, and then type the name of a new item.
   b) To remove an item, select it in the named range, and then press DELETE.
   Note: You may want to sort the data in the order that you want it to appear in the drop-down list.
2) On the Formulas tab, in the Defined Names group, click Name Manager.
3) In the Name box, click the named range you want to update.
4) In the **Refers to** box, type the new cell reference of the named range.

   **Tip:** You can also click the **Collapse Dialog Box** button in the **Source** box, and then select the named range in the worksheet to populate the reference automatically.

**Restrict data entry to a whole number within limits**

1) Select one or more cells to validate.
2) On the **Data** tab, in the **Data Tools** group, click **Data Validation**.
3) In the **Data Validation** dialog box, click the **Settings** tab.
4) In the **Allow** box, select **Whole number**.
5) In the **Data** box, select the type of restriction that you want.
   a) For example, to set upper and lower limits, select **between**.
6) Enter the minimum, maximum, or specific value to allow. You can also enter a formula that returns a number value.

   For example, to set a minimum limit of deductions to two times the number of children in cell F1, select **greater than or equal to** in the **Data** box and enter the formula, \( =2*F1 \), in the **Minimum** box.

7) To specify how you want to handle blank (null) values, select or clear the **Ignore blank** check box.

   **Note:** If your allowed values are based on a cell range with a defined name, and there is a blank cell anywhere in the range, setting the **Ignore blank** check box allows any values to be entered in the validated cell. This is also true for any cells that are referenced by validation formulas: if any referenced cell is blank, setting the **Ignore blank** check box allows any values to be entered in the validated cell.

8) Optionally, display an input message when the cell is clicked.
   a) Click the **Input Message** tab.
   b) Make sure the **Show input message when cell is selected** check box is selected.
   c) Fill in the title and text for the message.

9) Specify how you want Microsoft Office Excel to respond when invalid data is entered.
   a) Click the **Error Alert** tab, and make sure that the **Show error alert after invalid data is entered** check box is selected.
   b) Select one of the options for the **Style** box.
   c) Fill in the title and text for the message (up to 225 characters).

10) Test the data validation to make sure that it is working correctly.
    a) Try entering both valid and invalid data in the cells to make sure that your settings are working as you intended and your messages are appearing when you expect.

**Restrict data entry to a decimal number within limits**

1) Select one or more cells to validate.
2) On the **Data** tab, in the **Data Tools** group, click **Data Validation**.
3) In the **Data Validation** dialog box, click the **Settings** tab.
4) In the **Allow** box, select **Decimal**.
5) In the **Data** box, select the type of restriction that you want. For example, to set upper and lower limits, select **between**.
6) Enter the minimum, maximum, or specific value to allow.

   **Note:** To let a user enter percentages, for example 20%, select **Decimal** in the Allow box, select the type of restriction that you want in the Data box, enter the minimum, maximum, or specific value as a decimal, for example .2, and then display the data validation cell as a percentage by selecting the cell and clicking **Percent Style %** in the Number group on the Home tab.

7) To specify how you want to handle blank (null) values, select or clear the Ignore blank check box.

   **Note:** If your allowed values are based on a cell range with a defined name, and there is a blank cell anywhere in the range, setting the Ignore blank check box allows any values to be entered in the validated cell. This is also true for any cells that are referenced by validation formulas: if any referenced cell is blank, setting the Ignore blank check box allows any values to be entered in the validated cell.

8) Optionally, display an input message when the cell is clicked.

   a) How to display an input message
      - Click the Input Message tab.
      - Make sure the Show input message when cell is selected check box is selected.
      - Fill in the title and text for the message.

9) Specify how you want Microsoft Office Excel to respond when invalid data is entered.

   a) How to specify a response to invalid data
      - Click the Error Alert tab, and make sure that the Show error alert after invalid data is entered check box is selected.
      - Select one of the options for the Style box.
   
   b) Fill in the title and text for the message (up to 225 characters).

10) Test the data validation to make sure that it is working correctly.

    Try entering both valid and invalid data in the cells to make sure that your settings are working as you intended and your messages are appearing when you expect.

    **Tip:** If you change the validation settings for a cell, you can automatically apply your changes to all other cells that have the same settings. To do so, open the Data Validation dialog box, and then select the Apply these changes to all other cells with the same settings check box on the Settings tab.

---

**Restrict data entry to a date within a time frame**

1) Select one or more cells to validate.

2) On the Data tab, in the Data Tools group, click Data Validation.

3) In the Data Validation dialog box, click the Settings tab.

4) In the Allow box, select Date.

5) In the Data box, select the type of restriction that you want. For example, to allow dates after a certain day, select greater than.

6) Enter the start, end, or specific date to allow.

7) To specify how you want to handle blank (null) values, select or clear the Ignore blank check box.
**Note:** If your allowed values are based on a cell range with a defined name, and there is a blank cell anywhere in the range, setting the **Ignore blank** check box allows any values to be entered in the validated cell. This is also true for any cells that are referenced by validation formulas: if any referenced cell is blank, setting the **Ignore blank** check box allows any values to be entered in the validated cell.

8) Optionally, display an input message when the cell is clicked.
   a) How to display an input message
      - Click the **Input Message** tab.
      - Make sure the **Show input message when cell is selected** check box is selected.
      - Fill in the title and text for the message.

9) Specify how you want Microsoft Office Excel to respond when invalid data is entered.
   a) How to specify a response to invalid data
      - Click the **Error Alert** tab, and make sure that the **Show error alert after invalid data is entered** check box is selected.
      - Select one of the options for the **Style** box.
      - Fill in the title and text for the message (up to 225 characters).

10) Test the data validation to make sure that it is working correctly.
    Try entering both valid and invalid data in the cells to make sure that your settings are working as you intended and your messages are appearing when you expect.

**Tip:** If you change the validation settings for a cell, you can automatically apply your changes to all other cells that have the same settings. To do so, open the **Data Validation** dialog box, and then select the **Apply these changes to all other cells with the same settings** check box on the **Settings** tab.

### Restrict data entry to a time within a time frame

1) Select one or more cells to validate.
2) On the **Data** tab, in the **Data Tools** group, click **Data Validation**.
3) In the **Data Validation** dialog box, click the **Settings** tab.
4) In the **Allow** box, select **Time**.
5) In the **Data** box, select the type of restriction that you want. For example, to allow times before a certain time of day, select **less than**.
6) Enter the start, end, or specific time to allow.
7) To specify how you want to handle blank (null) values, select or clear the **Ignore blank** check box.  
   **Note:** If your allowed values are based on a cell range with a defined name, and there is a blank cell anywhere in the range, setting the **Ignore blank** check box allows any values to be entered in the validated cell. This is also true for any cells that are referenced by validation formulas: if any referenced cell is blank, setting the **Ignore blank** check box allows any values to be entered in the validated cell.
8) Optionally, display an input message when the cell is clicked.
9) Specify how you want Microsoft Office Excel to respond when invalid data is entered.
10) Test the data validation to make sure that it is working correctly.
Try entering both valid and invalid data in the cells to make sure that your settings are working as you intended and your messages are appearing when you expect.

**Tip:** If you change the validation settings for a cell, you can automatically apply your changes to all other cells that have the same settings. To do so, open the **Data Validation** dialog box, and then select the **Apply these changes to all other cells with the same settings** check box on the **Settings** tab.

### Restrict data entry to text of a specified length

1. Select one or more cells to validate.
2. On the **Data** tab, in the **Data Tools** group, click **Data Validation**.
3. In the **Data Validation** dialog box, click the **Settings** tab.
4. In the **Allow** box, select **Text Length**.
5. In the **Data** box, select the type of restriction that you want. For example, to allow up to a certain number of characters, select **less than or equal to**.
6. Enter the minimum, maximum, or specific length for the text.
7. To specify how you want to handle blank (null) values, select or clear the **Ignore blank** check box.

   **Note:** If your allowed values are based on a cell range with a defined name, and there is a blank cell anywhere in the range, setting the **Ignore blank** check box allows any values to be entered in the validated cell. This is also true for any cells that are referenced by validation formulas: if any referenced cell is blank, setting the **Ignore blank** check box allows any values to be entered in the validated cell.

   Optionally, display an input message when the cell is clicked.
8. Specify how you want Microsoft Office Excel to respond when invalid data is entered.
9. Test the data validation to make sure that it is working correctly.

   Try entering both valid and invalid data in the cells to make sure that your settings are working as you intended and your messages are appearing when you expect.

   **Tip:** If you change the validation settings for a cell, you can automatically apply your changes to all other cells that have the same settings. To do so, open the **Data Validation** dialog box, and then select the **Apply these changes to all other cells with the same settings** check box on the **Settings** tab.

### Remove data validation

You can remove validation on a cell so that users are no longer required to enter information or information formatted in specific way.

1. Select the cells where you no longer want to validate data.
   a) To remove data validation from all similar cells or from all cells that have validation on a worksheet, find the cells with data validation:
      - **Find all cells with data validation:**
        1. On the **Home** tab, in the **Editing** group, click the arrow next to **Find & Select**, and then click **Go To Special**.
        2. Click **Data Validation**, and then click **All**.
      - **Find cells that match certain data validation settings:**
        1. Click a cell that has the data validation settings for which you want to find matches.
(2) On the **Home** tab, in the **Editing** group, click the arrow next to **Find & Select**, and then click **Go To Special**.

(3) Click **Data Validation**, and then click **Same**.

2) On the **Data** tab, in the **Data Tools** group, click **Data Validation**.

3) Do one of the following:
   a) If you are prompted to erase the current settings and continue, click **OK**, and then click **Cancel**.
   b) If the **Data Validation** dialog box appears, click the **Settings** tab, and then click **Clear All**.

**Copy data validation settings**

After you define data validation in a cell, you may want to copy the data validation settings to other cells. For example, you may want to ensure that a user can only enter date values for the current year in a column of data, or you may want to use the same input message and error alert, but slightly modify the data validation settings in the other cells.

1) Select the cell, and then on the **Home** tab, in the **Clipboard** group, click **Copy**.

2) Select the cells for which you want to duplicate the settings.
   
   **Tip:** To cancel a selection of cells, click any cell on the worksheet.

3) On the **Home** tab, in the **Clipboard** group, click the arrow below **Paste**, and then click **Paste Special**.

4) Click **Validation**.

   **Note:** In the **Paste Special** dialog box, the **All** and **All except borders** options also paste the data validation settings.

**Display or hide circles around invalid data**

Data validation is designed to display messages and prevent invalid entries only when users type data directly in a cell. Validation messages won't appear and invalid data can be entered when a user enters data in a cell by copying or filling, a formula in the cell calculates a result that isn't valid, or a macro enters invalid data in the cell.

You may want to audit your worksheets to look for incorrect data that may cause inaccurate calculations or results. You can identify cell(s) with data validation that contain invalid data by having Excel circle the cells in red.

**Circle invalid cells**

1) On the **Data** tab, in the **Data Tools** group, click the arrow next to **Data Validation**, and then click **Circle Invalid Data**:
   a) Microsoft Office Excel displays a red circle around any cells that contain invalid data.
   b) All cells that don't meet their data validation criteria are circled, including values that were typed, copied, or filled in the cells, calculated by formulas, or entered by macros.

**Hide validation circles**

1) Do one of the following:
   a) To remove the circle from a single cell, enter valid data in the cell.
   b) On the **Data** tab, in the **Data Tools** group, click the arrow next to **Data Validation**, and then click **Clear Validation Circles**.