Working with Tables in Word 2010

Table of Contents

INSERT OR CREATE A TABLE ......................................................................................................................... 2
  USE TABLE TEMPLATES (QUICK TABLES) ............................................................................................. 2
  USE THE TABLE MENU ......................................................................................................................... 2
  USE THE INSERT TABLE COMMAND ............................................................................................... 2
  KNOW YOUR AUTOFIT OPTIONS ......................................................................................................... 3
CONVERT TEXT TO A TABLE OR VICE VERSA .......................................................................................... 3
  Create a table out of text .......................................................................................................................... 3
  Remove your table and keep your text ..................................................................................................... 3
COPY A WORD TABLE INTO EXCEL ........................................................................................................... 4

WORKING WITH TABLES .......................................................................................................................... 4
  ABOUT THE TABLE TOOLS CONTEXTUAL TABS .............................................................................. 4
TABLE PROPERTIES .................................................................................................................................... 4
  Resize and align a table on a page .......................................................................................................... 4
  Resize and align a row, column or cell ................................................................................................... 5
  Distribute rows and columns evenly ...................................................................................................... 6
ADD A ROW ABOVE OR BELOW ............................................................................................................ 6
  Delete a row ............................................................................................................................................ 6
ADD A COLUMN TO THE LEFT OR RIGHT ............................................................................................... 6
  Delete a column .................................................................................................................................... 6
ADD A CELL ............................................................................................................................................... 6
  Delete a cell ............................................................................................................................................ 7
DELETE A TABLE ........................................................................................................................................ 7
SELECT THE CONTENTS OF A TABLE ..................................................................................................... 7
CLEAR THE CONTENTS OF A TABLE ......................................................................................................... 8
CHANGE DEFAULT MARGINS AND ALIGNMENT ....................................................................................... 8
REPEAT YOUR HEADINGS .......................................................................................................................... 8
MERGE CELLS ........................................................................................................................................... 8
SPLIT CELLS ............................................................................................................................................... 9
SPLIT A TABLE ......................................................................................................................................... 9
ADD TEXT AND GRAPHICS TO A TABLE ................................................................................................ 9
MOVE OR COPY ITEMS IN A TABLE ....................................................................................................... 10
SORT THE CONTENTS OF A TABLE ......................................................................................................... 10
  Sort a single column in a table ............................................................................................................. 10
ADJUST BORDERS AND BACKGROUNDs ............................................................................................... 11
  Turn on the gridlines .............................................................................................................................. 11
**Insert or create a table**

In Microsoft Word, you can insert a table by in three ways:

- Choose from a gallery of preformatted table templates.
- Use the Table menu to specify the number of rows and columns that you want.
- Use the Insert Table dialog box.

**Use table templates (Quick Tables)**

You can use table templates to insert a table that is based on a gallery of preformatted tables. Table templates contain sample data to help you visualize what the table will look like when you add your data.

1) Click where you want to insert a table.
2) On the Insert tab, in the Tables group, click Table, point to Quick Tables, and then click the template that you want.
3) Replace the data in the template with the data that you want.

**Use the Table menu**

1) Place your insertion point where you want to insert a table.
2) On the Insert tab, in the Tables group, click Table, and then, under Insert Table, drag to select the number of rows and columns that you want.
3) The table will be empty and the cursor will appear in the first row of the first column.

**Use the Insert Table command**

You can use the Insert Table command to choose the table dimensions and format before you insert the table into a document.

1) Place your insertion point where you want to insert a table.
2) On the Insert tab, in the Tables group, click Table, and then click Insert Table.
3) Under Table size, enter the number of columns and rows.
4) Under AutoFit behavior, choose options to adjust the table size.
Know your AutoFit options

The AutoFit option currently associated with your table may affect your table width when adding a column. The AutoFit options are located in the Cell Size group of the Layout tab.

When you first create a table, it will automatically fit between the margins — that setting is called AutoFit Window. When you use this setting, if you add a column before you add text, the size of the columns automatically adjusts to keep the table within the margins.

Another AutoFit option is AutoFit Contents, which changes column width based on what's inside the cells. If you don't have any text in the cells and choose this option, your cells will shrink to about a character width. If you begin adding text to a new table, and haven't chosen an AutoFit option, your table will adjust column widths to accommodate your content.

If you want your columns to remain the same width, you can use the Fixed Column Width option.

Convert text to a table or vice versa

Create a table out of text

The first step you do when converting text to a table is to decide what character to use to separate the columns. Common characters to use are tabs and commas, but you can use others. Paragraph marks are what separate the rows. Make sure that the character and paragraph marks are between the parts of the text that you want to convert to a table.

1) Insert separator characters to indicate where you want to divide the text into columns. Use paragraph marks to indicate where you want to begin a new row.
   a) For example, in a list with two words on a line, insert a comma or a tab after the first word to create a two-column table.

2) Select the text that you want to convert.

3) On the Insert tab, in the Tables group, click Table, and then click Convert Text to Table.

4) In the Convert Text to Table dialog box, under Separate text at, click the option for the separator character that is in your text.

5) In the Number of columns box, check the number of columns.
   a) If you don’t see the number of columns that you expect, you may be missing a separator character in one or more lines of text.

6) Select any other options that you want.

7) Click OK:
   a) If your table isn't what you've expected, confirm that you have characters where you want the columns.

Remove your table and keep your text

Sometimes, you may decide that you don't want to have a table in your document, even though you've already entered information in it. You could cut and paste the information out of the table and into the text of the document, but there's an easier way.
You can remove the table, but keep the information that you've entered with the **Table to Text** command. This is great to know about if you need to save the entire document as a text file.

To convert an existing table to text, select the table or parts of the table that you want to convert. Then select the **Layout** tab and click **Convert to Text** from the **Data** group.

**Copy a Word table into Excel**

When you want to move data from a Microsoft Office Word table to Microsoft Office Excel, you can avoid having to retype that data by copying it from Word directly into Excel. When you copy data from a Word table into an Excel worksheet, the data in each Word table cell is pasted in an individual cell on the worksheet.

**Important**: After pasting the data, you may have to clean it up so that you can take advantage of the calculation features in Excel. For example, there may be unwanted extra spacing in cells, numbers may have been pasted as text rather than as numeric values that you can calculate, or dates are not displayed correctly.

1) In a Word document, select the rows and columns of the table that you want to copy to an Excel worksheet / copy the selection.

2) In the Excel worksheet, select the upper-left corner of the worksheet area where you want to paste the Word table.

   **Important**: Make sure that the paste area is empty before you paste the data. Data in Word table cells will replace any existing data in worksheet cells in the paste area. If necessary, review the table first in Word to verify its dimensions.

3) On the **Home** tab, in the **Clipboard** group, click **Paste**.

   a) To adjust the formatting, click **Paste Options** next to the data that you pasted, and then do the following:

      • To use the formatting that is applied to the worksheet cells, click **Match Destination Formatting**.

      • To use the formatting of the Word table, click **Keep Source Formatting**.

**Working with Tables**

**About the Table Tools contextual tabs**

You will need to know where the **Design** and **Layout Table Tools** contextual tabs are when working on the design and structural layout of a table. The **Design** and **Layout** tabs are only visible after you have clicked inside of a table, and appear at the top of the screen on the ribbon.

The **Layout** tab enables you to change a table’s structure, like adding and deleting rows or columns.

The **Design** tab has lots of predefined table styles that will allow you to easily change the look of an entire table.

**Table Properties**

**Resize and align a table on a page**

Use the **Table Properties** box to quickly resize the table to a specific measurement or a specific percentage of the page. To access **Table Properties**, click the **Layout** tab and click **Properties** from the **Table** group.

**Note**: If you're trying to resize a table to fit its contents or to fit the page, try the **AutoFit** options.
On the **Table** tab, select the **Preferred width** check box and then enter the width you want. In the **Measure in** box, select either your default unit of measurement (such as inches or millimeters, set in Word Options) or **Percent** if you want the width to be a percentage of the entire table.

By default, tables are aligned against the left margin of the page. Tables can also be centered, or right-aligned on the page.

From the **Table** tab, you can also adjust whether text wraps around the table, change the table's cell default margins, or access the **Borders and Shading** box.

**Resize and align a row, column or cell**

Besides the **Table** tab, the **Table Properties** box has three other tabs for formatting columns, rows, and cells. Use these tabs to quickly resize a row or column to a specific measurement, or to easily resize several rows or columns.

On the **Row** tab, select the **Specify height** check box and then enter the height you want. In the **Row height is** box, select **Exactly** if you want exactly that height, or **At least** if you want the height to grow taller if the content requires.

On the **Column** tab, you can set column width by choosing a specific measurement using your default unit of measurement or as a percentage of your table size.

For instance, if you want a three-inch column in a table that measures six inches across, you can either enter 3 and choose **Measure in inches** or you can enter 50 and choose **Measure in Percent**. Click **Next Column** or **Previous Column** to resize other columns without exiting the dialog box.

On the **Cell** tab, you also can choose the default cell width in either the default unit of measurement or percentage of the entire table. You can also choose vertical alignment. The **Options** button on this tab allows you to choose cell margins that are different from the table's margins.

Although you can use the Table Properties dialog box to resize rows, columns and cells, the easiest way to change the width or height of a column or row is to rest the pointer over the right edge of the column or the bottom edge of the row until your pointer changes to a double-backed arrow, then just click and drag to resize.

**Be careful**: If you select a single cell, only that cell will change size.
**Distribute rows and columns evenly**
If you prefer, you can distribute all of the rows and columns evenly.

1) Click in the table.
2) Under **Table Tools**, on the **Layout** tab, in the **Cell Size** group, click **Distribute Rows** or **Distribute columns**.

**Add a row above or below**

1) Click in a cell above or below where you want to add a row.
2) Under **Table Tools**, on the **Layout** tab, do one of the following:
   a) To add a row above the cell, click **Insert Above** in the **Rows and Columns** group.
   b) To add a row below the cell, click **Insert Below** in the **Rows and Columns** group.

**Delete a row**

1) Select the row that you want to delete by clicking its left edge.
2) Under **Table Tools**, click the **Layout** tab.
3) In the **Rows & Columns** group, click **Delete**, and then click **Delete Rows**.

**Add a column to the left or right**

1) Click in a cell to the left or right of where you want to add a column.
2) Under **Table Tools**, on the **Layout** tab, do one of the following:
   a) To add a column to the left of the cell, click **Insert Left** in the **Rows and Columns** group.
   b) To add a column to the right of the cell, click **Insert Right** in the **Rows and Columns** group.

**Delete a column**

1) Select the column that you want to delete by clicking its top gridline or top border.
2) Under **Table Tools**, click the **Layout** tab.
3) In the **Rows & Columns** group, click **Delete**, and then click **Delete Columns**.

**Add a cell**

1) Click in a cell that is to the right of or above where you want to insert a cell.
2) Under **Table Tools**, on the **Layout** tab, click the **Rows & Columns** Dialog Box Launcher.
3) Click one of the following options.

<table>
<thead>
<tr>
<th>Click</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift cells right</td>
<td>Insert a cell and move all other cells in that row to the right.</td>
</tr>
<tr>
<td><strong>Note:</strong> Word does not insert a new column. This may result in a row that has more cells than the other rows.</td>
<td></td>
</tr>
<tr>
<td>Shift cells down</td>
<td>Insert a cell and move the existing cells down one row. A new row is added at the bottom of the table.</td>
</tr>
<tr>
<td>Insert entire row</td>
<td>Insert a row above the cell that you clicked in.</td>
</tr>
<tr>
<td>Insert entire column</td>
<td>Insert a column to the left of the cell that you clicked in.</td>
</tr>
</tbody>
</table>
Delete a cell

1) Select the cell that you want to delete by clicking its left edge.
2) Under Table Tools, click the Layout tab.
3) In the Rows & Columns group, click Delete, and then click Delete Cells.
4) Click one of the following options:

<table>
<thead>
<tr>
<th>Click</th>
<th>To do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift cells left</td>
<td>Delete a cell and shift all other cells in that row to the left.</td>
</tr>
<tr>
<td></td>
<td>Note: Word does not insert a new column. Using this option may result in</td>
</tr>
<tr>
<td></td>
<td>a row that has fewer cells than the other rows.</td>
</tr>
<tr>
<td>Shift cells up</td>
<td>Delete a cell and move the remaining existing cells in that column up</td>
</tr>
<tr>
<td></td>
<td>one row each. A new, blank cell is added at the bottom of the column.</td>
</tr>
<tr>
<td>Delete entire row</td>
<td>Delete the entire row that contains the cell that you clicked in.</td>
</tr>
<tr>
<td>Delete entire column</td>
<td>Delete the entire column that contains the cell that you clicked in.</td>
</tr>
</tbody>
</table>

Delete a table
The Delete key on your keyboard just deletes the text in your table or parts of your table, but there is a way to delete text and structure all at once.

Put your cursor anywhere in the table that you want to delete, and then click Delete Table from the Rows and Columns group in the Layout tab. Be careful, your deletions do not move to the clipboard.

Note: Using the BACKSPACE key on your keyboard will also delete the table and its contents.

Select the contents of a table

<table>
<thead>
<tr>
<th>To select</th>
<th>Do this</th>
</tr>
</thead>
<tbody>
<tr>
<td>A cell</td>
<td>Click the left edge of the cell.</td>
</tr>
<tr>
<td>A row</td>
<td>Click to the left of the row.</td>
</tr>
<tr>
<td>A column</td>
<td>Click the column's top gridline or border.</td>
</tr>
<tr>
<td>Contiguous cells, rows, or columns</td>
<td>Drag the pointer across the cells, rows, or columns that you want.</td>
</tr>
<tr>
<td>Noncontiguous cells, rows, or columns</td>
<td>Click the first cell, row, or column that you want, hold down CTRL, and</td>
</tr>
<tr>
<td></td>
<td>then click the next cell, row, or column that you want.</td>
</tr>
<tr>
<td>Text in the next cell</td>
<td>Press the TAB key.</td>
</tr>
<tr>
<td>Text in the previous cell</td>
<td>Press SHIFT+TAB.</td>
</tr>
<tr>
<td>The entire table</td>
<td>In Print Layout view, rest the pointer over the table until the table</td>
</tr>
<tr>
<td></td>
<td>move handle appears, and then click the table move handle.</td>
</tr>
</tbody>
</table>
Clear the contents of a table
1) Select the items that you want to clear.
2) Press DELETE.

Change default margins and alignment
Every cell in a table behaves like its own page with its own margins and alignment. You can change cell margins and alignment for either the entire table or for selected cells.

By default, the alignment and margins for cells in a table are identical. However, if you select a built-in style, you may affect text alignment.

You can change a table's margins (the default cell margins) by selecting the table, clicking the Layout tab, and choosing Cell Margins from the Alignment group.

The Table Options dialog box opens.

You can change default margins and alignment for a cell, a group of cells, or the entire table by choosing one of the text alignment buttons in the Alignment group.

The Tables Property box has other alignment and margin options.

Repeat your headings
When you work with a very long table, it will be divided into several pages. You can make adjustments to the table so that the table headings appear on each page. A heading, or header, identifies the type of data in each column. Not all tables need heading rows.

Repeated table headings are visible only in Print Layout view or when you print the document.

1) Select the heading row or rows. The selection must include the first row of the table.
2) Under Table Tools, on the Layout tab, in the Data group, click Repeat Header Rows.

Note: Microsoft Office Word automatically repeats table headings on new pages that result from automatic page breaks. Word does not repeat a heading if you insert a manual page break within a table.

Merge cells
You can combine two or more table cells located in the same row or column into a single cell. For example, you can merge several cells horizontally to create a table heading that spans several columns.

You can merge any number of cells — they don't need to be heading cells or even be in the same row. They can be any number of adjacent cells anywhere in your table.

Keep in mind, however, that because a table is an organizing tool, simplicity is important. Merge cells only for small alterations.

1) Select the cells that you want to merge by clicking the left edge of a cell and then dragging across the other cells that you want.
2) Under Table Tools, on the Layout tab, in the Merge group, click Merge Cells.
Split cells
Splitting one cell is pretty straightforward. You just place your cursor in the cell you want split, click the **Layout** tab, and click **Split**. Then choose the number of columns and rows you want to split that cell into.

If you split more than one cell at a time, you will need to decide whether to check or clear the **Merge cells before split** check box. If you check **Merge cells before split**, Word merges the cells before dividing them. If you don't select the check box, Word splits each of the cells.

For example, if you select two cells, check **Merge cells before split**, and then select 3 for **Number of columns**, you will end up with three columns (cells) in the space where the two cells were. If you clear the check box, you will end up with six columns (cells) in the space where the two cells were.

**Tip:** The default number in the **Number of columns** box varies depending on whether **Merge cells before split** is selected. Determine whether you want the selected cells to merge before choosing the number of columns and rows you want.

1) Click in a cell, or select multiple cells that you want to split.

2) Under **Table Tools**, on the **Layout** tab, in the **Merge** group, click **Split Cells**.

3) Enter the number of columns or rows that you want to split the selected cells into.

**Split a table**
Splitting a table can be useful if you decide you want a table to be split into smaller sections. Splitting a table is also handy if you want to format a section of a table. When working with a table, the larger the portion of the table that you can format at once, the less work you will end up doing.

Splitting a table has four steps.

1) Highlight or place your cursor in the row that you want to become the first row of the new table.

2) Click the **Layout** tab.

3) Click **Split Table** from the **Merge** group.

4) A paragraph will separate the two tables.

**Add text and graphics to a table**
To add text to any cell in your table, click in the cell and begin typing. When you're finished with that cell, move to the next cell by pressing the **TAB** key. Or just click in any cell.

If you're at the last cell of a table, clicking the **TAB** key adds a new row to your table.

If you want to move backwards using the keyboard, hold down the **Shift** key and press **TAB**. This moves you back one cell at a time. Of course, you can also use the arrow keys to move throughout the table.
You can add more than just text to a table. You can insert a graphic into a table cell just as you do in the body of your document with the **Insert Picture** function.

When you place a picture into a table using Insert Picture, the picture is formatted to be **In Line with Text**. This setting causes your picture to act just like a text character — you can format it by using font and paragraph formatting, and it will sit securely in your table cell.

You can also paste a picture from another program, but when you do, the picture may not be formatted to be **In Line with Text**. It's easy to change this layout option: just select the graphic, select **Position** from the **Format** tab, and click **In Line with Text**.

### Move or copy items in a table

1) Select the item that you want to move or copy.
2) Do one of the following:
   a) To move the selected item, drag it to the new location.
   b) To copy the selected item, hold down **CTRL** while you drag it to the new location.

### Sort the contents of a table

In a table, you can enter information in any order and then sort by any column. If you have headings in your table, you pick the headings to sort by. If you don't have headings, you can sort by columns, numbered from left to right.

1) In Print Layout view, move the pointer over the table until the table move handle appears.
2) Click the table move handle to select the table that you want to sort.
3) Under **Table Tools**, on the **Layout** tab, in the **Data** group, click **Sort**.
4) In the **Sort** dialog box, select the options that you want.

### Sort a single column in a table

1) Select the column that you want to sort.
2) Under **Table Tools**, on the **Layout** tab, in the **Data** group, click **Sort**.
3) Under **My list has**, click **Header row** or **No header row**.
4) Click **Options**.
5) Under **Sort options**, select the **Sort column only** check box.
6) Click **OK**.

### Adjust borders and backgrounds

Borders and shading are a part of a table's style. Even if you may have already selected a table's style, you can modify borders or shading. You can apply borders or shading to the entire table, individual cells, or even individual paragraphs within a table.

To remove or change the borders of a table, cell, or group of cells, highlight the cells and open the **Borders** list in the **Table Styles** group of the **Design** tab. Select from the buttons to make a change or click **Borders and Shading**.
In the **Borders and Shading** box, pay careful attention to the **Apply to** list. The **Apply to** options vary, depending on what table parts you've selected. If you accidentally selected a cell, but wanted to apply a border for the entire table, you can change the selection in the **Apply to** list.

![Borders and Shading dialog box]

**Turn on the gridlines**

If your table doesn't have borders, you might have trouble seeing the edges of the cells. Gridlines allow you to easily see cell edges. To turn on gridlines, click anywhere within the table, and then click **View Gridlines** in the **Table** group of the **Layout** tab.

*Note:* the gridlines do not print.