Introduction
Several of the lists you see in day-to-day life are either already sorted or allow you to sort them the way you want. A calendar or a day planner is sorted on date. On the other hand, when you search for flight tickets or browse the entries in your e-mail inbox, you have the option of sorting on one of many available fields. You can sort tickets based on price, departure time, or the airline, and you can sort the entries in your mailbox by sender, subject, or date. A sorted list helps users review and locate what they want without having to browse the data.

You can sort the records in a table, query, form, or a report on one or more fields. With minimal design work, you and the users of your form or report can choose how the records are sorted.

For example, when you design a product catalog report, you might choose to list the products in alphabetical order. The order you choose when you design an object becomes the object's default sort order. But when viewing the query or report, each of your users can sort the records the way they want, such as by price or by supplier.

Note: A view can be sorted on any field that is displayed in the view, except on fields that contain attachments or OLE objects.

You can fine-tune your results by sorting records on more than one field. When sorting on multiple fields, it is important to identify what are known as the outermost and innermost sort fields. The records are sorted first on the outermost field and then next on the innermost field. The outermost field is the primary sort. Use innermost fields as tie-breakers.

One thing to remember when applying sort orders is that numbers, text, and special characters are sorted according to the selected language and regional settings of your computer. If the language and regional settings specified in the Access Options dialog box do not match those specified in Control Panel, the resulting sort orders might not match your expectations.
Sort the records in a view

Note: In Access, sorting a report is slightly different from sorting a table, query, or form.

Sort a table, query, or form

1) Identify the fields on which you want to sort. To sort on two or more fields, identify the fields that will act as the innermost and outermost sort fields.

2) Do one of the following:

a) Use the Ascending, or Descending Sort button on the Ribbon:

   - Click in any field and select the **Ascending** or **Descending Sort** button.
   - Repeat the previous step for each sort field, ending with the outermost sort field.

b) Use the mouse:

   - Right-click anywhere in the column or control corresponding to the innermost field, and click one of the sort commands.

   Note: The commands vary with the type of data that is in the selected field. If a text field contains null and zero-length strings, when sorted in ascending order, the records with null values are listed first, then the records with zero-length strings, and then the records with nonblank values.

3) To remove a sort order:

   a) **Home** tab / **Sort & Filter** group / **Clear All Sorts** button.
Sort in the query design view
1) Open your query in Design view.
2) Add the fields you want to sort by, if necessary.
3) Choose Ascending or Descending from the Sort row drop down list for each field.

Tip: If you want to sort by a field, but do not want the field displayed in your datasheet results, add the field to the grid, choose Ascending or Descending from the Sort row, but then uncheck the “Show” checkbox
4) To remove the sort criteria from the grid:
   a) In Design view, choose (not sorted) from the Sort drop down list for each field.

Sort a report
1) Open a report in Layout view or Design view.
2) If the Group, Sort, and Total pane is not open, in the Grouping & Totals group (on the Format tab in Layout view, or on the Design tab in Design view), click Group & Sort.
3) Do one of the following:
   a) If the report is not sorted already:
      • Click Add a sort and choose a field to sort by. Repeat these steps for each sort field, with the innermost sort field appearing at the bottom.
b) **If the report is already grouped or sorted:**
   - Review the existing levels and make changes carefully.
   - To change a field, use the first drop-down arrow (**Sort by**).
   - To change the order, click the second drop-down arrow (**with A on top or with Z on top**).
   - To change a grouping level to just a sorting level:
     i. Next to the field you are currently grouped by, click **More** and change “**with a header section**” to “**without a header section.**”
   
   **Tip:** To sort a report on a single field, open the report in Layout view, right-click the field, and select the sort command you want. But if the report is grouped, or if you want to sort on multiple fields, you must use the **Group, Sort, and Total** pane.

4) To remove a sort from the design:
   a) In the **Group, Sort, and Total** pane, select the sort row to be deleted and click the **“Delete”** button at the end of that row.

   ![Sort row deletion](image)
   
   **Note:** An entry corresponding to a sort field will start with the words **Sort by**. Avoid deleting entries that start with **Group by**, because that will change the design of the report.

---

**Use the Advanced filter to Sort**

Although you can sort using the **Ascending** or **Descending Sort** buttons in a table, query, or form, you can also use the **Advanced Filter** button to perform sorts on multiple fields.

1) On the **Home** tab, in the **Sort & Filter** group, click **Advanced** and then click **Advanced Filter/Sort** on the shortcut menu.
   a) A new document tab appears, containing a design grid and a window in which you can select a field on which to sort.

2) In the window, double-click the field that you want to use to sort.
   a) The field appears in the design grid.

3) In the design grid, in the **Sort** row, specify whether you want to sort the field in ascending order (smallest values first; **A-to-Z**) or in descending order (largest values first; **Z-to-A**).
   
   **Note:** Whatever field is in the first column of the design grid becomes the outermost sort field, ties are broken going left to right in the grid.

4) On the **Home** tab, in the **Sort & Filter** group, click **Toggle Filter**.

5) To clear the advanced sort grid:
   a) **Home** tab / **Sort & Filter** group / **Advanced** drop down / **Advanced Filter/Sort…** / **Advanced** drop down / **Clear Grid** / **Toggle filter**
   
   **Note:** This does not revert your list to a previous sort order. This must be done manually, unless a sort order was previously saved with your object. If so, you can close the table, query, or form without saving changes, and the next time the object is opened, it will revert to the **last saved order.**

Understand sort orders
When you sort the data in a table, query, form, or report, you can save the sort order with the object. If you sort the data in one of these objects and then save the object, the sort order that is in effect when you save the object is automatically saved with the object. You can specify whether the saved sort order will be in effect when the object is next opened.

For queries and reports, you can also define a default sort order. The default sort order is applied to the data in the query or report when no other sort order is specified.

There are two kinds of saved sort orders:

- **Last-applied**: A last-applied sort order is the sort order that was in effect when the object was last saved. Tables, queries, forms, and reports can all have last-applied sort orders.

- **Default**: A default sort order is built into the design of a query or a report. A default sort order is applied when no other sort order is specified.
  - Because the last-applied sort order can change whenever someone sorts an object and then saves it, you may want to define a default sort order. A default sort order is part of the design of the object, and does not change when a different sort order is applied.
  - You can only specify a default sort order for a query or report. The default sort order is not overwritten by the current or last-applied sort order, it comes into effect only when the current or last-applied sort order is removed.

Define the default sort order for a query
1) Open the query in Design view.
2) Double-click the field that you want to use to sort.
   a) If you do not want to see the field with the query results:
      - In the design grid, clear the box in the Show row of the field that you’ve added,
3) In the Sort row, specify whether you want to sort the field in ascending order or in descending order.
   a) If you want to sort by more than one field, add additional sort fields by repeating steps 2 through 3.
      Note: When you sort by more than one field, results are sorted initially by the first field that you specified, then by the next field that you specified, and so on.
4) Save the query.
   a) To remove a default sort order from a query, remove the sort fields from the query design grid.

Sort records on text, numeric, or date values
Sorting data can play a big role in making a report or form effective and easy to use. For example, a product catalog that lists the products in alphabetical order or on the basis of unit price is much easier to use than one that lists the items in random order.

If a value in a field starts with a special character – such as a hyphen, parenthesis, or other symbol – you will observe the following behavior when sorting in ascending order:

- Values that start with a space character will appear before alphanumeric values.
- Values enclosed in quotation marks follow values that start with a space, but precede alphanumeric values.
- Values that start with the minus sign (−) precede values that start with the plus (+) sign.
- For all other symbols, the order is determined by looking at the ASCII character codes of the characters. For example, the code for the dollar symbol ($) is 36, and the code for the equal sign (=) is 61, so values starting with $ will appear before values that start with =.
Sort records on numeric values stored in a text field

Numbers and strings stored in a text or memo field are sorted alphabetically. In other words, numbers will be sorted based on the individual digits that make up the value, instead of on the numeric value. For example, the value 11 appears before 2, and the value 12 appears before 3, as shown in the table.

<table>
<thead>
<tr>
<th>Student Name</th>
<th>Student No</th>
</tr>
</thead>
<tbody>
<tr>
<td>John</td>
<td>1</td>
</tr>
<tr>
<td>Maria</td>
<td>10</td>
</tr>
<tr>
<td>William</td>
<td>11</td>
</tr>
<tr>
<td>Mary</td>
<td>12</td>
</tr>
<tr>
<td>Jane</td>
<td>2</td>
</tr>
<tr>
<td>Lynn</td>
<td>3</td>
</tr>
<tr>
<td>Jason</td>
<td>4</td>
</tr>
<tr>
<td>Mary</td>
<td>5</td>
</tr>
</tbody>
</table>

To ensure that the numbers are sorted based on their numeric value instead of alphabetically, do one of the following:

1) **If the field contains only numeric values:**
   a) Consider changing the data type of the field to Number or Currency.

2) **Use the Val function to obtain the numeric value of a number that is stored as text if:**
   a) The field contains only numeric values, but you do not want to change the data type of the field.
   b) The field contains both numeric and string values, but you want to ignore the string values when sorting.

   **Note:** The Val function returns the numbers contained in a string as a numeric value. The expression also uses the If function to handle null values that might be in the sort field.

   1) On the **Home** tab, in the **Sort & Filter** group, click **Advanced** and then click **Advanced Filter/Sort** on the shortcut menu.
   2) Type the following expression in the first column **Field** row:

      \[
      
      \text{Expr1: IIf([Fieldname] Is Null, 0, Val([Fieldname]))}.
      \]

      **Note:** The If function checks to see if the field value is null and, if so, treats it as 0. If the value is not null, the If function calls the Val function to obtain the numeric equivalent.

   3) In the **Sort** cell, select **Ascending** or **Descending**.
   4) On the **Home** tab, in the **Sort & Filter** group, click **Toggle Filter**.

Sort on partial text values

Sorting on partial text values requires that you write an expression in the Advanced Filter/Sort window to extract the characters that form the basis for sorting.

Assume that the City field contains values such as **North Seattle**, **South Seattle**, **North Tacoma**, or **South Tacoma**. Suppose you want to ignore the first word and sort the records on the second word alone.

1) On the **Home** tab, in the **Sort & Filter** group, click **Advanced** and then click **Advanced Filter/Sort** on the shortcut menu.
2) Type an expression in the **Field** row in the first column.

   For example, type \( =\text{Mid([City], 7)} \) to ignore the first six characters in the City field.

   **Note:** the Mid function returns a substring contained in a specified string or field. In this case, for each record, the function returns the value starting from the seventh character (that is, after the space) in the City field.

   3) In the **Sort** cell, select **Ascending** or **Descending**.
   4) On the **Home** tab, in the **Sort & Filter** group, click **Toggle Filter**.