# Access 2007 Creating Forms

Table of Contents

**CREATING FORMS IN ACCESS 2007** .................................................................................................................. 3

**UNDERSTAND LAYOUT VIEW AND DESIGN VIEW** .......................................................................................... 3

  LAYOUT VIEW .................................................................................................................................................. 3
  DESIGN VIEW .................................................................................................................................................. 3

**UNDERSTAND CONTROLS** ............................................................................................................................... 4

  BOUNDED CONTROL ..................................................................................................................................... 4
  UNBOUNDED CONTROL ............................................................................................................................... 4
  CALULATED CONTROL ................................................................................................................................. 4

**CREATE FORMS IN DIFFERENT WAYS** ............................................................................................................ 5

  CREATE A FORM BY USING THE FORM TOOL .............................................................................................. 5
  CREATE A FORM BY USING THE FORM WIZARD ......................................................................................... 5
  CREATE A FORM THAT DISPLAYS MULTIPLE RECORDS BY USING THE MULTIPLE ITEMS TOOL .............. 6
  CREATE A FORM BY USING THE BLANK FORM TOOL ............................................................................... 6

  **THE FIELD LIST** ....................................................................................................................................... 7
    Add a field to a form by using the Field list pane ...................................................................................... 8
    Add a field to a form in Design view .......................................................................................................... 9

  **THE PROPERTY SHEET** ............................................................................................................................. 10

  **LEARN ABOUT SUBFORMS** ....................................................................................................................... 11
    Create a form that contains a subform by using the Form Wizard ......................................................... 12
    Create a subform by dragging one form onto another ........................................................................... 13
    Open a subform in a new window in Design view .................................................................................. 14

  **UNDERSTAND THE DIFFERENCES BETWEEN A SPLIT FORM AND A FORM THAT CONTAINS A DATASHEET** ................................................................................................................................. 14
    Create a split form .................................................................................................................................... 14
    Turn your existing form into a split form ................................................................................................ 15
    Set the split form properties .................................................................................................................. 15
    Add a field to a split form, or delete a field from a split form .............................................................. 16
    Insert a datasheet into a form ................................................................................................................. 16
    Create a form that contains a datasheet by using the Form tool ...................................................... 16
    Create a form that contains a datasheet by using Layout view ......................................................... 17
    Insert a datasheet into an existing form by using Design view ............................................................ 18
    My Link child fields and Link Master fields properties are blank ...................................................... 18

  **SAVE YOUR WORK** .................................................................................................................................... 19
    Save your form design ............................................................................................................................... 19
    Save your form design under a new name .............................................................................................. 19

Create Forms in Access 2007 Training Session Handout

Topics came directly from Microsoft Access Help.
Creating forms in Access 2007

A form is a database object that you can use to enter, edit, or display data from a table or a query. You can use forms to control access to data, such as which fields or rows of data are displayed. For example, certain users might need to see only several fields in a table with many fields. Providing those users with a form that contains just those fields makes it easier for them to use the database. You can also add buttons and other functionality to a form to automate frequently performed actions.

Think of forms as windows through which people see and reach your database. An effective form speeds the use of your database, because people don't have to search for what they need. A visually attractive form makes working with the database more pleasant and more efficient, and it can also help prevent incorrect data from being entered. Microsoft Office Access 2007 gives you new tools to help you create forms quickly, and provides new form types and features that improve the usability of your database.

Note: As you read this handout, the assumption is that you have already created a table (or a query based on one or more tables), and that you want to build a form to view or manipulate the data.

Understand Layout view and Design view

Layout view

Layout view is the most intuitive view to use for form modification, and it can be used for nearly all the changes you would want to make to a form in Office Access 2007. In Layout view, the form is actually running, so you can see your data much as it will appear in Form view. However, you can also make changes to the form design in this view. Because you can see the data while you are modifying the form, this is a very useful view for setting the size of controls or performing almost any other task that affects the appearance and usability of the form.

Certain tasks cannot be performed in Layout view and require switching to Design view. In certain situations, Access displays a message telling you that you must switch to Design view to make a particular change.

Design view

Design view gives you a more detailed view of the structure of your form. You can see the Header, Detail, and Footer sections for the form. The form is not actually running when it is shown in Design view, so you cannot see the underlying data while you are making design changes; however, there are certain tasks you can perform more easily in Design view than in Layout view. You can:

- Add a wider variety of controls to your form, such as labels, images, lines, and rectangles.
- Edit text box control sources in the text boxes themselves, without using the property sheet.
- Resize form sections, such as the Form Header or the Detail section.
- Change certain form properties that cannot be changed in Layout view (such as Default View or Allow Form View).
Understand controls
Controls are objects that display data, perform actions, and let you view and work with information that enhances the user interface, such as labels and images. The most commonly used control is the text box, but other controls include labels, check boxes, and subform/subreport controls.

Controls can be bound, unbound, and calculated:

**Bound control**
- A control whose source of data is a field in a table or query is called a bound control. You use bound controls to display values that come from fields in your database. The values can be text, dates, numbers, Yes/No values, pictures, or graphs. For example, a text box on a form that displays an employee's last name might get this information from the Last Name field in an Employees table.

**Unbound control**
- A control that doesn't have a source of data (such as a field or expression) is called an unbound control. You use unbound controls to display information, lines, rectangles, and pictures. For example, a label that displays the title of a form is an unbound control.

**Calculated control**
- A control whose source of data is an expression, rather than a field, is called a calculated control. You specify the value that you want to use as the source of data in the control by defining an *expression*. An expression can be a combination of operators (such as *=` and `+`), control names, field names, functions that return a single value, and constant values. For example, the following expression calculates the price of an item with a 25 percent discount by multiplying the value in the Unit Price field by a constant value (0.75).

\[ \text{=[Unit Price]} \times 0.75 \]

An expression can use data from a field in the form's underlying table or query, or data from another control on the form.

When you create a form, it is probably most efficient to add and arrange all the bound controls first, especially if they make up the majority of the controls on the form. You can then add the unbound and calculated controls that complete the design by using the tools in the **Controls** group on the **Design** tab in Design view.

You bind a control to a field by identifying the field from which the control gets its data. You can create a control that is bound to the selected field by dragging the field from the Field List pane to the form. The Field List pane displays the fields of the form's underlying table or query. To display the Field List pane, press **ALT+F8**, or on the **Design** tab, in the **Tools** group, click **Add Existing Field**. When you double-click a field in the Field List pane, Access adds the appropriate type of control for that field to the form.

Alternatively, you can bind a field to a control by typing the field name in the control itself or in the box for the **Control Source** value in the control's property sheet. The property sheet defines the characteristics of the control, such as its name, the source of its data, and its format. To open the property sheet, press **F4**.

Using the Field List pane is the best way to create a bound control for two reasons:
- Access automatically fills in the control's attached label with the name of the field (or the caption defined for that field in the underlying table or query), so you don't have to type the control's label yourself.
- Access automatically sets many of the control's properties to the appropriate values according to the properties of the field in the underlying table or query (such as the **Format**, **Decimal Places**, and **Input Mask** properties).
If you already created an unbound control and want to bind it to a field, set the value in the control's **Control Source** property box to the name of the field. For details about the **Control Source** property, press F1 while the cursor is in the property's drop-down list. Pressing F1 will display the Help topic for the active property.

**Create forms in different ways**

Think of forms as windows through which people see and reach your database. An effective form speeds the use of your database, because people don't have to search for what they need. A visually attractive form makes working with the database more pleasant and more efficient. Office Access 2007 gives you new tools to help you create forms quickly, and provides new form types and features that improve the usability of your database.

**Create a form by using the Form tool**

You can use the Form tool to create a form with a single mouse-click. When you use this tool, all the fields from the underlying data source are placed on the form. You can begin using the new form immediately, or you can modify it in Layout view or Design view to better suit your needs.

1) In the Navigation Pane, click the table or query that contains the data you want to see on your form.
2) On the **Create** tab, in the **Forms** group, click **Form**.

Access creates the form and displays it in Layout view. In Layout view, you can make design changes to the form while it is displaying data. For example, you can adjust the size of the text boxes to fit the data, if necessary.

If Access finds a single table that has a one-to-many relationship with the table or query that you used to create the form, Access adds a datasheet to the form that is based on the related table or query. For example, if you create a simple form that is based on the Customers table, and there is a one-to-many relationship defined between the Customers table and Orders table, the datasheet displays all the records in the Orders table that pertain to the current Customer record. You can delete the datasheet from the form if you decide you do not need it. If there is more than one table with a one-to-many relationship to the table that you used to create the form, Access does not add any datasheets to the form.

**Create a form by using the Form Wizard**

To be more selective about what fields appear on your form, you can use the Form Wizard. You can also define how the data is grouped and sorted, and you can use fields from more than one table or query, provided that you specified the relationships between the tables and queries beforehand.

1) On the **Create** tab, in the **Forms** group, click **More Forms**, and then click **Form Wizard**.
2) Follow the directions on the pages of the Form Wizard.
   
   **Note:** If you want to include fields from multiple tables and queries on your form, do not click **Next** or **Finish** after you select the fields from the first table or query on the first page of the Form Wizard. Instead, repeat the steps to select a table or query, and click any additional fields that you want to include on the form. Then click **Next** or **Finish** to continue.
3) On the last page of the wizard, click **Finish**.
**Create a form that displays multiple records by using the Multiple Items tool**

When you create a form by using the Simple Form tool, the form that Access creates displays a single record at a time. If you want a form that displays multiple records but is more customizable than a datasheet, you can use the Multiple Items tool.

When you use the Multiple Items tool, the form that Access creates resembles a datasheet. The data is arranged in rows and columns, and you see more than one record at a time. However, a Multiple Items form gives you more customization options than a datasheet, such as the ability to add graphical elements, buttons, and other controls.

1) In the Navigation Pane, click the table or query that contains the data you want to see on your form.

2) On the **Create** tab, in the **Forms** group, click **Multiple Items**.
   a) Access creates the form and displays it in Layout view.

**Create a form by using the Blank Form tool**

If the wizard or the form-building tools don't fit your needs, you can use the Blank Form tool to build a form. This can be a very quick way to build a form, especially if you plan to put only a few fields on your form.

1) On the **Create** tab, in the **Forms** group, click **Blank Form**.
2) Access opens a blank form in Layout view, and displays the Field list pane.
3) In the Field list pane, click the plus sign (+) next to the table or tables that contain the fields that you want to see on the form.
4) To add a field to the form, double-click it or drag it onto the form. To add several fields at once, hold down **CTRL** and click several fields, and then drag them onto the form at the same time.

   **Note:** The order of the tables in the Field list pane can change, depending on which part of the form is currently selected. If you are not able to add a field to the form, try selecting a different part of the form and then try adding the field again.

5) Use the tools in the **Controls** group on the **Format** tab to add a logo, title, page numbers, or the date and time to the form.

6) If you want to add a wider variety of controls to the form, switch to Design view by right-clicking the form and then clicking **Design View**. You can then use the tools in the **Controls** group on the **Design** tab.
The Field list
Use the Field List in conjunction with the Controls group to place bound controls (controls linked to fields in a table or a query) on your form.

You can open the Field List by clicking the Add Existing Fields button in the Tools group on the Design tab.

If the form is bound to a table or query, Access displays the name of the underlying table or query along with all the fields available.

Any tables that have relationships to the underlying table defined are displayed under Fields Available In Related Tables. The last section of the Field List, Fields Available In Other Tables, lists the tables and fields from all other tables in this database.

Click the Show Only Fields In The Current Record Source link to remove the bottom two sections of the Field List.

To use the Field List to place a bound control on a form, drag the field you want from the Field List and drop it into position on the form.

The following list contains tips about working with the Field List pane that may be helpful to you as you add fields to your form. To display the Field List pane, open a form in Layout view or Design view, and then press ALT+F8.

- If the form's Record Source property is empty, and you drag a field from the Field List pane to the form, Access automatically fills in the form's Record Source property for you.
- If the form’s Record Source property is a SELECT statement or a table name, you can toggle the Field List pane display between the following two states:
  - All database fields: Displays the Fields available for this view section, the Fields available in related tables section (if such tables exist), and the Fields available in other tables section.
  - Record source fields only: Displays only the Fields available for this view section.

To switch between the two modes, click either Show only fields in the current record source or Show all tables at the bottom of the Field list pane.
Topics came directly from Microsoft Access Help.
4) When you find the field you want to add, do one of the following to add it to the form:
   a) Double-click the field.
   b) Drag the field from the Field List pane to the form.
   c) Hold the **CTRL** key and click several fields, and then drag them all to the form at the same time.
      **Note:** This technique can be used only on fields in the **Fields available for this view** section of the Field List pane.
   d) Add a range of fields from the Field List pane to the form by doing the following:
      - Click the first field in the range.
      - Press and hold the **SHIFT** key, and then click the last field in the range.
      (1) Access selects the fields you clicked, as well as all the fields in between.
      - Drag all the selected fields to the form.
      **Note:** This technique can only be used on fields in the **Fields available for this view** section of the Field List pane.

Office Access 2007 creates the appropriate control to display each field, and also binds the control to the field. In addition, Access creates an attached label for the control. You can edit the label by clicking it once to select it, and then clicking it again to place the insertion point in the label. Then, you can edit the label in the same way that you would edit text in a document.

If you want a field displayed in a different type of control other than the one that Access creates automatically, you can change the control to another type. However, you can only change it to a control type that is appropriate for that field. For example, you can change a combo box to a text box or a list box, but you can't change a combo box to a command button.

*Add a field to a form in Design view*

In general, using the Field list pane is the easiest way to add a field to a form or report. However, you can also add a field by creating a control and then binding it to a field. The following procedure shows you how.

1) Open the form in Design view by right-clicking it in the Navigation Pane and then clicking **Design View**.
2) On the **Design** tab, in the **Controls** group, if **Use Control Wizards** is not highlighted, click it to highlight it.
   a) **Control Wizards:** You can use the Control Wizards to help you create command buttons, list boxes, subforms, combo boxes, and option groups. A Control Wizard asks you a series of questions about how you want the control to look and operate, and then it creates the control and sets the control's properties based on your answers.
   b) If you would rather create controls without the help of the wizards, click **Use Control Wizards** so that it is not selected.
3) On the **Design** tab, in the **Controls** group, click the tool for the type of control you want to add.
   a) To determine the name of a tool, position the pointer over it. Access displays the name of the tool.
4) Click in the form design grid where you want to position the upper-left corner of the control. Click once to create a default-sized control, or click the tool and then drag in the form design grid to create a control of the size that you want.
5) If you have selected **Use Control Wizards**, and the control you are placing has a wizard associated with it, the wizard starts and guides you through the settings for the control.

6) If you don't position the control perfectly on the first try, you can move it by doing the following:
   a) Click the control to select it.
   b) Position the pointer over the control until it turns into a move pointer ⊞.
   c) Click and drag the control to the location that you want.

**The Property Sheet**

The form, each section of the form (header, detail, footer), and each control on the form have a list of properties associated with them, and you set these properties using a property sheet. Each control on a form, each section on a form, and the form itself are all objects. The kinds of properties you can specify vary depending on the object.

To open the property sheet for an object, select the object and then click the **Property Sheet** button in the **Tools** group on the **Design** tab. You cannot have both the property sheet and the Field List open at the same time.

You can drag the title bar to move the property sheet around on your screen. You can also drag the edges of the window to resize it so that you can see more of the property settings.

Because a form has more than 100 properties that you can set and because many controls have more than 70 properties, Access provides tabs at the top of the property sheet so that you can choose to display all properties (the default) or to display only format properties, data properties, event properties, or other properties.

If you have previously undocked either the Field List or property sheet, the property sheet appears in the undocked window. If the property sheet is already open, you can view the properties specific to an object by clicking the object. You can also click the arrow under **Selection Type** and then select the object name from the list at the top of the property sheet.

When you click in a property box that provides a list of valid values, a small arrow appears on the right side of the property box. Click this arrow to see a list of the values for the property. For properties that can have a very long value setting, you can click the property and then press **SHIFT+F2** to open the **Zoom** dialog box. The **Zoom** dialog box provides an expanded text box for entering or viewing a value.
In many cases, a window, dialog box, or wizard is available to help you create property settings for properties that can accept a complex expression, a query definition, or code (a macro or a Visual Basic procedure) to respond to an event. When such help is available for a property setting, Access displays a small button with an ellipsis next to the property box when you select the property; this is the **Build** button. If you click the **Build** button, Access responds with the appropriate window, dialog box, or wizard.

**Learn about subforms**

When you are working with relational data (where related data is stored in separate tables), you often need to view data from more than one table or query on the same form. For example, you want to see customer data, but you also want to see information about the customer's orders at the same time. Subforms are a convenient tool for doing this, and Microsoft Office Access 2007 provides many ways to help you create subforms quickly.

A subform is a form that is inserted in another form. The primary form is called the main form, and the form within the form is called the subform. A form/subform combination is sometimes referred to as a hierarchical form, a master/detail form, or a parent/child form.

Subforms are especially effective when you want to show data from tables or queries that have a one-to-many relationship. For example, you can create a form that contains a subform to show data from a Categories table and a Products table. The data in the Categories table is the "one" side of the relationship. The data in the Products table is the "many" side of the relationship — each category can have more than one product.

The main form and subform in this type of form are linked so that the subform displays only records that are related to the current record in the main form. For example, when the main form displays the Beverages category, the subform displays only the products in the Beverages category. If the form and subform were unlinked, the subform would display all the products, not just those in the Beverages category.
The following table defines some of the terminology associated with subforms. Access will handle most of the details if you use the procedures in this handout, but it is helpful to know what is happening behind the scenes if you need to make modifications later.

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Subform control</td>
<td>The control that embeds a form into a form. You can think of the subform control as a &quot;view&quot; of another object in your database, whether it is another form, a table, or a query. The subform control provides properties which allow you to link the data displayed in the control to the data on the main form.</td>
</tr>
<tr>
<td>Source Object property</td>
<td>The property of the subform control that determines what object is displayed in the control.</td>
</tr>
<tr>
<td>Datasheet</td>
<td>A simple display of data in rows and columns, much like a spreadsheet. The subform control displays a datasheet when its source object is a table or query, or when its source object is a form whose Default View property is set to Datasheet. In these cases, the subform is sometimes referred to as a datasheet instead of as a subform.</td>
</tr>
<tr>
<td>Link Child Fields property</td>
<td>The property of the subform control that specifies which field or fields in the subform link it to the main form.</td>
</tr>
<tr>
<td>Link Master Fields property</td>
<td>The property of the subform control that specifies which field or fields on the main form link it to the subform.</td>
</tr>
</tbody>
</table>

For best results, establish all relationships first. This enables Access to automatically create the links between subforms and main forms. To view, add, or modify relationships between the tables in your database, on the Database Tools tab, in the Show/Hide group, click Relationships.

When a subform control has a form as its source object, it contains the fields that you place on the form, and it can be viewed as a single form, continuous form (a form that displays more than one record on the screen in Form view), or datasheet. One advantage of basing a subform on a form object is that you can add calculated fields to the subform, such as [Quantity] * [Unit price].

You can also insert a datasheet into a form by creating a subform control whose source object is a table or query. A datasheet is not as customizable as a subform; for example, you can't add a calculated field to a datasheet. You can, however, create a subform that is based on a form that contains a calculated field, and then set that form's Default View property to Datasheet. This results in a datasheet type of subform that contains a calculated field.

Create a form that contains a subform by using the Form Wizard

1) On the Create tab, in the Forms group, click More Forms, and then click Form Wizard.
2) On the first page of the wizard, in the Tables/Queries drop-down list, select a table or query.
   Note: It does not matter which table or query you choose first.
3) Double-click the fields that you want to include from this table or query.
4) On the same page of the wizard, in the Tables/Queries drop-down list, select another table or query from the list.
   a) Double-click the fields that you want to include from this table or query.
5) When you click **Next**, assuming that you set up the relationships correctly before starting the wizard, the wizard asks **How do you want to view your data?** — that is, by which table or query. The wizard displays a small diagram of the form. The box in the lower portion of the form represents the subform.
   a) At the bottom of the wizard page, select the **Form with subform(s)** option, and then click **Next**.

6) On the **What layout would you like for your subform?** page of the wizard, click **Tabular** or **Datasheet** depending on which layout you want for your subform. Both layout styles arrange the subform data in rows and columns, but a tabular layout is more customizable. You can add color, graphics, and other formatting elements to a tabular subform, whereas a datasheet is more compact, like the datasheet view of a table. When you have made your selection, click **Next**.

7) On the **What style would you like?** page of the wizard, select a formatting style for the form. If you chose **Tabular** on the previous page, the formatting style you choose will also be applied to the subform. When you have made your selection, click **Next**.

8) On the last page of the wizard, type the titles you want for the forms. Access names the forms based on the titles you type, and labels the subform based on the title you type for the subform.
   a) Also on this page, specify whether you want to open the form in Form view so that you can view or enter information, or whether you want to open the form in Design view so that you can modify its design. When you have made your selection, click **Finish**.
   b) Access creates two forms — one for the main form that contains the subform control, and one for the subform itself.

**Create a subform by dragging one form onto another**

Use this process if you have two existing forms and you want to use one form as a subform on the other form.

1) In **Design view**, open the form that you want to use as the main form.
2) On the **Design** tab, in the **Controls** group, if the **Use Control Wizards** tool is not selected, click it to select it.
3) Drag a form from the Navigation Pane onto the main form.
4) Access adds a subform control to the main form and binds the control to the form that you dragged from the Navigation Pane. Access also attempts to link the subform to the main form, based on the relationships that have been defined in your database. If Access cannot determine how to link the subform to the main form, the **Link Child Fields** and **Link Master Fields** properties of the subform control are left blank, and you must set these properties manually by doing the following:
   a) Right-click the main form in the Navigation Pane, and then click **Design View**.
   b) Click the subform control once to select it.
   c) If the property sheet is not already displayed, press **F4** to display it.
   d) On the **Data** tab of the property sheet, click next to the **Link Child Fields** property box.
      - The **Subform Field Linker** dialog box appears.
   e) In the **Master Fields** and **Child Fields** drop-down lists, select the fields that you want to link the forms with. If you are not sure which fields to use, click **Suggest** to have Access try to determine the linking fields. When you finish, click **OK**.
      **Note:** If you do not see the field that you want to use to link the forms, you might need to edit the record source of the master form or child form to ensure that the linking field is in it. For example, if the form is based on a query, you should ensure that the linking field is present in the query results.
5) Save the main form and switch to Form view, and then verify that the form works as you expect.
Open a subform in a new window in Design view
If you want to make design changes to a subform while you are working on its main form in Design view, you can open the subform in its own window:

1) Click the subform to select it.
2) On the Design tab, in the Tools group, click Subform in New Window.

Understand the differences between a split form and a form that contains a datasheet
A form that contains a datasheet displays data from different (but usually related) data sources. For example, a form might show employees, and it might have a datasheet that shows all the tasks assigned to each employee. The datasheet has a different data source from the form that contains it. By contrast, a split form has two sections (a form and a datasheet), but the same data is displayed in both sections. The two sections track with each other and give you two different views of your data at once.

Create a split form
A split form is a new feature in Microsoft Office Access 2007 that gives you two views of your data at the same time — a Form view and a Datasheet view. The two views are connected to the same data source and are synchronized with each other at all times. Selecting a field in one part of the form selects the same field in the other part of the form. You can add, edit, or delete data from either part (provided the record source is updateable and you have not configured the form to prevent these actions).

Working with split forms gives you the benefits of both types of forms in a single form. For example, you can use the datasheet portion of the form to quickly locate a record, and then use the form portion to view or edit the record. The form portion can serve as an attractive and functional header for the datasheet portion. This technique is used in many of the template databases that are available for Office Access 2007.

This procedure creates a new split form from scratch. The form is based on a table or query that you select from the Navigation Pane or have open in Datasheet view.

1) In the Navigation Pane, click the table or query that contains the data that you want on your form. Or open the table or query in Datasheet view.
2) On the Create tab, in the Forms group, click Split Form.
   a) Access creates the form and displays it in Layout view.
**Turn your existing form into a split form**

You can turn your existing form into a split form by setting a few form properties.

1) Open your form in Design view by right-clicking it in the Navigation Pane and then clicking **Design View**.
2) If the property sheet is not already displayed, press **F4** to display it.
3) Select **Form** from the drop-down list at the top of the property sheet.
4) On the **Format** tab of the property sheet, in the **Default View** drop-down list, select **Split Form**.
5) Check your form in Form view. To switch to Form view, double-click the form name in the Navigation Pane.

After you create your split form, you can make some adjustments in Design view or Layout view to get the results you want.

**Set the split form properties**

The following table lists some of the properties that are related to split forms that you can set on the property sheet to fine-tune your form. If the property sheet is not already displayed, press **F4** to display it. Also, ensure that **Form** is selected in the drop-down list at the top of the property sheet. All of the properties in the table are located on the **Format** tab of the property sheet.

<table>
<thead>
<tr>
<th>Property</th>
<th>View(s) in which you can set the property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Split Form Orientation</td>
<td>Design view only</td>
<td>Allows you to define whether the datasheet appears above, below, to the left, or to the right of the form.</td>
</tr>
<tr>
<td>Split Form Datasheet</td>
<td>Design view or Layout view</td>
<td>If set to Allow Edits (and the form's record source is updateable), Access allows edits to be made on the datasheet. If the property is set to Read Only, Access prevents edits from being made on the datasheet.</td>
</tr>
<tr>
<td>Split Form Splitter Bar</td>
<td>Design view only</td>
<td>If set to Yes, Access allows you to resize the form and datasheet by moving the splitter bar that separates the two parts. You can drag the splitter bar to provide more room or less room for the datasheet. If this property is set to No, the splitter bar is hidden, and the form and datasheet cannot be resized.</td>
</tr>
<tr>
<td>Save Splitter Bar Position</td>
<td>Design view only</td>
<td>If set to Yes, the form opens with the splitter bar in the same position in which you last left it. If this property is set to No, the form and datasheet cannot be resized, and the splitter bar is hidden.</td>
</tr>
<tr>
<td>Split Form Size</td>
<td>Design view or Layout view</td>
<td>Allows you to specify an exact height or width (depending on whether the form is split vertically or horizontally) for the form part of the split form. For example, type 1&quot; to set the form to a height or width of 1 inch. Type Auto to set the dimension by other means, such as dragging the splitter bar in Layout view.</td>
</tr>
</tbody>
</table>
Fix the form separator in place
To fix the form separator in a certain position so that it cannot be moved by the user, do the following:

1) Switch to Design view by right-clicking the form in the Navigation Pane, and then clicking Design View.
2) If the property sheet is not already displayed, press F4 to display it.
3) Select Form from the drop-down list at the top of the property sheet.
4) On the Format tab of the property sheet, set the Split Form Splitter Bar property to No.
5) Set the Save Splitter Bar Position property to Yes.
6) Switch to Layout view by right-clicking the form in the Navigation Pane, and then clicking Layout view.
7) Drag the splitter bar to the position that you want (or type an exact height in the Split Form Size property box).
8) Switch to Form view to view the results.
   a) The separator is fixed in the position where you set it, and the splitter bar is hidden.

Add a field to a split form, or delete a field from a split form
1) If the Field list pane is not displayed, on the Format tab, in the Tools group, click Add Existing Fields.
2) Locate the field that you want to add, and then drag the field to either the datasheet or the form.
3) If you drag a field to the datasheet, the field is also added to the form. Likewise, if you drag a field to the form, the field is also added to the datasheet.
4) To delete a field, you must use the form portion of the split form. Click the field to select it, and then press DELETE.
   a) The field is removed from both the form and the datasheet.

Insert a datasheet into a form
A datasheet is a simple view of data arranged in rows and columns. If you double-click a table in the Navigation Pane, Microsoft Office Access 2007 displays the table as a datasheet. Due to their compact presentation of data, datasheets work well when they are used as subforms to display data from the "many" side of a one-to-many relationship.

Establish relationships between tables
Before you design a form that contains a datasheet, you should review the relationships between your tables and add any relationships that are missing. Doing this enables Access to automatically create the links between datasheets and main forms. To view, add, or modify relationships between the tables in your database, on the Database Tools tab, in the Show/Hide group, click Relationships.

Create a form that contains a datasheet by using the Form tool
When you use the Form tool to build a form that is based on a table that is on the "one" side of a single one-to-many relationship, Access automatically inserts a datasheet that displays the data on the "many" side of the relationship.
For example, if the following conditions are true, Access inserts a datasheet that shows all the orders for each customer:

- You create a simple form that is based on the Customers table.
- You have defined a one-to-many relationship with the Orders table that specifies that one record in the Customers table can be related to many records in the Orders table.
- The Customers table is not on the "one" side of any other one-to-many relationships.

1) In the Navigation Pane, click the table that is on the "one" side of the one-to-many relationship.
2) On the Create tab, in the Forms group, click Form.

Access creates the form with the datasheet at the bottom of the form. If Access does not create a datasheet, it means either that the table you used for the form is not part of a one-to-many relationship, or that the table is part of more than one one-to-many relationship.

**Notes:**
- Aside from creating the main form, this process does not create any other form objects. The datasheet is a direct view of the table.
- **To hide a column in a datasheet:** Right-click the column and then click Hide Column. This setting is saved; if you save and close the form and then reopen it, the column will still be hidden.
- **To restore a hidden column in a datasheet:** Right-click any column heading in the datasheet and then click Unhide Columns. Select the check box next to each column that you want to restore to the view, and then click Close.

**Create a form that contains a datasheet by using Layout view**

If you have already defined the relationships between the tables in your database, you can quickly create a form that contains a datasheet by using Layout view. When you add a field from the "many" side of a relationship to a form that is based on the "one" side of the relationship, Access automatically creates a datasheet to display the related records.

1) On the Create tab, in the Forms group, click Blank Form.
2) Access opens a blank form in Layout view and displays the Field list pane.
3) Click the plus sign next to the table that is on the "one" side of the one-to-many relationship, and then drag the first field that you want onto the form.
4) From the Fields available for this view section, drag any other fields that you want onto the main form.
5) From the Fields available in related tables section, drag the first field that you want in your datasheet onto the form.
   a) Access creates a datasheet and adds the field to it.
6) To add additional fields to the new datasheet, you must first click the datasheet to select it. Note that Access rearranges the Field list pane so that the fields available for the datasheet are at the top. From the Fields available for this view section, drag any other fields that you want onto the datasheet. As you drag each field into the datasheet, Access draws an insertion bar to show you where the field will be inserted when you release the mouse button.
7) Continue adding fields to the main form or the datasheet by first clicking the main form or datasheet to select it, and then dragging the field from the Field list pane.
**Insert a datasheet into an existing form by using Design view**

Use this procedure to add a datasheet that is based directly on a table or query to an existing form in Design view.

1) Open the form in Design view by right-clicking the form in the Navigation Pane, and then clicking **Design View**.

2) On the **Design** tab, in the **Controls** group, if the **Use Control Wizards** tool is selected, click it so that it is not selected.
   a) Why?
      - If used, the subform Control Wizard builds a separate form object and bases the subform control on that form object. By contrast, this procedure creates a datasheet that is based directly on a table or query rather than a form.

3) On the **Design** tab, in the **Controls** group, click the **Subform/Subreport** tool.

4) In the form design grid, click where you want the datasheet to be inserted.

5) Reposition and resize the subform control by dragging the handles on the edges and corners of the control.

6) Edit the attached label for the subform control by first clicking the label, double-clicking it to select its text, and then typing a new label. If you prefer to delete the label, click the label once and then press **DELETE**.

7) If the subform control is not currently selected, click it once to select it.

8) On the **Data** tab of the property sheet, click the **Source Object** drop-down list, and then click the table or query that you want to display in the datasheet.

9) If you set up the relationships correctly before you started this procedure, Access automatically sets the **Link Child Fields** and the **Link Master Fields** properties with the correct values that will link the main form to the datasheet.

**My Link Child Fields and Link Master Fields properties are blank**

If Access cannot determine how to link the subform control to the main form, it leaves the **Link Child Fields** and **Link Master Fields** properties of the subform control blank. You must set these properties manually by doing the following:

1) Open the main form in Design view.

2) Click the subform control once to select it.

3) On the **Data** tab of the property sheet, click (...) next to the **Link Child Fields** property box.
   a) The **Subform Field Linker** dialog box appears.

4) In the **Master Fields** and **Child Fields** drop-down lists, select the fields that you want to link the forms with. If you are not sure which fields to use, click **Suggest** to have Access determine the linking fields. When you finish, click **OK**.
   a) If you do not see the field that you want to use to link the forms, you might need to edit the record source of the master or child form to be sure the field is in it. For example, if the form is based on a query, be sure the linking field is present in the query results.

5) Save the main form and switch to Form view to verify that the form works as you expect.
Save your work

After you save your form design, you can run the form as often as you want. The design stays the same, but you see current data every time you view the form. If your needs change, you can modify the form design or create a new form that is based on the original.

Save your form design

1) Click the Microsoft Office Button and then click Save, or press CTRL+S.
2) If the form is untitled, type a name in the Form Name box, and then click OK.

Save your form design under a new name

1) Click the Microsoft Office Button, and then click Save As.
2) In the Save As dialog box, type a name in the Save Form To box, select Form in the As list, and then click OK.

Layout your form

Understand control layouts

Control layouts are guides that align your controls horizontally and vertically to give your form a uniform appearance. You can think of a control layout as a table, where each cell of the table contains a control. The following procedures show you how to add, remove, or rearrange controls in control layouts.

Control layouts come in two varieties: tabular and stacked.

- In tabular control layouts, controls are arranged in rows and columns like a spreadsheet, with labels across the top. Tabular control layouts always span two sections of a form; whichever section the controls are in, the labels are in the section above.

- In stacked layouts, controls are arranged vertically like you might see on a paper form, with a label to the left of each control. Stacked layouts are always contained within a single form section.

You can have multiple control layouts of either type on a form. For example, you might have a tabular layout to create a row of data for each record, and then one or more stacked layouts underneath, containing more data from the same record.
Create a new control layout
Access automatically creates stacked control layouts in either of the following circumstances:

- You create a new form by clicking Form in the Forms group on the Create tab.
- You create a new form by clicking Blank Form in the Forms group on the Create tab, and then dragging a field from the Field list pane to the form.

On an existing form, you can create a new control layout by doing the following:

1) Select a control that you want to add to the layout.
   a) If you want to add other controls to the same layout, hold down the SHIFT key and also select those controls.

2) Do one of the following:
   a) On the Arrange tab, in the Control Layout group, click Tabular or Stacked.
   b) Right-click the selected control or controls, point to Layout, and then click Tabular or Stacked.

   - Access creates the control layout and adds the selected controls to it.

Switch a control layout from tabular to stacked, or from stacked to tabular
To switch an entire layout from one type of layout to the other:

1) Select all of the cells in the layout.
2) Do one of the following:
   a) On the Arrange tab, in the Control Layout group, click the layout type you want (Tabular or Stacked).
   b) Right-click the control layout, point to Layout, and then click the layout type you want.

   - Access rearranges the controls into the layout type you want.

Split one control layout into two layouts
You can split a control layout into two layouts by doing the following:

1) Hold down the SHIFT key and click the controls you want to move to the new control layout.
2) Do one of the following:
   a) On the Arrange tab, in the Control Layout group, click the layout type you want for the new layout.
   b) Right-click the selected controls, point to Layout, and then click the layout type you want for the new layout.

Rearrange controls in a control layout
- You can move a control within a control layout by dragging it to the location you want. As you drag the field, a horizontal or vertical bar indicates where it will be placed when you release the mouse button.
- You can move a control from one control layout to another control layout of the same type. For example, you can drag a control from one stacked layout to another stacked layout, but not to a tabular layout.
Add controls to a control layout

To add a new field from the Field list pane to an existing control layout
1) Drag the field from the Field list pane to the layout.

To add existing controls to an existing control layout
1) Select the first control you want to add to the control layout.
   a) If you want to add other controls to the same layout, hold down the SHIFT key and also select those controls. You can select controls in other control layouts.
2) Do one of the following:
   a) If the form is open in Design view, drag the selected fields to the layout.
   b) If the form is open in Layout view:
      • On the Arrange tab, in the Control Layout group, click the type of the layout to which you are adding the controls. If you are adding controls to a tabular layout, click Tabular. If you are adding controls to a stacked layout, click Stacked.
      • Access creates a new layout and adds the selected controls to it.
3) Drag the new layout to the existing layout. A horizontal or vertical bar indicates where the fields will be placed when you release the mouse button.

Remove controls from a control layout
Removing a control from a control layout allows you to place it anywhere on the form without affecting the positioning of any other controls.
1) Select the control you want to remove from the layout. To select multiple controls, hold down the SHIFT key and then click the controls you want to remove. To select all of the controls in the layout, click the layout selector box at the top left corner of the layout.
2) Do one of the following:
   a) On the Arrange tab, in the Control Layout group, click Remove .
      • Right-click one of the selected controls, point to Layout, and then click Remove .
      (1) Access removes the selected controls from the layout.

Add controls to your form
Some controls are created automatically, such as the bound control that is created when you add a field from the Field list pane to your form. Many other controls can be created in Design view by using the tools in the Controls group on the Design tab.

Note: Many of the tools in the Controls group are accessible only while your form is open in Design view. To switch to Design view, right-click the form name in the Navigation Pane and then click Design View .
To determine the name of a tool, place the mouse pointer over the tool. Access displays the name of the tool.
Add a text box control to a form
The text box is the standard control used for viewing and editing data on forms and reports. Many different types of data can be displayed in text boxes, and you can also use them to perform calculations.

Understand text box properties
Regardless of how you create a text box, certain properties need to be set so that the text box works and appears the way that you want. The following list shows a few of the more important and commonly used text box properties:

- **Name:** You should give your text box a short, meaningful name so that you can easily tell what data it contains. This makes it easy to refer to the text box in expressions that you might use in other text boxes. Some database developers prefer to add a prefix, such as **txt**, to text box names so that they can easily distinguish text boxes from other types of controls. — for example, **txtFirstName** or **txtAddress**.

- **Control Source:** This property determines whether the text box is bound, unbound, or calculated.
  - If the value in the **Control Source** property box is the name of a field in a table, the text box is bound to that field.
  - If the value in **Control Source** is blank, the text box is unbound.
  - If the value in **Control Source** is an expression, the text box is a calculated text box.

- **Text Format:** If the text box is bound to a Memo field, you can set the value in the **Text Format** property box to **Rich Text**. Doing this allows you to apply multiple formatting styles to the text contained in the text box. For example, you can apply bold formatting to one word and underlining to another.

Add a bound text box
A bound text box displays data from a field in a table or query. On a form, you can use a text box that is bound to an updatable record source to enter or edit data in a field. The changes that you make in the text box will be reflected in the underlying table.

A quick way to create a bound text box is by dragging a field from the Field list pane onto your form or report. Access automatically creates a text box for fields of the following data types:

- Text
- Memo
- Number
- Date/Time
- Currency
- Hyperlink

Dragging fields of other data types creates different types of controls. For example, if you drag a Yes/No field from the Field list pane to a form, Access creates a check box. If you drag an OLE Object field to a form or report, Access creates a bound object frame, and if you drag an attachment field to a form or report, Access creates an attachment control.

Add a bound text box to a form by dragging a field from the Field list pane
1) Open the form in Layout view or Design view by right-clicking the form in the Navigation Pane, and then clicking the view you want.
2) On the **Format** tab, in the **Controls** group, click **Add Existing Fields**.
3) In the Field list pane, expand the table containing the field that you want to be bound to your text box.
4) Drag the field from the Field list pane to the form.

**Note:** You can also add a bound text box to a form by first adding an unbound text box, and then setting the **Control Source** property of the text box to the field you want to bind it to.
Add an unbound text box
An unbound text box is not connected to a field in a table or query. You can use an unbound text box to display the results of a calculation or to accept input that you don't want to store directly in a table. It is easiest to add an unbound text box in Design view.

1) Open the form in Design view by right-clicking the form or report in the Navigation Pane, and then clicking Design View.
2) On the Design tab, in the Controls group, click Text Box.
3) Position the pointer where you want the text box to be placed on the form or report, and then click to insert the text box.

Note: Access also places a label to the left of the text box, so leave some room to the left of the pointer for the label. You can reposition the label and the text box later. You can also delete the label by clicking it and then pressing DELETE.

Another way to create an unbound text box is by first creating a bound text box by dragging a field from the Field list pane onto the form or report, and then deleting the value in its Control Source property. If you do this in Design view, the text box will display "Unbound" instead of the field name. In Layout view, the text box will no longer display data — in fact, it will be blank.

Insert a title into a form
1) Open the form in Layout view.
2) On the Format tab, in the Controls group, click Title.
   a) A new label is added to the form header, and the form name is displayed as the title.
   b) When the label is created, the text in the label is automatically selected so that you can change the text by typing the title you want.
3) Press ENTER when you have finished.

Edit an existing form title
1) Place the cursor in the label that contains the title by double-clicking the label.
2) Type the text you want to use as the title, and then press ENTER when you have finished.

Create a list of choices by using a list box or combo box
When entering data on forms, it is often quicker and easier to select a value from a list than to remember a value to type. A list of choices also helps ensure that the value that's entered in a field is appropriate. A list control can connect to existing data, or it can display fixed values that you enter when you create the control.

Types of list box controls
Office Access 2007 provides two list controls — the list box and the combo box.
List box: The list box control displays a list of values or choices. The list box contains rows of data, and is usually sized so that several rows are visible at all times. The rows can have one or more columns, which can appear with or without headings. If the list has more rows than can be displayed in the control, Access displays a scroll bar in the control. The user is limited to the choices given in the list box; it is not possible to type a value into a list box.

![List Box Example](image1)

Combo box: The combo box control provides a more compact way to present a list of choices; the list is hidden until you click the drop-down arrow. A combo box also gives you the ability to enter a value that is not in the list. In this way, the combo box control combines the features of a text box and a list box.

![Combo Box Example](image2)

List boxes and combo boxes can be bound or unbound controls. These controls can look up values in a fixed list that you type yourself, or they can look up values in a table or query. To create a bound list box or combo box that looks up values in a table or query, make sure the form is based on a record source that includes a foreign key field or Lookup field. This makes it possible to create the relationships that are needed to link the data in the list box or combo box to the data on the form.

Create a list box or a combo box by using a wizard

1) Right-click the form in the Navigation Pane, and then click Design View.

   **Note:** This procedure assumes that the form is bound to a table or query. Some of the steps will not apply if the form is unbound. To determine if the form is bound to a table or query, press **F4** to display the property sheet. On the Data tab of the property sheet, the Record Source property box displays the table or query that the form is bound to.

2) On the Design tab, in the Controls group, ensure that Use Control Wizards is selected.

3) Click either the List Box tool or the Combo Box tool.

4) On the form, click where you want to place the list box or combo box.
   a) Depending on your choice, the List Box Wizard or the Combo Box Wizard starts.
5) When the wizard asks how you want to get the values for the control, do one of the following:
   a) If you want to display the current data from a record source, click **I want the list box/combo box to look up the values in a table or query**.
   b) If you want to display a fixed list of values that will seldom change, click **I will type in the values that I want**.
   c) If you want the control to perform a find operation, rather than serve as a data entry tool, click **Find a record on my form based on the value I selected in my list box/combo box**. This creates an unbound control with an embedded macro that performs a find operation based on the value the user enters.

6) Follow the instructions for specifying how the values will appear.
   a) If you chose one of the first two options on the first page of the wizard, the wizard asks what you want Access to do when you select a value. Do one of the following:
      - To create an unbound control, click **Remember the value for later use**. This means that Access will hold the selected value until the user changes it or closes the form, but it will not write the value to a table.
      - To create a bound control, click **Store that value in this field**, and then select the field you want to bind the control to.

7) Click **Next** and type a label for the control. This label will be displayed next to the control.

8) Click **Finish**.

**Customize a list box or a combo box**

With the form open in Design view, ensure that the list box or combo box is selected, and then press **F4** to open the property sheet for the control. Then, do one of the following:

- **Change the sort order in a list box or combo box**: If you used a wizard to create the list box or combo box, Access automatically sorts the rows that make up the list by the first visible column. If you want to specify a different sort order, or if you have set the **Row Source** property of the control to a saved query, use the following procedure:
  - Click the **Data** tab, and then click the **Row Source** property box.
  - On the **Data** tab of the property sheet, click ![Query Builder](image) to open the Query Builder.
  - In the **Sort** row for the column you want to sort, specify the sort order you want.

- **Bind a column from a list box or combo box**: In the **Bound Column** property box of the list box or the combo box, specify a number that corresponds to the placement of the column in the list box or combo box. For example, type 1 to bind the first column in the list box or combo box to the underlying field specified in the **Control Source** property. Include hidden columns when you count columns.

- If you set the **Bound Column** property to 0, Access saves the list index instead of a value from one of the columns. This is useful if you want to store a sequence of numbers instead of the list value.

- **Hide a column in a list box or combo box on a form**: In the **Column Widths** property box, type 0 for the column or columns that you want to hide.

- **Add column headings to a combo box on a form**: In the **Column Heads** property box, click **Yes** to display column headings. Headings in combo boxes appear only when the list is open.
• **Set the width of the list box portion of a combo box on a form:** In the **List Width** property box, enter the width that you want, using the current unit of measurement (set in Windows Control Panel). To use a unit of measurement other than the default, include a measurement indicator. For example, enter 2 cm. Make sure to leave enough space for a scroll bar.
  
  o The list box portion of the combo box can be wider than the text box portion, but it cannot be narrower. The default setting (**Auto**) makes the list box the same width as the text box portion of the combo box.

• **Set the maximum number of rows to display in a combo box on a form:** In the **List Rows** property box, enter a number.
  
  o If the actual number of rows exceeds the number specified in the **List Rows** property, a vertical scroll bar is displayed in the combo box.

• **Limit combo box entries to items in the list portion of a combo box on a form:** In the **Limit To List** property box, click **Yes**.
Using the AutoFormat feature
After you have used Microsoft Office Access 2007 to create forms to display your table and query data, you can change the appearance of any control on the form or report. You can change the appearance of individual elements in your Office Access 2007 objects, but an easier way to change the format of an entire form at once is to use an AutoFormat that is included with Access. You can use an AutoFormat as it is out of the box, or you can choose to apply certain parts of the AutoFormat. If you want, you can even create and modify your own AutoFormats so you can make the appearance of your forms and reports consistent. Another useful Access capability is to create a conditional format, which changes the appearance of the data in a text box based on the data's value. If a customer hasn't placed an order in the last year, a product has been discontinued, or a shipment took more than a week to arrive, you can use conditional formats to highlight that data and bring it to your attention quickly.

Select an AutoFormat
1) Open the form you want to format in Design view.
2) Click the Arrange tab.
3) In the AutoFormat group, click the AutoFormat button.
4) Click the AutoFormat you want to apply. Caution: You can't change a built-in AutoFormat; you can only change an AutoFormat you created.

Apply AutoFormat elements
1) Open the form you want to format in Design view.
2) Click the Arrange tab.
3) In the AutoFormat group, click the AutoFormat button.
4) Click AutoFormat Wizard.
5) Click the AutoFormat you want to apply.
6) Click Options.
7) Select or clear the Font, Color, and Border check boxes to select the AutoFormat attributes you want to apply.
8) Click OK.
**Customize an AutoFormat**

1) Open the form you want to format in Design view.
2) Click the Arrange tab.
3) In the AutoFormat group, click the AutoFormat button.
4) Click AutoFormat Wizard.
5) Click the AutoFormat you want to customize. You can only customize an AutoFormat you created.
6) Click Customize.
7) Select the Update option to modify the selected AutoFormat to match the formatting of the active form or report.
8) Click OK.
9) Click OK to close the AutoFormat dialog box.

**Create an AutoFormat**

1) Open the form or report you want to format in Design view.
2) Click the Arrange tab.
3) Click the AutoFormat button.
4) Click AutoFormat Wizard.
5) Click the AutoFormat you want to customize.
6) Click Customize.
7) Select the Create A New AutoFormat option and click OK.
8) Type the name of the new AutoFormat in the New Style Name dialog box.
9) Click OK to close the New Style Name dialog box.
10) Click OK to close both the Customize AutoFormat and AutoFormat dialog boxes.

**Tip:** To delete an AutoFormat, open the AutoFormat dialog box, click the AutoFormat that you want to delete, click Customize, select the Delete option, and then click OK twice to close the dialog boxes.
Applying conditional formatting
Changing the appearance of your form data by applying formats (or AutoFormats) makes your data easier to read. However, you may want to apply different formats to a control's contents based on the data's value.

Define a conditional format
1) Open a form in Design view.
2) Click the control to which you want to apply a conditional format.
3) If necessary, click the Design tab.
4) In the Font group, click Conditional.
   a) The Conditional Formatting dialog box opens.

![Conditional Formatting dialog box]

5) Click the comparison phrase field's down arrow and then click the desired comparison.
6) Type values into the value fields to define the condition's parameters.
7) Use the Bold, Italic, Underline, Fill Color, Font Color, and Enabled buttons to define the conditional format.
8) If desired, follow either of these steps:
   a) Click Add to define another condition.
   b) Click Delete, select which conditions you want to delete, and then click OK to delete a condition.
9) Click OK.

Caution: If you change the appearance of a control's contents by making the contents bold or increasing the font size, be sure the control is large enough to display the data.

Tip: If you create multiple conditions, make sure there is no overlap between the conditions, such as one condition checking whether a number is less than 3000 and another checking whether the same number is less than 1500. If there is overlap, the first condition Access checks is applied. The proper way to create the conditions is to check in Condition 1 if a value is between 1500 and 3000 and then check in Condition 2 if the value is less than 1500.
Use a command button to start an action or a series of actions
You use a command button on a form to start an action or a set of actions. For example, you can create a command button that opens another form. To make a command button perform an action, you write a macro or event procedure and attach it to the command button's On Click property. You can also embed a macro directly into the On Click property of the command button. This makes it possible to copy the button to other forms without losing the functionality of the button.

Add a command button to a form by using a wizard
By using the Command Button Wizard, you can quickly create command buttons that do a variety of tasks, such as closing the form, opening a report, finding a record, or running a macro.

1) Right-click the form in the Navigation Pane, and then click Design view on the shortcut menu.
2) On the Design tab, in the Controls group, ensure that Use Control Wizards is selected.
3) On the Design tab, in the Controls group, click Button.
4) In the design grid, click where you want the command button to be inserted.
   a) The Command Button Wizard starts.
5) Follow the directions in the wizard. On the last page, click Finish.
6) The wizard creates the command button and embeds a macro in the button's On Click property. The macro contains actions that perform the task you chose in the wizard.

View or edit a macro embedded in a command button
1) In the Navigation Pane, right-click the form that contains the command button, and then click Design View or Layout View on the shortcut menu.
2) Click the command button to select it, and then press F4 to display its property sheet.
3) On the Event tab of the property sheet, [Embedded Macro] should be displayed in the On Click property box. Click anywhere in the property box, and then click in the right side of the box.
   a) The Macro Builder is displayed, showing the action or actions that make up the embedded macro.

Overview of expressions
Often, you need information that isn't directly available in a field in your database. For example, you might need to calculate sales tax on an order, or calculate the order total itself. At other times, you'll need to supply a query or filter with criteria — information that determines which records you work with. Or you might want to set a default value for a field or control, or a validation rule for a field or table. In all of these cases, you use an expression.
In Access, an expression is equivalent to a formula in Excel. An expression consists of a number of possible elements that are used, alone or in combination, to produce a result. Elements can include **identifiers** (the names of fields, controls, or properties), **operators** such as + (plus) or - (minus), **functions**, **constants**, and **values**. You use an expression to perform a calculation, retrieve the value of a control, supply criteria to a query, define rules, create calculated controls and calculated fields, and define a group level for a report. Each expression evaluates to a single value.

### Identifiers
An identifier is the name of a field, property, or control. You use an identifier in an expression to refer to the value that is associated with a field, property, or control.

### Operators
Access supports a variety of operators, including the expected arithmetic operators such as + (multiply), / (divide), as well as comparison operators for comparing values, text operators for concatenating text, logical operators for determining true or false values, and other operators specific to Access.

### Functions
Functions are built-in procedures that you can use in your expressions. You use them to perform calculations, manipulate text and dates, summarize data, and perform a wide variety of operations. For example, one of the more commonly used functions is **Date**. The **Date** function returns the current date. You might use it in an expression that sets the default value for a field in a table. That way, whenever a new record is added, the field defaults to the current date.

Some functions require **arguments**. An argument is a value that serves as input to the function. If a function requires more than one argument, you separate the arguments with a comma. For example, consider the **Format** function in the following example expression:

```
=Format(Date(),"mmm, d, yyyy")
```

In this example, we supply two arguments. The first is the **Date** function. You can often supply the value that a function returns as an argument to yet another function. In this case, we supply the current date, as returned by the **Date** function. The second argument, separated from the first by a comma, is a text string that tells the **Format** function how to format the date. Note that the text string is enclosed in quotation marks. As a general rule, when you need to supply text, place it inside quotation marks.

### Constants
A constant is a named item whose value remains constant while Access is running. The constants you'll use most often in your expressions are **True**, **False**, and **Null**.
Values

You can employ literal values in your expressions. Numeric values can be a series of digits, including a sign and a decimal point, if needed. In the absence of a sign, Access assumes a positive value. To make a value negative, include the minus sign (-). You can also use scientific notation. To do so, include E or e and the sign of the exponent (for example, 1.0E-6).

Text string values should be placed within quotation marks. In some circumstances, Access will supply them for you. For example, if you type the text Paris, Access displays "Paris" in the expression. If you want an expression to produce a string that is actually enclosed in quotation marks, you can enclose the nested string either in single (') quotation marks or within three sets of double (") quotation marks.

For example, the following expressions are equivalent:

Forms![Contacts]![City].DefaultValue = ' "Paris" '
Forms![Contacts]![City].DefaultValue = " " "Paris" " "

Date/Time values should be enclosed in number signs (#). For example, #3-7-05#, #7-Mar-05#, and #Mar-7-2005# are all valid Date/Time values. When Access sees a valid Date/Time value enclosed by # characters, it automatically treats the value as a Date/Time data type.

In Access, expressions are used in many places to perform calculations, manipulate characters, or test data. Tables, queries, forms, reports, and macros all have properties that accept an expression. For example, you can use expressions in the **Control Source** and **Default Value** properties for a control.

The following expression contains four of the previously mentioned elements:

=Sum([Purchase Price])*0.08

In this example, **Sum()** is a built-in function, **[Purchase Price]** is an identifier, *** is a mathematical operator, and **0.08** is a constant. This expression can be used in a text box in a form footer to calculate sales tax for a group of items.

Why use expressions?

In Access, you use expressions often and for a variety of reasons. For example, when you want to calculate a value for a field on a form, you use an expression. Let's say you want to calculate the total dollar amount for a line item in an invoice. Typically, you do not store the line item total in the database. Instead, you calculate it as needed from two items that you should store in the database — quantity and price.

=CCur([Quantity]*[Price])

This expression multiplies **quantity** times **price** and then uses the **CCur** function (convert to currency) to convert the result to the Currency data type.

You usually use a text box control to hold a calculated value, but you can use any control that has a **ControlSource** property. A control that has an expression as its control source is called a calculated control. If the control is a text box, you can enter the expression directly in the text box. You can also enter it in the **ControlSource** property in the property sheet.
Besides using an expression to calculate a needed value that isn’t stored in the database, you often use an expression to supply information to a query. For example, suppose you want to see product sales that were shipped within a certain time frame. You can enter a criteria expression that uses the Between operator to define the date range. Access returns only the rows that match the criteria and have a shipped date within the specified date range:

Between #1/1/2004# And #12/31/2004#

You might also decide that a good place to calculate a line item total is in the query that provides the form or report with its data. A column in a query that results from such a calculation is called a calculated field.

Another good use of an expression is to provide a default value for a field in a table or for a control. For example, if you have a date field that you want to default to the current date, you can type Date() in the Default Value property box for that field. You can also use an expression to set a validation rule. For example, you might use a validation rule that requires the date that is entered to be greater than or equal to the current date. In that case, you set the value in the Validation Rule property box to >= Date().

Table of operators
Access supports a variety of operators, including arithmetic operators such as +, -, *, (multiply), and / (divide), as well as comparison operators for comparing values, text operators for concatenating text, logical operators for determining true or false values, and other operators specific to Access.

**Arithmetic operators**
You use the arithmetic operators to calculate a value from two or more numbers or to change the sign of a number from positive to negative.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Purpose</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Sum two numbers.</td>
<td>[Subtotal]+[SalesTax]</td>
</tr>
<tr>
<td>-</td>
<td>Find the difference between two numbers or indicate the negative value of a number.</td>
<td>[Price]-[Discount]</td>
</tr>
<tr>
<td>*</td>
<td>Multiply two numbers.</td>
<td>[Quantity]*[Price]</td>
</tr>
<tr>
<td>/</td>
<td>Divide the first number by the second number.</td>
<td>[Total]/[ItemCount]</td>
</tr>
<tr>
<td>^</td>
<td>Raise a number to the power of an exponent.</td>
<td>Number ^ Exponent</td>
</tr>
</tbody>
</table>

**Comparison operators**
You use the comparison operators to compare values and return a result that is true, false, or null.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;</td>
<td>Determine if the first value is less than the second value.</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Determine if the first value is less than or equal to the second value.</td>
</tr>
<tr>
<td>&gt;</td>
<td>Determine if the first value is greater than the second value.</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Determine if the first value is greater than or equal to the second value.</td>
</tr>
<tr>
<td>=</td>
<td>Determine if the first value is equal to the second value.</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Determine if the first value is not equal to the second value.</td>
</tr>
</tbody>
</table>

In all cases, if either the first value or the second value is null, the result is then also null. Because null represents an unknown value, the result of any comparison with null is also unknown.
Logical operators
You use the logical operators to combine two values and return a true, false, or null result. You might also see the logical operators referred to as *Boolean* operators.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Usage</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>And</td>
<td>Expr1 And Expr2</td>
<td>True when Expr1 and Expr2 are true.</td>
</tr>
<tr>
<td>Or</td>
<td>Expr1 Or Expr2</td>
<td>True when either Expr1 or Expr2 is true.</td>
</tr>
<tr>
<td>Eqv</td>
<td>Expr1 Eqv Expr2</td>
<td>True when both Expr1 and Expr2 are true or both Expr1 and Expr2 are false.</td>
</tr>
<tr>
<td>Not</td>
<td>Not Expr</td>
<td>True when Expr is not true.</td>
</tr>
<tr>
<td>Xor</td>
<td>Expr1 Xor Expr2</td>
<td>True when either Expr1 is true, or Expr2 is true, but not both.</td>
</tr>
</tbody>
</table>

Concatenation operators
You use the concatenation operators to combine two text values into one.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Usage</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&amp;</td>
<td>string1 &amp; string2</td>
<td>Combines two strings to form one string.</td>
</tr>
<tr>
<td>+</td>
<td>string1 + string2</td>
<td>Combines two strings to form one string and propagates null values.</td>
</tr>
</tbody>
</table>

Special operators
You use the special operators as described in the following table.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
<th>For More Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>Is (Not) Null</td>
<td>Determines whether a value is Null or Not Null.</td>
<td></td>
</tr>
<tr>
<td>Like &quot;pattern&quot;</td>
<td>Matches string values by using wildcard operators ? and *.</td>
<td>Like Operator</td>
</tr>
<tr>
<td>Between val1 And val2</td>
<td>Determines whether a numeric or date value falls within a range.</td>
<td>Between...And Operator</td>
</tr>
<tr>
<td>In(string1,string2...)</td>
<td>Determines whether a string value is within a set of string values.</td>
<td>In Operator</td>
</tr>
</tbody>
</table>

Add a calculated text box
1) Open the form in Design view by right-clicking the form or report in the Navigation Pane, and then clicking **Design View**.
2) On the **Design** tab, in the **Controls** group, click **Text Box**.
3) Position the pointer where you want the text box to be placed on the form or report, and then click to insert the text box.
4) Do one of the following:
   a) Place the cursor in the text box, and then type an expression that calculates a total.
   b) Select the text box, press **F4** to display the property sheet, and type the expression in the Control Source property box.
5) Save the form and then switch to Form view to check the results.
Notes:

- If you need more room to type an expression in the **ControlSource** property box, press **SHIFT+F2** to open the **Zoom** box.

- If your form is based on a query, you might want to put the expression in the query instead of in a calculated control. Doing this can improve performance, and if you are going to calculate totals for groups of records, it is easier to use the name of a calculated field in an aggregate function (A function, such as Sum, Count, Avg, or Var, that you use to calculate totals).

**Change a bound control to a calculated control**

A good way to create a calculated control is by first creating a bound control (for example, by dragging a field from the Field list pane to your form or report), and then editing the bound control's **Control Source** property to create an expression. This works well, as long as you ensure that the name of the control does not conflict with any of the field names contained in the expression.

Assuming you have already created your bound control, use the following procedure to change it to a calculated control and avoid any name conflicts.

1) Right-click the form in the Navigation Pane, and then click **Design View**.

2) Click the field you want to change, and then press **F4** to open the property sheet.

3) On the **All** tab of the property sheet, if the **Name** property matches the **Control Source** property, edit the **Name** property so that the two properties do not match.

4) Edit the string in the **Control Source** property box so that it contains the expression you want.

5) Press **CTRL+S** to save your changes.

6) Switch to Layout view or Form view and verify that the calculated control works as you expect.

If the control does not display the data you want (for example, if Access displays **#Name?** in the control), check the record source of the form or report to ensure that all the fields you used in the expression are available. If the record source is a query, you might need to add one or more fields to the query before the expression will work.
Create a macro
You can create a macro (An action or set of actions that you can use to automate tasks.) to perform a specific series of actions (The basic building block of a macro; a self-contained instruction that can be combined with other actions to automate tasks. This is sometimes called a command in other macro languages.), and you can create a macro group (A collection of related macros that are stored together under a single macro name. The collection is often referred to simply as a macro.) to perform related series of actions.

In Microsoft Office Access 2007, macros can be contained in macro objects (sometimes called standalone macros), or they can be embedded into the event properties of forms, reports, or controls. Embedded macros become part of the object or control in which they are embedded. Macro objects are visible in the Navigation Pane, under Macros; embedded macros are not.

Learn about the Macro Builder
You use the Macro Builder to create and modify macros. To open the Macro Builder:

1) On the Create tab, in the Other group, click Macro.
   a) If this command is unavailable, click the arrow beneath either the Module or the Class Module button, and then click Macro.
   • The Macro Builder is displayed.

   In the Macro Builder window, you build the list of actions that you want to carry out when the macro runs. When you first open the Macro Builder, the Action column, the Arguments column, and the Comment column are displayed.

   Under Action Arguments, you enter and edit arguments on the left side for each macro action, if any are required. A description box that gives you a short description of each action or argument is displayed on the right side. Click an action or action argument to read the description in the box.

   You can use the commands on the Design tab of the Macro Builder to create, test, and run a macro.
Create a standalone macro
1) On the Create tab, in the Other group, click Macro.
   a) The Macro Builder is displayed.
2) Add an action to the macro:
   a) In the Macro Builder, click the first empty cell in the Action column.
   b) Type the action that you want to use, or click the arrow to display the list of available actions, and then select the action that you want to use.
   c) Under Action Arguments (in the lower part of the Macro Builder), specify arguments for the action, if any are required.
3) To add more actions to the macro, move to another action row, and then repeat step 2.
   a) When you run the macro, Access carries out the actions in the order in which you list them.

Notes:
- As you type arguments in the Action Arguments pane, they are displayed in the Arguments column in the action list. However, the Arguments column is for display only; you cannot enter arguments in that column.
- To see a short description of each argument, in the Action Arguments pane, click in the argument box, and then read the description in the adjacent box.

Tips:
- For an action argument (Additional information required by some macro actions. For example, the object affected by the action or special conditions under which the action is carried out.) whose setting is a database object name, you can set the argument by dragging the object from the Navigation Pane to the action's Object Name argument box.
- You can also create an action by dragging a database object from the Navigation Pane to an empty row in the Macro Builder. If you drag a table, query, form, report, or module to the Macro Builder, Access adds an action that opens the table, query, form, or report. If you drag a macro to the Macro Builder, Access adds an action that runs the macro.
- Optionally, type a comment for the action in the Comment column.

Create an embedded macro
Embedded macros differ from standalone macros in that they are stored in the event properties of forms, reports, or controls. They are not displayed as objects under Macros in the Navigation Pane. This can make your database easier to manage, because you don't have to keep track of separate macro objects containing
macros for a form or report. Also, embedded macros are included with the form or report whenever you copy, import, or export it.

1) In the Navigation Pane, right-click the form that will contain the macro, and then click **Design View** or **Layout View**.
   a) If the property sheet is not already displayed, press **F4** to display it.
2) Click the control or section that contains the event property in which you want to embed the macro. You can also select the control or section (or the entire form) by using the drop-down list under **Selection Type** at the top of the property sheet.
3) On the property sheet, click the **Event** tab.
   a) Click the event property in which you want to embed the macro, and then click the **Build** button.
   b) In the **Choose Builder** dialog box, click **Macro Builder**, and then click **OK**.
   c) In the Macro Builder, click in the first row of the **Action** column.
      • In the **Action** drop-down list, click the action that you want.
      • Enter any required arguments under **Action Arguments**.
   d) If you want to add another action, click in the next row of the **Action** column and repeat the above steps.
   e) When your macro is complete, click **Save**, and then click **Close**.
      • The macro runs each time that the event property is triggered.

*Learn more about macro actions*

While you are working in the Macro Builder, you can learn more about an action or argument by clicking it and reading its description in the box in the lower-right corner of the Macro Builder window. Also, each macro action has a Help topic associated with it. To learn more about an action, choose the action from the action list, and then press **F1**.

**Edit a macro**

- **To insert an action row**: Right-click the action row above which you want to insert the new action row, and then click **Insert Rows**.
- **To delete an action row**: Right-click the action row that you want to delete, and then click **Delete Rows**.
- **To move an action row**: Select the action row by clicking the row header to the left of the action, and then drag it to a new position.

You can insert, delete, or move multiple rows by first selecting the group of rows, and then performing the operation you want. To select a group of rows, click the row header for the first row you want to select, hold down the **SHIFT** key, and then click the row header for the last row you want to select. (The row header is the shaded box to the left of each action row.)

An alternative method of selecting multiple rows is to position the pointer over the row header of the first row you want to select, and then click and drag up or down to select the other rows.

**Note:** When selecting rows by clicking and dragging, the first row you select must not already be selected. If it is already selected, Access will assume you are trying to drag the row to a new location.