# Working with Excel 2007 Tables

## Table of Contents

### OVERVIEW OF EXCEL TABLES
- WHAT HAPPENED TO EXCEL LISTS? ................................................................. 3
- Symptoms ........................................................................................................ 3
- Cause .............................................................................................................. 3
- Resolution ...................................................................................................... 3
- NEW TABLE MANAGEMENT FEATURES IN EXCEL 2007 .......................... 3
- LEARN ABOUT THE ELEMENTS OF AN EXCEL TABLE ............................... 5
- HOW TO ORGANIZE A TABLE ...................................................................... 6

### CREATING AND USING A TABLE ................................................................. 6
- INSERT A TABLE ............................................................................................ 6
- DELETE A TABLE .......................................................................................... 7
- TURN EXCEL TABLE HEADERS ON OR OFF ............................................... 7
  - Overwriting default headers ..................................................................... 7
- SELECTING ROWS AND COLUMNS WITHIN A TABLE ............................... 8
- ADD OR REMOVE TABLE ROWS AND COLUMNS IN AN EXCEL TABLE ...... 8
  - Insert a table row or column .................................................................... 9
  - Delete rows or columns in a table ............................................................ 9
- REMOVE DUPLICATE ROWS FROM A TABLE ............................................ 10
- REMOVE BLANK ROWS FROM A TABLE ..................................................... 10
- INCLUDE A WORKSHEET ROW OR WORKSHEET COLUMN IN A TABLE .. 10
- RESIZE A TABLE .......................................................................................... 11
- NAMING A TABLE ........................................................................................ 11
  - Rename an Excel table ............................................................................ 11
- EXPANDING A TABLE .................................................................................. 12
- CONVERT A TABLE TO A RANGE OF DATA ............................................. 13
  - Turning a table back into an ordinary range ......................................... 13
- TOTAL THE DATA IN AN EXCEL TABLE .................................................. 13

### FORMAT AN EXCEL TABLE ....................................................................... 15
- CHOOSE A TABLE STYLE WHEN YOU CREATE A TABLE ......................... 16
  - Apply a table style to an existing table .................................................... 16
  - Remove a table style ................................................................................ 16
  - Choose table style options to format the table elements ..................... 17
  - Create a custom table style ..................................................................... 17
  - Delete a custom table style .................................................................... 17
FILTER DATA IN A RANGE OR TABLE ............................................................... 18
FILTER TEXT ................................................................................................. 18
FILTER NUMBERS ......................................................................................... 20
FILTER DATES OR TIMES ............................................................................. 20
  Ungroup the hierarchy of dates in the AutoFilter menu .................................. 22
FILTER FOR TOP OR BOTTOM NUMBERS ...................................................... 22
FILTER FOR BLANKS OR NONBLANKS .......................................................... 22
FILTER BY CELL COLOR, FONT COLOR, OR ICON SET .................................. 23
FILTER BY SELECTION ................................................................................. 23
FILTER BY USING ADVANCED CRITERIA ...................................................... 23
FILTER FOR UNIQUE VALUES OR REMOVE DUPLICATE VALUES .................. 24
  Filter for unique values ............................................................................ 24
  Remove duplicate values .......................................................................... 25

USING SUBTOTALS IN A LIST OF DATA IN A WORKSHEET ......................... 25
INSERT SUBTOTALS ..................................................................................... 26
INSERT NESTED LEVELS OF SUBTOTALS: .................................................. 27
REMOVE SUBTOTALS ................................................................................... 28
Overview of Excel tables
To make managing and analyzing a group of related data easier, you can turn a range of cells into a Microsoft Office Excel table (previously known as an Excel list). A table typically contains related data in a series of worksheet rows and columns that have been formatted as a table. By using the table features, you can then manage the data in the table rows and columns independently from the data in other rows and columns on the worksheet.

What happened to Excel lists?

Symptoms
You cannot find the Excel List feature on the Ribbon, which is a component of the Microsoft Office Fluent user interface.

Cause
The Excel List feature still exists, but it has been renamed. Excel lists are now called Excel tables.

Resolution
To create an Excel table, select the range that you want to turn into a table, and then do one of the following:

- On the Insert tab, in the Tables group, click Table.
  - Keyboard shortcut: In addition to CTRL+L, you can now press CTRL+T to create a table.

- On the Home tab, in the Styles group, click Format as Table, and then select the format that you want to use.

Tips: This displays the Table Tools, adding a Design tab that provides access to additional table features, such as table options and styles.

New table management features in Excel 2007
Here are just some of the advances that Office Excel 2007 has made in the area of table management:

- Autoexpansion: If you add a row directly below the last row of a table or add a column directly to the right of a table, the table expands to incorporate the new row or column. All table styles, conditional formatting, calculations, and data validation rules extend to the new row or column. Charts based on data from the table also are similarly updated. Likewise, if you add a new column adjacent to the table, the new column is automatically incorporated into the table definition.

- Structured referencing: Instead of using cell references, such as A1, you can use structured references that reference table names in a formula. Formulas that reference elements of a table can use column names and other tags in place of ordinary cell addresses. This kind of referencing makes table calculations self-documenting and enhances reliability.

- Sorting improvements: Older versions of Excel let you sort data on as many as three criteria. In Excel 2007, you can sort on as many criteria as you please. You can also sort data based on the font or fill colors assigned to cells. You can sort tables in ascending or descending order or by color, or you can create a custom sort order.
• **Filtering improvements:** Filter drop-down lists are automatically added in the header row of a table. It’s easier now to filter a table so you see only the rows in which you’re currently interested. You can filter on multiple criteria or on icon sets applied via conditional formatting. You can filter tables to show only the data that meets the criteria that you specify, or you can filter by color. You can also use filters based on dynamic date definitions, such as last week or the current quarter.

• **Formula replication:** To use a single formula that adjusts for each row in a table, you can create a calculated column. A calculated column automatically expands to include additional rows so that the formula is immediately extended to those rows. If you add a column to a table that performs calculations based on table data, Excel automatically replicates the calculation formula throughout the column. You can quickly total the data in a table by displaying a totals row at the end of the table and then using the functions that are provided in drop-down lists for each totals row cell.

• **Removal of duplicate data:** A simple command lets you highlight and (optionally) remove duplicate rows from a table.

• **Table styles:** Excel 2007 comes with a large library of styles that you can use to apply consistent formatting to your tables. You can quickly format table data by applying a predefined or custom table style. You can also choose Table Styles options to display a table with or without a header or a totals row, to apply row or column banding to make a table easier to read, or to distinguish between the first or last columns and other columns in the table. If you use a style that adds banding to a table (displaying alternate rows in contrasting colors), the banding adjusts correctly to changes in sorting, filtering, and table dimension. You can also create your own table styles or customize any of the existing styles.

**Notes:**
If you used older versions of Excel, you’ll notice some terminology changes in Excel 2007. What was formerly called a list is now a table. The term AutoFilter has been replaced by the simpler Filter. And the AutoFormat command of yore is gone, replaced by Table Styles.

You can use one table to manage your data, but if you want to manage several groups of data, you can insert more than one table in the same worksheet.

Because table functionality is not supported in shared workbooks, you cannot create a table in a shared workbook.
Learn about the elements of an Excel table
A table can include the following elements:

- **Header row**: By default, a table has a header row. Every table column has filtering enabled in the header row so that you can filter or sort your table data quickly.

- **Banded rows**: By default, alternate shading or banding has been applied to the rows in a table to better distinguish the data.

- **Calculated columns**: By entering a formula in one cell in a table column, you can create a calculated column in which that formula is instantly applied to all other cells in that table column.

- **Total row**: You can add a total row to your table that provides access to summary functions (such as the AVERAGE, COUNT, or SUM function). A drop-down list appears in each total row cell so that you can quickly calculate the totals that you want.

- **Sizing handle**: A sizing handle in the lower-right corner of the table allows you to drag the table to the size that you want.
How to organize a table

In a sense, you can call anything you put in a contiguous block of spreadsheet cells a table, but in Excel the term has a more specific meaning. It refers to a block of data organized so that each row refers to an item (a person in an address list, a sale in a transaction log, a product in a product catalog, and so on) and each column contains one piece of information about that item (for example, the postal code of a contact, the date of a sale, or the catalog number of a product). In addition, for a block of data to become a table, you have to designate it as such.

Typically, the worksheet range defined as a table should have the following characteristics:

- The top row should consist of labels, with each label describing the contents of the column beneath it. Each label should be unique. (The labels row is not mandatory, but if you omit it Excel will generate one for you using default column names.)
- Each column should contain the same kind of information.
- Each category of information you want to be able to sort by, search on, or otherwise manipulate individually should occupy a separate column.

Creating and using a table

After you have some data in a worksheet range, you can designate that range as a table by selecting any cell within it and pressing Ctrl+T or Ctrl+L. That’s the easy way. If you want to work a little harder, you can click Table in the Tables group on the Insert tab. Either way, start by selecting a single cell anywhere in the table range before issuing the command. Excel will figure out the dimensions of the table for you and ask for confirmation in the Create Table dialog box:

Unless the program has made some kind of mistake, you can click OK to create your table. If you select more than one cell but less than the entire range before pressing Ctrl+T, Excel will try to create a table out of the specific cells you selected.

Note: Many new features of Excel tables do not work if your workbook is opened in Compatibility mode. You must convert a workbook you have saved with the type Excel 97–2003 Workbook to an Excel 2007 workbook in order to get the new functionality.

You can use one of two ways to create a table. You can either insert a table in the default table style or you can format your data as a table in a style that you choose.

Insert a table

1) On a worksheet, select the range of cells that you want to include in the table. The cells can be empty or can contain data.
2) On the Insert tab, in the Tables group, click Table.
3) If the selected range contains data that you want to display as table headers, select the My table has headers check box.
   a) Table headers display default names if you do not select the My table has headers check box. You can change the default names by typing the text that you want.
      Note: If you do not want to display table headers, you can turn them off later.
Tips:
- After you create a table, the **Table Tools** become available, and a **Design** tab is displayed. You can use the tools on the **Design** tab to customize or edit the table.
- Unlike lists in Office Excel 2003, a table does not have a special row (marked with *) for quickly adding new rows.

**Delete a table**
1) On a worksheet, select a table.
2) Press **DELETE**.

**Turn Excel table headers on or off**
When you create a Microsoft Office Excel table on a worksheet, table headers are automatically added and displayed by default.

Table headers either display default names that you can change on the worksheet, or you can specify that they display the header data that is on your worksheet. In a long table, table headers replace the worksheet column headings (column heading: The lettered or numbered gray area at the top of each column. Click the column heading to select an entire column. To increase or decrease the width of a column, drag the line to the right of the column heading.) so that they stay visible when you scroll the table data. If you do not want to view the table headers, you can turn them off.

**Note:** Table headers should not be confused with worksheet column headings or the headers for printed pages.

1) Click anywhere in the table to make sure that the active cell is in a table column.
2) On the **Design** tab, in the **Table Style Options** group, clear or select the **Header Row** check box to hide or display the table headers.

**Notes:**
- When you turn the table headers off, the table header AutoFilters and any applied filters are removed from the table.
- When you add a new column when table headers are not displayed, the name of the new table header cannot be determined by a series fill that is based on the value of the table header that is directly adjacent to the left of the new column. This only works when table headers are displayed. Instead, a default table header is added that you can change when you display table headers.
- Although it is possible to refer to table headers that are turned off in formulas, you cannot refer to them by selecting them. References in tables to a hidden table header return zero (0) values, but they remain unchanged and return the table header values when the table header is displayed again. All other worksheet references to the table header are adjusted when the table header is turned off and may cause formulas to return unexpected results.

**Overwriting default headers**
Notice that, in addition to recognizing the size of the table, Excel figures out whether the top row of your range is a header row—a row of column labels. If your range does not include such a row or if for some reason you choose to clear the **My Table Has Headers** check box in the **Create Table** dialog box, Excel will create a header row for you using labels such as Column 1, Column 2, and so on. Default headers like these are both ugly and pointless; it’s far better to set up your own descriptive headers before creating the table. But if you omit this step, you can always override the defaults later by selecting the header cells and typing over them, just as if they were ordinary worksheet cells. (They’re not quite ordinary data, actually; Excel won’t let you delete them, and if you try to clear a header, you’ll just get the default back.)
Selecting rows and columns within a table
Excel makes it easy to select rows and columns within a table. If you rest the pointer on the left edge of the first cell in a row, the pointer changes to a solid arrow. Click once, and you’ve selected the row. If your table happens to begin in column A of the worksheet, be sure you rest the pointer inside the first cell, rather than on the worksheet frame. On the frame, the pointer also changes to a solid arrow, but clicking here will select the entire worksheet row.

To select a column, rest the pointer near the top of the column’s heading, and then click. Clicking once selects the column’s data, excluding the header and the total (if you have displayed the total row). Clicking a second time selects the entire column—header, data, and total.

To select the entire table, rest the pointer on the upper-left corner of the first column’s header. When you see the pointer turn southeast, click. Click once for the data only or twice for everything—data, headers, and totals.

Selecting with the keyboard is even easier, particularly with a large table when the top and left edges are out of sight:
- Pressing **Shift+Spacebar** selects the current row, regardless of which cell is selected.
- Pressing **Ctrl+Spacebar** selects the current column’s data, omitting the header and total.
- Pressing **Shift+Ctrl+Spacebar** or **Ctrl+A** selects all the table’s data.

Multiple key presses expand the selection predictably:
- Pressing **Shift+Spacebar** twice selects the entire current worksheet row.
- Pressing **Ctrl+Spacebar** twice selects the current table column, with the header and total.
- Pressing **Ctrl+Spacebar** three times selects the entire current worksheet column.
- Pressing **Shift+Ctrl+Spacebar** or **Ctrl+A** twice gets the entire table, headers, and totals included. Pressing that combination a third time selects all gazillion cells of the worksheet.

Add or remove table rows and columns in an Excel table
After you create a Microsoft Office Excel table in your worksheet, you can easily add table rows and columns. You can quickly add a blank row at the end of the table, include adjacent worksheet rows or worksheet columns in the table, or insert table rows and table columns anywhere you want.

You can delete rows and columns as needed. You can also quickly remove rows that contain duplicate data from a table.

**Note:** Adding and removing table rows and columns is different from adding and removing worksheet rows and columns.
**Insert a table row or column**

1) Do one of the following:
   a) **To insert one or more table rows:** select one or more table rows above which you want to insert one or more blank table rows.
      
      **Tip:** If you select a cell or range in the last row, you can also insert a row above or below that row.
   b) **To insert one or more table columns:** select one or more table columns to the left of which you want to insert one or more blank table columns.
      
      **Tip:** If you select a cell or range in the last column, you can also insert a column to the left or to the right of that column.

2) On the **Home** tab, in the **Cells** group, click the arrow next to **Insert**.

3) Do one of the following:
   a) **To insert table rows:** click **Insert Table Rows Above**.
   b) **To insert a table row below the last row:** click **Insert Table Row Below**.
   c) **To insert table columns:** click **Insert Table Columns to the Left**.
   d) **To insert a table column to the right of the last column:** click **Insert Table Column to the Right**.

**Tip:** You can also right-click one or more table rows or table columns, point to **Insert** on the shortcut menu, and then select what you want to do from the list of options. Or you can right-click one or more cells in a table row or table column, point to **Insert**, and then click **Table Rows Above** or **Table Columns to the Left**.

**Delete rows or columns in a table**

1) Select one or more table rows or table columns that you want to delete.

   **Tip:** You can also just select one or more cells in the table rows or table columns that you want to delete.

2) On the **Home** tab, in the **Cells** group, click the arrow next to **Delete**, and then click **Delete Table Rows** or **Delete Table Columns**.

   **Tip:** You can also right-click one or more rows or columns, point to **Delete** on the shortcut menu, and then click **Table Columns** or **Table Rows**. Or you can right-click one or more cells in a table row or table column, point to **Delete**, and then click **Table Rows** or **Table Columns**.

**Add a blank row at the end of the table**

1) Press **TAB** in the last cell of the last row to add a blank row at the end of the table.

   **Note:** If a totals row is displayed in the table, pressing **TAB** in the last cell of the totals row does not add a new row.
**Remove duplicate rows from a table**

Just as you can remove duplicates from any selected data in Excel, you can easily remove duplicates from a table.

1) Click anywhere in the table.
2) On the **Data** tab, in the **Data Tools** group, click **Remove Duplicates**.

3) In the **Remove Duplicates** dialog box, under **Columns**, select the columns that contain duplicates that you want to remove.

   **Tip:** You can also click **Unselect All** and then select the columns that you want or click **Select All** to select all of the columns.

   ![Remove Duplicates dialog box](image)

**Note:** Duplicates that you remove are deleted from the worksheet. If you inadvertently delete data that you meant to keep, you can click **Undo** on the **Quick Access Toolbar** to restore the deleted data. You may also want to use conditional formats to highlight duplicate values before you remove them.

**Remove blank rows from a table**

1) Make sure that the active cell is in a table column.
2) Click the arrow down in the column header.
3) To filter for blanks, in the AutoFilter menu at the top of the list of values, clear **(Select All)**, and then at the bottom of the list of values, select **(Blanks)**.

   **Note:** The **(Blanks)** check box is available only if the range of cells or table column contains at least one blank cell.

4) Select the blank rows in the table, and then press **CTRL+ -** (hyphen).

   **Note:** You can use a similar procedure for filtering and removing blank worksheet rows.

**Include a worksheet row or worksheet column in a table**

1) Do one of the following:
   a) **To include a worksheet row in the table:** type a value or text in a cell that is directly below the table.
   b) **To include a worksheet column in the table:** type a value or text in a cell that is directly adjacent to the right of the table.
   c) **To include worksheet rows or worksheet columns by using the mouse:** drag the resize handle at the lower-right corner of the table down to select rows and to the right to select columns.
Resize a table
1) Click anywhere in the table.
2) On the Design tab, in the Properties group, click Resize Table.

3) In the Select the new data range for your table box, type the range that you want to use for the table.

Tip: You can also click the Collapse Dialog button at the right end of the Select the new data range for your table box and then select the range that you want to use for the table on the worksheet. When you finish, click the Collapse Dialog button again to display the entire dialog box.

Naming a table
When you designate a range as a table, Excel assigns a name to that table and displays the name in the Properties group on the Design tab.

Excel uses default names (Table1, Table2, and so on) unless you supply your own names. Does the name matter? Perhaps.

Formulas that take advantage of structured referencing use the table name, and a descriptive name serves the purpose of self-documentation better than a default name.

In the following formula: =SUM(Scores[Math]) for example, the word Scores is the table’s name. (The formula sums the values from the Math column of the Scores table.)

Giving a meaningful name to the table is particularly useful when you have multiple tables on a single worksheet and have formulas that refer to the tables. By using names for the tables, you can instantly tell when looking at a formula which table it is referencing.

Rename an Excel table
1) In the worksheet, click the table that you want to rename.
   a) This displays the Table Tools, adding the Design tab.
2) On the Design tab, in the Properties group, click the Table Name text box.
3) Type a new name.
4) Press ENTER.
Expanding a table
To add a new row to the end of a table, go to the bottom-right cell of the table (ignoring the total row, if there is one), and press Tab. Excel will extend the table for you, no questions asked, copying all formatting and formulas in the process. When you get to the last column in the new row, press Tab to create yet another new row. Thus, after you have created the stub of a table, you can expand it downward by simply typing in the usual way and pressing Tab between cells (or at any rate at the end of each row).

Note that pressing Tab creates a new table row above the total row, if your table has a total row. The total row simply moves down one row to accommodate your new data, and Excel updates the formulas appropriately. If you don’t have a total row in your table, you can also extend the table by simply typing in the blank row below the bottom row of the table. Using Tab to extend the table works whether you have a total row or not.

Automatic expansion works for columns as well as rows. If you type in any row of the column directly to the right of a table, Excel expands the table to include the new column. If the new data is a formula, the formula is replicated throughout the column.

If you don’t want the table to automatically expand or automatically fill columns with formulas, you can turn off the option.

1) Click the Microsoft Office Button, and then click Excel Options.
2) Select the Proofing category, and click AutoCorrect Options.
3) In the AutoCorrect dialog box click the AutoFormat As You Type tab.
   a) Clear the Include New Rows And Columns In Table check box to prevent Excel from expanding the table, and clear the Fill Formulas In Tables To Create Calculated Columns check box to prevent Excel from filling entire columns with identical formulas.

If you’re not currently displaying a total row with your table, you’ll find a minuscule handle in the lower-right corner of the cell occupying the lower-right corner of your table. This handle gives you yet another way to expand your table. Usually, it’s easier just to add data and let Excel expand the table. But if you want to add several new rows or columns all at once, the handle is a good way to do it.
**Convert a table to a range of data**

1) Click anywhere in the table.
   a) This displays the **Table Tools**, adding the **Design** tab.
2) On the **Design** tab, in the **Tools** group, click **Convert to Range**.

**Note:** Table features are no longer available after you convert the table back to a range. For example, the row headers no longer include the sort and filter arrows, and structured references (references that use table names) that were used in formulas turn into regular cell references.

**Tips:**
- You can also right-click the table, point to **Table**, and then click **Convert to Range**.
- Immediately after you create a table, you can also click **Undo** on the **Quick Access Toolbar** to convert that table back to a range.

**Turning a table back into an ordinary range**

If the need arises to turn a table back into an ordinary worksheet range, select any cell or block of cells within the table. Then click **Convert To Range** in the **Tools** group on the **Design** tab. Click **Yes** to answer the confirmation prompt. Note that after you change a table into a regular range, the formatting turns into regular cell formatting. This can cause unexpected behavior if you ever turn the range back into a table.

**Tip:** An easy way to tell whether a range is a table is to select a cell in the range and look at the Ribbon. If you see a **Table Tools** tab, then the current list has been converted to a table.

**Total the data in an Excel table**

You can quickly total the data in a Microsoft Office Excel table by displaying a totals row at the end of the table and then by using the functions that are provided in drop-down lists for each totals row cell.

1) Click anywhere in the table.
2) On the **Design** tab, in the **Table Style Options** group, select the **Total Row** check box.
   a) The total row appears as the last row in the table and displays the word **Total** in the leftmost cell.
3) In the total row, click the cell in the column for which you want to calculate a total, and then click the drop-down list arrow that appears.
4) In the drop-down list, select the function that you want to use to calculate the total.
   a) You can toggle the row on or off by selecting or clearing the **Total Row** check box.

**Tip:** Formulas that you can use in the total row are not limited to the functions in the list. You can enter any formula that you want in any total row cell.
Example of a total row.

By default, the total row applies the SUBTOTAL function, with a Function_num argument of 109, to the rightmost column of the table. (Using 109 in the Function_num argument creates a sum that ignores all rows hidden by filters.) That generates a sum in the lower-right corner—which might not be what you want. In the example, it would make more sense to show an average in that cell than a sum. It would also be useful to calculate averages in the Critical Reading, Writing, and Math columns, as well as the Total column. All that is quite easy to do. When you click the small arrow at the right edge of a total row cell, a list of alternative functions appears:
You can make the same list appear in any other total row cell (not just the rightmost) by selecting the cell and clicking the arrow that appears. You can also type directly over any of the total row cells. Here’s how you might make the total row look if you wanted to replace the sums with averages:

```
1000  Zukowski, Jake  432  482  577  1491
1001  Zwilling, Michael  488  599  550  1637

1002  Average

523.7  498.3  549.9  1571.9
```

A few more points to note about the total row:

- Unlike the total row in an Excel 2003 list, the Excel 2007 total row does not limit you to the commonplace aggregation functions. With the help of the **More Functions** command in the list, you can create any kind of formulas you want.

- Because the choices in the list—AVERAGE, COUNT, COUNT NUMBERS, and so on—generate formulas based on the SUBTOTAL function (using arguments in the 101–111 range), they ignore rows that are hidden by filters. If you want to aggregate based on all rows except those you manually hide, subtract 100 from the first argument function. For example, change SUBTOTAL(101,column) to SUBTOTAL(1,column). If you want aggregate calculations based on all rows, ignoring the column filter settings, change the formulas to standard aggregate functions. For example, substitute SUM(column) for SUBTOTAL(109,column).

- After you’ve customized the formulas in the total row, turning the total row off and then back on retains your customized formulas. If you frequently toggle the total row off and on, consider putting the command on your Quick Access Toolbar. (Click the **Design** tab under **Table Tools**, right-click the **Total Row** check box, and select **Add To Quick Access Toolbar**.)

- When you enter a formula in the row directly below a table without a total row, the total row is displayed with the formula and without the word Total.

**Format an Excel table**

Microsoft Office Excel provides numerous predefined table styles (or quick styles) that you can use to quickly format a table. If the predefined table styles don’t meet your needs, you can create and apply a custom table style. Although you can delete only a custom table style, you can remove any table style so that it is no longer applied to the data.

You can further adjust the table formatting by choosing Quick Styles options for table elements, such as header and total rows, first and last columns, and banded rows and columns.
Choose a table style when you create a table
1) On the worksheet, select a range of empty cells or cells that contain the data that you want to quickly format as a table.
2) On the Home tab, in the Styles group, click Format as Table.
   a) When you use Format as Table, Office Excel automatically inserts a table. If you don't want to work with your data in a table, you can convert the table to a regular range while keeping the table style formatting that you applied.
3) Under Light, Medium, or Dark, click the table style that you want to use.
   Note: Custom table styles are available under Custom after you create one or more of them.

Apply a table style to an existing table
1) On the worksheet, select the table to which you want to apply a table style.
2) On the Design tab, in the Table Styles group, do one of the following:
   a) Click the table style that you want to use.
      • Use the arrow buttons to scroll through the available table styles.
   b) Click the More button , and then under Light, Medium, or Dark, click the table style that you want to use.
   Note: When the Excel window is reduced in size, table styles will be available in the Table Quick Styles gallery in the Table Styles group.

Remove a table style
1) On the worksheet, select the table from which you want to remove the current table style.
2) On the Design tab, in the Table Styles group, click the More button .
3) Click Clear.
   a) The table will be displayed in the default table format.
   Note: Removing a table style does not remove the table. If you don't want to work with your data in a table, you can convert the table to a regular range.
Choose table style options to format the table elements
1) On the worksheet, select the table to which you want to apply table style options.
2) On the **Design** tab, in the **Table Style Options** group, do one of the following:

   a) **To turn the header row on or off**, select or clear the **Header Row** check box.
   
   b) **To turn the totals row on or off**, select or clear the **Totals Row** check box.
   
   c) **To display special formatting for the first column of the table**, select the **First Column** check box.
   
   d) **To display special formatting for the last column of the table**, select the **Last Column** check box.
   
   e) **To display odd and even rows differently for ease of reading**, select the **Banded Rows** check box.
   
   f) **To display odd and even columns differently for ease of reading**, select the **Banded Columns** check box.

Create a custom table style
**Important:** Custom table styles that you create are stored only in the current workbook and therefore are not available in other workbooks.
1) On the **Home** tab, in the **Styles** group, click **Format as Table**.
2) Select an existing table to display the **Table Tools**, and then on the **Design** tab, in the **Table Styles** group, click the **More** button.
3) Click **New Table Style**.
4) In the **Name** box, type a name for the new table style.
5) In the **Table Element** box, do one of the following:
   a) **To format an element**: click the element, and then click **Format**.
   
   b) **To remove existing formatting from an element**: click the element, and then click **Clear**.
6) On the **Font**, **Border**, and **Fill** tabs, select the formatting options that you want, and then click **OK**.
   
   **Tip:** Under **Preview**, you can see how the formatting changes that you made affect the table.
7) Repeat steps 5 and 6 for all table elements that you want to customize.
8) To use the new table style as the default table style in the current workbook, select the **Set as default table quick style for this document** check box.

Delete a custom table style
1) On the **Home** tab, in the **Styles** group, click **Format as Table**.
2) Under **Custom**, right-click the table style that you want to delete, and then click **Delete** on the shortcut menu.

**Note:** All tables in the current workbook that are using that table style will be displayed in the default table format.

Create and use Excel 2007 Tables - Training Session Handout
Topics came directly from Microsoft Excel Help.
Filter data in a range or table

Using AutoFilter to filter data is a quick and easy way to find and work with a subset of data in a range of cells or table column.

Filtered data displays only the rows that meet criteria (conditions you specify to limit which records are included in the result set of a query or filter) that you specify and hides rows that you do not want displayed. After you filter data, you can copy, find, edit, format, chart, and print the subset of filtered data without rearranging or moving it.

You can also filter by more than one column. Filters are additive, which means that each additional filter is based on the current filter and further reduces the subset of data.

Using AutoFilter, you can create three types of filters: by a list values, by a format, or by criteria. Each of these filter types is mutually exclusive for each range of cells or column table. For example, you can filter by cell color or by a list of numbers, but not by both; you can filter by icon or by a custom filter, but not by both.

Important: For best results, do not mix storage formats, such as text and number or number and date, in the same column because only one type of filter command is available for each column. If there is a mix of storage formats, the command that is displayed is the storage format that occurs the most. For example, if the column contains three values stored as number and four as text, the filter command that is displayed is Text Filters.

Filter text

1) Do one of the following:
   a) **Range of cells:**
      - Select a range of cells containing alphanumeric data.
      - On the Home tab, in the Editing group, click Sort & Filter, and then click Filter.
   b) **Table:**
      - Make sure that the active cell is in a table column that contains alphanumeric data.

2) Click the arrow in the column header.

3) Do one of the following:
   a) **Select from a list of text values:**
      - In the list of text values, select or clear one or more text values to filter by.
      - The list of text values can be up to 10,000. If the list is large, clear (Select All) at the top, and then select the specific text values to filter by.

Tip: To make the AutoFilter menu wider or longer, click and drag the grip handle at the bottom.
b) Create criteria:

- Point to **Text Filters** and then click one of the comparison operators commands, or click **Custom Filter**.
  1. To filter by text that begins with a specific character, select **Begins With**, or to filter by text that has specific characters anywhere in the text, select **Contains**.

- In the **Custom AutoFilter** dialog box, in the box on the right, enter text or select the text value from the list.
  1. For example, to filter by text that begins with the letter "J", enter J, or to filter by text that has "bell" anywhere in the text, enter bell.
  2. If you need to find text that shares some characters but not others, use a wildcard character.

The following wildcard characters can be used as comparison criteria for text filters:

<table>
<thead>
<tr>
<th>Use</th>
<th>To find</th>
</tr>
</thead>
<tbody>
<tr>
<td>? (question mark)</td>
<td>Any single character</td>
</tr>
<tr>
<td>* (asterisk)</td>
<td>Any number of characters</td>
</tr>
<tr>
<td>~ (tilde)</td>
<td>A question mark, asterisk, or tilde</td>
</tr>
</tbody>
</table>

- Optionally, **filter by one more criteria**.
  1. Do one of the following:
     a) To filter the table column or selection so that both criteria must be true, select **And**.
     b) To filter the table column or selection so that either or both criteria can be true, select **Or**.
  2. In the second entry, select a comparison operator, and then in the box on the right, enter text or select a text value from the list.
Filter numbers
1) Do one of the following:
   a) **Range of cells:**
      - Select a range of cells containing numeric data.
      - On the **Home** tab, in the **Editing** group, click **Sort & Filter**, and then click **Filter**.
   b) **Table:**
      - Make sure that the active cell is in a table column that contains numeric data.
2) Click the arrow \(\checkmark\) in the column header.
3) Do one of the following:
   a) **Select from a list of numbers:**
      - In the list of numbers, select or clear one or more numbers to filter by.
      - The list of numbers can be up to 10,000. If the list is large, clear (Select All) at the top, and then select the specific numbers to filter by.
   b) **Create criteria:**
      - Point to **Number Filters** and then click one of the comparison operator commands or click **Custom Filter**.
      (1) For example, to filter by a lower and upper number limit, select **Between**.
      - In the **Custom AutoFilter** dialog box, in the box or boxes on the right, enter numbers or select numbers from the list.
      (1) For example, to filter by a lower number of 25 and an upper number of 50, enter 25 and 50.
      - Optionally, **filter by one more criteria:**
      (1) Do one of the following:
      (a) To filter the table column or selection so that both criteria must be true, select **And**.
      (b) To filter the table column or selection so that either or both criteria can be true, select **Or**.
      (2) In the second entry, select a comparison operator, and then in the box on the right, enter a number or select a number from the list.

Filter dates or times
1) Do one of the following:
   a) **Range of cells:**
      - Select a range of cells containing numeric data.
      - On the **Home** tab, in the **Editing** group, click **Sort & Filter**, and then click **Filter**.
   b) **Table:**
      - Make sure that the active cell is in a table column that contains dates or times.
2) Click the arrow \(\checkmark\) in the column header.
3) Do one of the following:
   a) **Select from a list of dates or times:**
      - In the list of dates or times, select or clear one or more dates or times to filter by.
      - By default, all dates in the range of cells or table column are grouped by a hierarchy of years, months, and days. Selecting or clearing a higher level in the hierarchy selects or clears all nested
topics came directly from Microsoft Excel Help.

b) Create criteria:
- Point to Date Filters and then do one of the following:
  1) Common filter:
     - Note: A common filter is one based on a comparison operator.
     - Click one of the comparison operator commands (Equals, Before, After, or Between) or click Custom Filter.
     - In the Custom AutoFilter dialog box, in the box on the right, enter a date or time, select a date or time from the list, or click the Calendar button to find and enter a date.
     - For example, to filter by a lower and upper date or time, select Between.
     - In the Custom AutoFilter dialog box, in the box or boxes on the right, enter a date or time, select dates or times from the list, or click the Calendar button to find and enter a date.
     - For example, to filter by an earlier date of "3/1/2006" and a later date of "6/1/2006", enter 3/1/2006 and 6/1/2006. Or, to filter by an earlier time of "8:00 AM" and a later time of "12:00 PM", enter 8:00 AM and 12:00 PM.
  2) Dynamic filter:
     - Note: A dynamic filter is one where the criteria can change when you reapply the filter.
     - Click one of the pre-defined date commands.
     - For example, to filter all dates by the current date, select Today, or by the following month, select Next Month.
     - Click OK.

Notes:
- The commands under the All Dates in the Period menu, such as January or Quarter 2, filter by the period no matter what the year. This can be useful, for example, to compare sales by a period across several years.
- This Year and Year to Date are different in the way that future dates are handled. This Year can return dates in the future for the current year, whereas Year to Date only returns dates up to and including the current date.
- All date filters are based on the Gregorian calendar.
- Fiscal years and fiscal quarters always start in January of the calendar year.
- If you want to filter by days of the week, format the cells to show the day of the week. If you want to filter by the day of the week regardless of the date, convert them to text by using the TEXT function. However, the TEXT function returns a text value, and so the filter command that is displayed would be Text Filters, not Date Filters.
**Ungroup the hierarchy of dates in the AutoFilter menu**
For the list of dates at the bottom of the AutoFilter menu in a date filter, you can change the hierarchical grouping of dates to a nonhierarchical list of dates. For example, you can filter for just two-digit years by manually selecting them from a nonhierarchical list.

1) Click the **Microsoft Office Button**  
, click **Excel Options**, and then click the **Advanced** category.  
2) In the **Display options for this workbook** section, select a workbook, and then clear the **Group dates in the AutoFilter menu** check box.

**Filter for top or bottom numbers**
1) Do one of the following:
   a) **Range of cells:**
      - Select a range of cells containing numeric data.  
      - On the **Home** tab, in the **Editing** group, click **Sort & Filter**, and then click **Filter**.  
   b) **Table:**
      - Make sure that the active cell is in a table column that contains numeric data.
2) Click the arrow in the column header.  
3) Point to **Number Filters** and then select **Top 10**.  
4) In the **Top 10 AutoFilter** dialog box, do the following.  
   a) In the box on the left, click **Top** or **Bottom**.  
   b) In the box in the middle, enter a number.  
   c) In the box on the right, do one of the following:  
      - **To filter by number:** click **Items**.  
      - **To filter by percentage:** click **Percent**.  

**Note:** Top and bottom values are based on the original range of cells or table column and not the filtered subset of data.

**Filter for blanks or nonblanks**
1) Do one of the following:
   a) **Range of cells:**
      - Select a range of cells.  
      - On the **Home** tab, in the **Editing** group, click **Sort & Filter**, and then click **Filter**.  
   b) **Table:**
      - Make sure that the active cell is in a table column.  
2) Click the arrow in the column header.  
3) Do one of the following:  
   a) **To filter for nonblanks:** in the AutoFilter menu at the top of the list of values, select **(Select All)**, and then at the bottom of the list of values, clear **(Blanks)**.  
   b) **To filter for blanks:** in the AutoFilter menu at the top of the list of values, clear **(Select All)**, and then at the bottom of the list of values, select **(Blanks)**.  

**Note:** The **(Blanks) check box is available only if the range of cells or table column contains at least one blank cell.
Filter by cell color, font color, or icon set
If you have manually or conditionally formatted a range of cells, by cell color or font color, you can also filter by these colors. You can also filter by an icon set created through a conditional format.

1) Do one of the following:
   a) **Range of cells:**
      - Select a range of cells containing formatted by cell color, font color, or an icon set.
      - On the Home tab, in the Editing group, click Sort & Filter, and then click Filter.
   b) **Table:**
      - Make sure that the table column contains data formatted by cell color, font color, or an icon set (no selection is required).
2) Click the arrow in the column header.
3) Select **Filter by Color**, and then depending on the type of format, select **Filter by Cell Color**, **Filter by Font Color**, or **Filter by Cell Icon**.
4) Depending on the type of format, select a color, font color, or cell icon.

Filter by selection
You can quickly filter data with criteria that is equal to the contents of the active cell.

1) In a range of cells or table column, right click a cell containing the value, color, font color, or icon you want to filter by.
2) Click **Filter**, and then do one of the following:
   a) **To filter by text, number, or date or time:** click **Filter by Selected Cell's Value**.
   b) **To filter by cell color:** click **Filter by Selected Cell's Color**.
   c) **To filter by font color:** click **Filter by Selected Cell's Font Color**.
   d) **To filter by icon:** click **Filter by Selected Cell's Icon**.

Filter by using advanced criteria
To filter a range of cells by using complex criteria, use the **Advanced** command in the **Sort & Filter** group on the Data tab.

The **Advanced** command works differently from the **Filter** command in several important ways.

- It displays the **Advanced Filter** dialog box instead of the AutoFilter menu.
- You type the advanced criteria in a separate criteria range on the worksheet and above the range of cells or table you want to filter. Microsoft Office Excel uses the separate criteria range in the Advanced Filter dialog box as the source for the advanced criteria.

1) Click a cell in the range.
2) On the **Data** tab, in the **Sort & Filter** group, click **Advanced**.
3) Do one of the following:
   a) **To filter the range by hiding rows that don't match your criteria:** click Filter the list, in-place.
   b) **To filter the range by copying rows that match your criteria to another area of the worksheet:** click Copy to another location.
      - Click in the Copy to box, and then click the upper-left corner of the spreadsheet area where you want to paste the rows.
4) In the **Criteria range** box, enter the reference for the criteria range, including the criteria labels.
   a) To move the Advanced Filter dialog box out of the way temporarily while you select the criteria range, click Collapse Dialog.
5) Click OK.

**Filter for unique values or remove duplicate values**

In Microsoft Office Excel 2007, you have several ways to filter for unique values or remove duplicate values:

- To filter for unique values, use the **Advanced** command in the Sort & Filter group on the Data tab.
- To remove duplicate values, use the **Remove Duplicates** command in the Data Tools group on the Data tab.

Filtering for unique values and removing duplicate values are two closely related tasks because the displayed results are the same — a list of unique values. The difference, however, is important: When you filter for unique values, you temporarily hide duplicate values, but when you remove duplicate values, you permanently delete duplicate values.

A duplicate value is one where all values in the row are an exact match of all the values in another row. Duplicate values are determined by the value displayed in the cell and not necessarily the value stored in the cell. For example, if you have the same date value in different cells, one formatted as "3/8/2006" and the other as "Mar 8, 2006", the values are unique.

It's a good idea to filter for or conditionally format unique values first to confirm that the results are what you want before removing duplicate values.

**Filter for unique values**

1) Select the range of cells, or make sure the active cell is in a table.
2) On the **Data** tab, in the Sort & Filter group, click **Advanced**.
3) In the **Advanced Filter** dialog box, do one of the following:
   a) **To filter the range of cells or table in place:** click Filter the list, in-place.
   b) **To copy the results of the filter to another location:** do the following:
      - Click **Copy to another location**.
      - In the **Copy to** box, enter a cell reference.
         (1) Alternatively, click **Collapse Dialog** to temporarily hide the dialog box, select a cell on the worksheet, and then press **Expand Dialog**.
4) Select the **Unique records only** check box, and click **OK**.
   a) The unique values from the selected range are copied to the new location.
**Remove duplicate values**

When you remove duplicate values, only the values in the range of cells or table are affected. Any other values outside the range of cells or table are not altered or moved.

Caution: Because you are permanently deleting data, it's a good idea to copy the original range of cells or table to another worksheet or workbook before removing duplicate values.

1) Select the range of cells, or make sure that the active cell is in a table.
2) On the **Data** tab, in the **Data Tools** group, click **Remove Duplicates**.
3) Do one or more of the following:
   a) Under **Columns**, select one or more columns.
      - To quickly select all columns, click **Select All**.
      - To quickly clear all columns, click **Unselect All**.
      - If the range of cells or table contains many columns and you want to only select a few columns, you may find it easier to click **Unselect All**, and then under **Columns**, select those columns.
   b) Click **OK**.
      - A message is displayed indicating how many duplicate values were removed and how many unique values remain, or if no duplicate values were removed.
4) Click **OK**.

**Note:** You cannot remove duplicate values from data that is outlined or that has subtotals. To remove duplicates, you must remove both the outline and the subtotals.

**Using subtotals in a list of data in a worksheet**

You can automatically calculate subtotals and grand totals in a list for a column by using the **Subtotal** command in the **Outline** group on the **Data** tab.

- **Subtotals** are calculated with a summary function, such as Sum or Average, by using the SUBTOTAL function. You can display more than one type of summary function for each column.
- **Grand totals** are derived from detail data, not from the values in the subtotals. For example, if you use the Average summary function, the grand total row displays an average of all detail rows in the list, not an average of the values in the subtotal rows.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Sport</td>
<td>Sales</td>
</tr>
<tr>
<td>2</td>
<td>Golf</td>
<td>$5,000</td>
</tr>
<tr>
<td>3</td>
<td>Golf</td>
<td>$2,000</td>
</tr>
<tr>
<td>4</td>
<td>Golf</td>
<td>$1,500</td>
</tr>
<tr>
<td>5</td>
<td>Golf Total</td>
<td>$8,500</td>
</tr>
<tr>
<td>6</td>
<td>Safari</td>
<td>$9,000</td>
</tr>
<tr>
<td>7</td>
<td>Safari</td>
<td>$4,000</td>
</tr>
<tr>
<td>8</td>
<td>Safari Total</td>
<td>$13,000</td>
</tr>
<tr>
<td>11</td>
<td>Tennis Total</td>
<td>$2,000</td>
</tr>
<tr>
<td>12</td>
<td>Grand Total</td>
<td>$23,500</td>
</tr>
</tbody>
</table>

If the workbook is set to automatically calculate formulas, the Subtotal command recalculates subtotal and grand total values automatically as you edit the detail data. The Subtotal command also outlines the list so that you can display and hide the detail rows for each subtotal.
Insert subtotals
1) Make sure that each column has a label in the first row, contains similar facts in each column, and that the range has no blank rows or columns.
2) Select a cell in the range.
3) Do one of the following:
   a) **Insert one level of subtotals:**
      - **Sort** the column that forms the group.
      - On the **Data** tab, in the **Outline** group, click **Subtotal**.
   b) The **Subtotal** dialog box is displayed.
      - In the **At each change in** box, click the column to subtotal.
      - In the **Use function** box, click the summary function that you want to use to calculate the subtotals.
      - In the **Add subtotal to** box, select the check box for each column that contains values that you want to subtotal.
      - If you want an automatic page break following each subtotal, select the **Page break between groups** check box.
      - To specify a summary row above the details row, clear the **Summary below data** check box. To specify a summary row below the details row, select the **Summary below data** check box.
      - Click **OK**.

   ![Subtotal dialog box]

<table>
<thead>
<tr>
<th>A</th>
<th></th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td><strong>Region</strong></td>
<td><strong>Sport</strong></td>
<td><strong>Sales</strong></td>
</tr>
<tr>
<td>2</td>
<td>East</td>
<td>Golf</td>
<td>$5,000</td>
</tr>
<tr>
<td>3</td>
<td>East</td>
<td>Golf</td>
<td>$2,000</td>
</tr>
<tr>
<td>4</td>
<td>East</td>
<td>Golf</td>
<td>$1,500</td>
</tr>
<tr>
<td>5</td>
<td>Golf Total</td>
<td></td>
<td>$8,500</td>
</tr>
<tr>
<td>6</td>
<td>East</td>
<td>Safari</td>
<td>$9,000</td>
</tr>
<tr>
<td>7</td>
<td>East</td>
<td>Safari</td>
<td>$4,000</td>
</tr>
<tr>
<td>8</td>
<td>Safari Total</td>
<td></td>
<td>$13,000</td>
</tr>
<tr>
<td>9</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

At each change in the Sport column…
…subtotal the Sales column.

**Note:** optionally, you can use the **Subtotals** command again by repeating the steps to add more subtotals with different summary functions. To avoid overwriting the existing subtotals, clear the **Replace current subtotals** check box.
Insert nested levels of subtotals:
You can insert subtotals for inner, nested groups within their corresponding outer groups as shown in the following example.

1) Sort the columns that form the groups.
2) On the Data tab, in the Outline group, click Subtotal.
   a) In the At each change in box, click the column for the outer subtotals. In the example above, you would click Region.
   b) In the Use function box, click the summary function that you want to use to calculate the subtotals. In the example above, you would select Sum.
   c) In the Add subtotal to box, select the check box for each column that contains values that you want to subtotal. In the example above, you would select Sales.
   d) If you want an automatic page break following each subtotal, select the Page break between groups check box.
   e) To specify a summary row above the details row, clear the Summary below data check box. To specify a summary row below the details row, select the Summary below data check box.
   Note: optionally, you can use the Subtotals command again by repeating the steps to add more subtotals with different summary functions. To avoid overwriting the existing subtotals, clear the Replace current subtotals check box.
3) Insert the nested subtotals:
   a) On the Data tab, in the Outline group, click Subtotal.
   b) In the At each change in box, click the nested subtotal column. In the example above, you would select Sport.
   c) In the Use function box, click the summary function that you want to use to calculate the subtotals. In the example above, you would select Sum.
   d) Select any other options that you want.
   e) Clear the Replace current subtotals check box.
   f) Repeat the previous step for more nested subtotals, working from the outermost subtotals in.
**Tip:** To display a summary of just the subtotals and grand totals, click the outline symbols 1 2 3 next to the row numbers. Use the + and - symbols to display or hide the detail rows for individual subtotals.

**Remove subtotals**
When you remove subtotals, Microsoft Office Excel also removes the outline and any page breaks that you inserted into the list along with the subtotals.

1) Click a cell in the list that contains a subtotal.
2) On the **Data** tab, in the **Outline** group, click **Subtotal**.
3) The **Subtotal** dialog box is displayed.
4) Click **Remove All**.