# Creating Reports in Access 2007

Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>GUIDE TO DESIGNING REPORTS</strong></td>
<td>3</td>
</tr>
<tr>
<td>Decide how to lay out your report</td>
<td>3</td>
</tr>
<tr>
<td>Make a sketch of your report</td>
<td>3</td>
</tr>
<tr>
<td>Decide which data to put in each report section</td>
<td>4</td>
</tr>
<tr>
<td>Decide how to arrange the detail data</td>
<td>4</td>
</tr>
<tr>
<td>Use control layouts to align your data</td>
<td>6</td>
</tr>
<tr>
<td>Create a new control layout</td>
<td>6</td>
</tr>
<tr>
<td>Switch a control layout from tabular to stacked, or from stacked to tabular</td>
<td>6</td>
</tr>
<tr>
<td>Split one control layout into two layouts</td>
<td>7</td>
</tr>
<tr>
<td>Rearrange controls in a control layout</td>
<td>7</td>
</tr>
<tr>
<td>Remove controls from a control layout</td>
<td>7</td>
</tr>
<tr>
<td><strong>CREATE A SIMPLE REPORT</strong></td>
<td>7</td>
</tr>
<tr>
<td>Choose a record source</td>
<td>8</td>
</tr>
<tr>
<td>Use a query as a record source for a report using the Report Wizard</td>
<td>8</td>
</tr>
<tr>
<td>Set the Record Source property to a query in report Design view</td>
<td>8</td>
</tr>
<tr>
<td>Create a report by using the Report tool</td>
<td>8</td>
</tr>
<tr>
<td>Create a report by using the Report Wizard</td>
<td>9</td>
</tr>
<tr>
<td>Create a report by using the Blank Report tool</td>
<td>9</td>
</tr>
<tr>
<td>The Field List pane</td>
<td>9</td>
</tr>
<tr>
<td>Add fields from the Field List pane</td>
<td>11</td>
</tr>
<tr>
<td>Understand controls</td>
<td>11</td>
</tr>
<tr>
<td>Create a control by using the tools in the Controls group</td>
<td>12</td>
</tr>
<tr>
<td>Display the property sheet</td>
<td>12</td>
</tr>
<tr>
<td>Save your work</td>
<td>12</td>
</tr>
<tr>
<td>Save your report design</td>
<td>12</td>
</tr>
<tr>
<td>Save your report design under a new name</td>
<td>13</td>
</tr>
<tr>
<td><strong>VIEWING, PRINTING, AND DISTRIBUTING YOUR REPORT</strong></td>
<td>13</td>
</tr>
<tr>
<td>Switch between views</td>
<td>13</td>
</tr>
<tr>
<td>View your report in Report view</td>
<td>13</td>
</tr>
<tr>
<td>Work with your data in Report view</td>
<td>13</td>
</tr>
<tr>
<td>Print a report quickly</td>
<td>14</td>
</tr>
<tr>
<td>Print select pages from a report</td>
<td>14</td>
</tr>
<tr>
<td>Start print preview</td>
<td>14</td>
</tr>
<tr>
<td>Preview multiple pages</td>
<td>15</td>
</tr>
<tr>
<td>Close Print Preview</td>
<td>15</td>
</tr>
<tr>
<td>Change the page setup</td>
<td>15</td>
</tr>
<tr>
<td>Start the Page Setup dialog box from the Print dialog box</td>
<td>15</td>
</tr>
<tr>
<td>Change the page settings from Print Preview</td>
<td>15</td>
</tr>
<tr>
<td>Distribute a report electronically</td>
<td>16</td>
</tr>
<tr>
<td>Understand the file formats to which you can export a report</td>
<td>16</td>
</tr>
<tr>
<td>Distribute a report by using the E-mail command</td>
<td>17</td>
</tr>
<tr>
<td>Export a report as a snapshot file</td>
<td>17</td>
</tr>
<tr>
<td>Export a report as a *.pdf or *.xps file</td>
<td>18</td>
</tr>
</tbody>
</table>

Create Reports in Access 2007 Training Session Handout

Topics came directly from Microsoft Access Help.
CREATE A GROUPED OR SUMMARY REPORT ................................................................. 18
ABOUT GROUPING AND SORTING ............................................................................ 18
ADD GROUPING, SORTING, AND TOTALS BY USING THE GROUP, SORT, AND TOTAL PANE .................................................. 19
  Change grouping options ...................................................................................... 20
  Change the priority of grouping and sorting levels ................................................. 21
  Delete grouping and sorting levels ....................................................................... 21
ADD GROUPING, SORTING, AND TOTALS IN LAYOUT VIEW .................................... 21
  Sort on a single field ............................................................................................. 22
  Group on a field .................................................................................................... 22
BUILD A NEW GROUPED REPORT BY USING THE REPORT WIZARD ..................... 22
  Start the Report Wizard ....................................................................................... 22
  Group records in the Report Wizard .................................................................... 23
  Sort and summarize records ................................................................................ 23
MAKE A GROUP HEADER APPEAR AT THE TOP OF EACH PAGE ......................... 24
  Create a grouping effect without using headers ................................................. 24
CREATE A SUMMARY REPORT (WITHOUT RECORD DETAILS) ............................... 25
MODIFY A REPORT .................................................................................................... 25
UNDERSTAND LAYOUT VIEW .................................................................................. 26
  Add a field ............................................................................................................ 26
  Change column or field width .............................................................................. 26
  Change row or field height .................................................................................. 26
UNDERSTAND DESIGN VIEW ..................................................................................... 26
ADD A TEXT BOX CONTROL TO A REPORT .............................................................. 27
  Add a bound text box to a report by dragging a field from the Field List pane ...... 27
  Add an unbound text box ...................................................................................... 27
  Understand text box properties .......................................................................... 28
CHANGE THE RECORD SOURCE OF THE REPORT ..................................................... 28
ADD REPORT OR PAGE HEADER AND FOOTER SECTIONS ..................................... 28
  Remove report or page header and footer sections .......................................... 29
DELETE A FIELD OR COLUMN ................................................................................ 29
CHANGE THE FORMATTING OF A FIELD ................................................................ 29
WRAP TEXT IN A FIELD .......................................................................................... 29
ADD A TITLE TO A REPORT ...................................................................................... 30
  Edit the report title ................................................................................................ 30
ADD PAGE NUMBERS ............................................................................................... 30
ADD THE DATE OR TIME .......................................................................................... 30
ADD A TOTAL OR OTHER AGGREGATE TO A REPORT ........................................... 31
TYPES OF AGGREGATES THAT YOU CAN ADD TO A REPORT ............................... 31
ADD A TOTAL OR OTHER AGGREGATE IN LAYOUT VIEW ..................................... 31
ADD A TOTAL OR OTHER AGGREGATE IN DESIGN VIEW ...................................... 31
CREATE A CALCULATED CONTROL ......................................................................... 32
  Change a bound control to a calculated control ................................................. 32
  Learn which types of controls can be used as calculated controls ..................... 33
ADD A CALCULATED TEXT BOX .............................................................................. 33

Create Reports in Access 2007 Training Session Handout

Topics came directly from Microsoft Access Help.
Guide to designing reports
A Microsoft Office Access 2007 report is used to summarize and organize information. In large databases with many tables, each of which may contain thousands of records, gathering and reporting can be difficult and time consuming. Creating and using customized Access reports can provide you with an efficient tool that simplifies your reporting requirements and can be saved for future use.

Access 2007 provides you with a number of tools that help you to quickly build attractive, easy-to-read reports that present the data in a way that best suits the needs of its users. You can use the commands on the Create tab to create a simple report with a single click. You can use the Report Wizard to create a more complicated report, or you can create a report by adding all the data and formatting elements yourself. Whichever method that you choose, you will probably make at least a few changes to the design of the report to make it display the data the way that you want.

Decide how to lay out your report
When you design a report, you must first consider how you want the data arranged on the page and how the data is stored in the database. During the design process, you might even discover that the arrangement of data in the tables will not allow you to create the report that you want. This can be an indication that the tables are not normalized — this means that the data is not stored in the most efficient manner.

Make a sketch of your report
This step is not required — you might find that the Access Report Wizard or the Report tool (both of which are available on the Create tab, in the Reports group) provide a sufficient starting design for your report.

However, if you decide to design your report without using these tools, you might find it helpful to make a rough sketch of your report on a piece of paper by drawing a box where each field goes and writing the field name in each box. Alternatively, you can use programs such as Microsoft Office Word 2007 to create a mockup of the report. Whichever method that you use, be sure to include enough rows to indicate how the data repeats.

For example, you can use a row for product information, then several repeating rows for that product's sales, and finally a row of sales totals for the product. Then, the sequence repeats for the next product and so on until the end of the report. Or, perhaps your report is a simple listing of the data in the table, in which case your sketch can contain just a series of rows and columns.

Note: This technique is also very useful if you are designing a report for someone else. In this case, the other person can draw the sketch before you begin work.

After you create your sketch, determine which table or tables contain the data that you want to display on the report. If all the data is contained in a single table, you can base your report directly on that table. More often, the data that you want is stored in several tables that you must pull together in a query, before you can display it on the report. The query can be embedded in the Record Source property of the report, or you can create a separate, saved query and base the report on that.
Decide which data to put in each report section

In Access, the design of a report is divided into sections. You can view your report in Design view to see its sections. To create useful reports, you need to understand how each section works. For example, the section in which you choose to place a calculated control determines how Access calculates the results. The one section that is present in every report is the Detail section. This section repeats once for each record in the table or query that the report is based on. Other sections are optional and repeat less often and are usually used to display information that is common to a group of records, a page of the report, or the entire report.

The following list describes where each section is located and how the section is typically used.

- **Report Header**: This section is printed just once, at the beginning of the report. Use the report header for information that might normally appear on a cover page, such as a logo, a title, or a date. When you place a calculated control that uses the **Sum** aggregate function in the report header, the sum calculated is for the entire report. The report header is printed before the page header.

- **Page Header**: This section is printed at the top of every page. For example, use a page header to repeat the report title on every page.

- **Group Header**: This section is printed at the beginning of each new group of records. Use the group header to print the group name. For example, in a report that is grouped by product, use the group header to print the product name. When you place a calculated control that uses the **Sum** aggregate function in the group header, the sum is for the current group.

- **Detail**: This section is printed once for every row in the record source. This is where you place the controls that make up the main body of the report.

- **Group Footer**: This section is printed at the end of each group of records. Use a group footer to print summary information for a group.

- **Page Footer**: This section is printed at the end of every page. Use a page footer to print page numbers or per-page information.

- **Report Footer**: This section is printed just once, at the end of the report. Use the report footer to print report totals or other summary information for the entire report.

Decide how to arrange the detail data

Most reports are arranged in either a tabular or a stacked layout, but Office Access 2007 gives you the flexibility to use just about any arrangement of records and fields that you want.

**Tabular layout**: A tabular layout is similar to a spreadsheet. Labels are across the top, and the data is aligned in columns below the labels. Tabular refers to the table-like appearance of the data. This is the type of report that Office Access 2007 creates when you click **Report** in the **Reports** group of the **Create** tab. The tabular layout is a good one to use if your report has a relatively small number of fields that you want to display in a simple list format. The illustration shows an employee report that was created by using a tabular layout.
**Stacked layout:** A stacked layout resembles a form that you fill out when you open a bank account or make a purchase from an online retailer. Each piece of data is labeled, and the fields are stacked on top of each other. This layout is good for reports that contain too many fields to display in a tabular format — that is, the width of the columns would exceed the width of the report. The illustration shows an employee report that was created by using a stacked layout.

**Note:** In the Report Wizard, this layout is referred to as a columnar layout.

**Mixed layout:** You can mix elements of tabular and stacked layouts. For example, for each record, you can arrange some of the fields in a horizontal row at the top of the Detail section and arrange other fields from the same record in one or more stacked layouts beneath the top row. The following illustration shows an employee report that was created by using a mixed layout. The ID, Last Name, and First Name fields are arranged in a tabular control layout, and the Job Title and Business Phone fields are arranged in a stacked layout. In this example, gridlines are used to provide a visual separation of fields for each employee.

**Justified layout:** If you use the Report Wizard to create your report, you can choose to use a justified layout. This layout uses the full width of the page to display the records as compactly as possible. Of course, you can achieve the same results without using the Report Wizard, but it can be a painstaking process to align the fields exactly. The illustration shows an employee report that was created by using the Report Wizard's justified layout.

The justified layout is a good layout to use if you are displaying a large number of fields on the report. In the preceding example, if you use a tabular layout to display the same data, the fields extend off the edge of the page. If you use a stacked layout, each record takes up much more vertical space, which wastes paper and makes the report more difficult to read.
Use control layouts to align your data

Control layouts are a new feature in Office Access 2007. Control layouts are guides that you can add to a report while it is open in Layout view or Design view. Access 2007 adds control layouts automatically when you use the Report Wizard to build a report, or when you create a report by clicking Report in the Reports group of the Create tab. A control layout is like a table, each cell of which can contain a label, a text box, or any other type of control. The illustration shows a tabular control layout on a report.

The orange lines indicate the rows and columns of the control layout, and they are visible only when the report is open in Layout view or Design view. Control layouts help you achieve a uniform alignment of data in rows and columns, and they make it easier to add, resize, or remove fields. By using the tools in the Control Layout group on the Arrange tab (available in Layout view or Design view), you can change one type of control layout to another, and you can remove controls from layouts so that you can position the controls wherever you want on the report.

Create a new control layout

Access automatically creates columnar control layouts in the following circumstances:

- You create a new report by clicking Report in the Reports group on the Create tab.
- You create a new report by clicking Blank Report in the Reports group on the Create tab, and then dragging a field from the Field List pane to the report.

On an existing report, you can create a new control layout by doing the following:

1) Select a control that you want to add to the layout.
2) If you want to add other controls to the same layout, hold down the SHIFT key and also select those controls.
3) Do one of the following:
   a) On the Arrange tab, in the Control Layout group, click Tabular or Stacked.
   b) Right-click the selected control or controls, point to Layout, and then click Tabular or Stacked.
4) Access creates the control layout and adds the selected controls to it.

Switch a control layout from tabular to stacked, or from stacked to tabular

1) Select the control layout by clicking the orange layout selector at the top left corner of the layout.
   a) All the cells in the layout are selected.
2) Do one of the following:
   a) On the Arrange tab, in the Control Layout group, click the layout type you want (Tabular or Stacked).
   b) Right-click the control layout, point to Layout, and then click the layout type you want.
3) Access rearranges the controls into the layout type you selected.
**Split one control layout into two layouts**

1) Hold down the **SHIFT** key and click the controls you want to move to the new control layout.

2) Do one of the following:
   a) On the **Arrange** tab, in the **Control Layout** group, click the layout type you want for the new layout (Tabular or Stacked).
   b) Right-click the selected controls, point to **Layout**, and then click the layout type you want for the new layout.

3) Access creates a new control layout and adds the selected controls to it.

**Rearrange controls in a control layout**

- You can move a control within a control layout by dragging it to the location you want. As you drag the field, a horizontal or vertical bar indicates where it will be placed when you release the mouse button.
  - You can move a control from one control layout to another control layout of the same type. For example, you can drag a control from one stacked layout to another stacked layout, but not to a tabular layout.

**Remove controls from a control layout**

Removing a control from a control layout allows you to place it anywhere on the report without affecting the positioning of any other controls.

1) Select the control you want to remove from the layout.
   a) To select multiple controls, hold down the **SHIFT** key and then click the controls that you want to remove.
   b) To select all of the controls in the layout, click the layout selector box at the top left corner of the layout.

2) Do one of the following:
   a) On the **Arrange** tab, in the **Control Layout** group, click **Remove**.
   b) Right-click one of the selected controls, point to **Layout**, and then click **Remove**.

3) Access removes the selected controls from the layout.

**Tip:** To prevent a control from being inserted into a control layout as you move it, press and hold the **CTRL** key, and then drag the control to where you want it.

**Create a simple report**

You can create a variety of different reports in Microsoft Office Access 2007, ranging from the simple to the complex. Begin by thinking about your report's record source. Whether your report is a simple listing of records or a grouped summary of sales by region, you must first determine which fields contain the data you want to see in your report, and in which tables or queries they reside.

After you choose your record source, you will usually find it is easiest to create your report by using the Report Wizard. The Report Wizard is a feature in Access that guides you through a series of questions and then generates a report based on your answers.
Choose a record source
A report consists of information that is pulled from tables or queries, as well as information that is stored with the report design, such as labels, headings, and graphics. The tables or queries that provide the underlying data are also known as the report's record source. If the fields that you want to include all exist in a single table, use that table as the record source. If the fields are contained in more than one table, you need to use one or more queries as the record source. Those queries may already exist in your database, or you may need to create new queries specifically to fit the needs of your report.

Use a query as a record source for a report using the Report Wizard
2) In the Tables/Queries combo box, click the name of the query that you want to use as the report's record source.
   Note: The query must already exist.
3) In the Available Fields list box, double-click each field that you want to use.
   a) When you double-click a field, it is added to the Selected Fields list box.

Set the Record Source property to a query in report Design view
1) On the Create tab, in the Reports group, click Report Design.
   Note: If you see a Simple Report button instead of a Report Design button, click the arrow next to Simple Report, and then click Report Design.
2) If the report property sheet is not already open, press F4 to open it.
3) In the report property sheet, on the Data tab, click the Record Source property box.
   Note: If you don't see a Record Source property box, make sure that you are viewing the properties for the report itself, rather than the properties for a particular control that is on the report.
4) Do one of the following:
   a) Start typing the name of the query you want to use as the report's record source.
      - Access automatically fills in the name of the object as you type.
   b) Click the down arrow and then select the query that you want to use from the drop-down list that appears.

Create a report by using the Report tool
The Report tool provides the fastest way for you to create a report, because it generates a report immediately without prompting you for information. The report displays all the fields from the underlying table or query. The Report tool may not create the final, polished product that you ultimately want, but it is quite useful as a means to quickly look at the underlying data. You can then save the report and modify it in Layout view or Design view so that it better serves your purposes.
1) In the Navigation Pane, click the table or query on which you want to base the report.
2) On the Create tab, in the Reports group, click Report .
   a) Access builds the report and displays it in Layout view.

After viewing the report, you can save it and then close both the report and the underlying table or query that you used as a record source. The next time that you open the report, Access will display the most recent data from your record source.
Create a report by using the Report Wizard

You can use the Report Wizard to be more selective about what fields appear on your report. You can also specify how the data is grouped and sorted, and you can use fields from more than one table or query, provided you have specified the relationships between the tables and queries beforehand.

2) Follow the directions on the Report Wizard pages. On the last page, click Finish.

When you preview the report, you see the report as it will appear in print.

**Note:** If you want to include fields from multiple tables and queries in your report, do not click Next or Finish after you select the fields from the first table or query on the first page of the Report Wizard. Instead, repeat the steps to select a table or query, and click any additional fields that you want to include in the report. Then, click Next or Finish to continue.

Create a report by using the Blank Report tool

If you aren't interested in using the Report tool or the Report Wizard, you can use the Blank Report tool to build a report from scratch. This can be a very quick way to build a report, especially if you plan to put only a few fields on your report.

1) On the Create tab, in the Reports group, click Blank Report.
   a) A blank report is displayed in Layout view, and the Field List pane is displayed on the right side of the Access window.
2) In the Field List pane, click the plus sign next to the table or tables containing the fields that you want to see on the report.
3) Drag each field onto the report one at a time, or hold down CTRL and select several fields, and then drag them onto the report at the same time.
4) Use the tools in the Controls group on the Format tab to add a logo, title, page numbers, or the date and time to the report.

The Field List pane

The following list contains tips about working with the Field List pane that may be helpful to you as you add fields to your report. To display the Field List pane, open a report in Layout view or Design view, and then press ALT+F8.

- If the report's Record Source property is empty, and you drag a field from the Field List pane to the report, Access automatically fills in the report's Record Source property for you.
- If the report's Record Source property is a SELECT statement or a table name, you can toggle the Field List pane display between the following two states:
o All database fields: Displays the **Fields available for this view** section, the **Fields available in related tables** section (if such tables exist), and the **Fields available in other tables** section (if such tables exist).

- **Record source fields only:** Displays only the **Fields available for this view** section. To switch between the two modes, click either **Show only fields in the current record source** or **Show all tables** at the bottom of the **Field List** pane.

To edit the record source, right-click any one of the fields, and then click **Edit Record Source**.

**Note:** If you have set the report's **Record Source** property to a saved query, the **Field List** pane displays only the **Fields available for this view** section (there is no **Show all tables** option at the bottom of the **Field List** pane).

- If you have set the report's **Record Source** property to a table, and you then drag a field from the **Fields available in related tables** section of the **Field List** pane to the report, Access changes the **Record Source** of the report to a SELECT statement that includes the field you are adding. If Access cannot determine how to relate the tables, it displays the **Choose Relationship** dialog box so you can choose the appropriate relationship.

- If you drag a field from the **Fields available in other tables** section of the **Field List** pane to the report, Access displays the **Specify Relationship** dialog box. You must use this dialog box to specify a relationship between the other table and the report's record source. If you are not sure which fields to enter in this dialog box, you might want to click **Cancel** and then examine your table relationships.

It is possible that a field in the **Fields available in other tables** section of the **Field List** pane is indirectly related to the record source of the report through one of the tables in the **Fields available in related tables** section. If this is the case, dragging a field from one of the related tables to the report may cause one or more tables to move from the **Fields available in other tables** section to the **Fields available related tables** section.

- If the record source of the report is a SELECT statement or a saved query, you can view and edit the record source in the Query Builder by right-clicking any field in the **Field List** pane and then clicking **Edit Record Source**. If the record source is a table, this command invokes the Query Builder on the table. Access asks you if you want to create a query based on the table; click **Yes** to change the record source to a query, or **No** to leave the record source unchanged.
You can open a table in Datasheet view by clicking Edit Table next to the table name, or by right-clicking the table name in the Field List pane and then clicking Open Table in Datasheet View.

Add fields from the Field List pane
- To add a single field, drag the field from the Field List pane to the section where you want it displayed on the report.
- To add several fields at once, hold down CTRL and click the fields that you want. Then, drag the selected fields onto the report.

When you drop the fields onto a report section, Access creates a bound text box control for each field and automatically places a label control beside each field.

Understand controls
Controls are objects that display data, perform actions, and let you view and work with information that enhances the user interface, such as labels and images. Access supports three types of controls: bound, unbound, and calculated:

- **Bound control**: A control whose source of data is a field in a table or query is a bound control. You use bound controls to display values from fields in your database. The values can be text, dates, numbers, Yes/No values, pictures, or graphs. A text box is the most common type of bound control. For example, a text box on a report that displays an employee's last name might get this information from the Last Name field in the Employees table.

- **Unbound control**: A control that doesn't have a source of data (a field or expression) is an unbound control. You use unbound controls to display information, lines, rectangles, and pictures. For example, a label that displays the title of a report is an unbound control.

- **Calculated control**: A control whose source of data is an expression rather than a field is a calculated control. You specify the value that you want in the control by defining an expression as the source of data for the control. An expression is a combination of operators (such as = and + ), control names, field names, functions that return a single value, and constant values. For example, the following expression calculates the price of an item with a 25 percent discount by multiplying the value in the Unit Price field by a constant value (0.75).

\[ = \text{[Unit Price]} \times 0.75 \]

An expression can use data from a field in the report's underlying table or query, or from a control in the report.

When you create a report, it is probably most efficient to add and arrange all the bound controls first, especially if they make up the majority of the controls on the report. You can then add the unbound and calculated controls that complete the design by using the tools in the Controls group on the Design tab.

You bind a control to a field by identifying the field from which the control gets its data. You can create a control that is bound to the selected field by dragging the field from the Field List pane to the report. The Field List pane displays the fields of the report's underlying table or query. To display the Field List pane, on the Design tab, in the Controls group, click Add Existing Field.

Alternatively, you can bind a field to a control by typing the field name in the control itself or in the box for the Control Source value in the control's property sheet. The property sheet defines the characteristics of the control, such as its name, the source of its data, and its format.
Using the **Field List** pane is the best way to create a control for two reasons:

- A bound control has an attached label, and the label takes the name of the field (or the caption defined for that field in the underlying table or query) as its caption by default, so you don't have to type the caption yourself.
- A bound control inherits many of the same settings as the field in the underlying table or query (such as for the **Format**, **Decimal Places**, and **Input Mask** properties). Therefore, you can be sure that these properties for the field remain the same whenever you create a control that is bound to that field.

If you already created an unbound control and want to bind it to a field, set the control's **Control Source** property to the name of the field.

**Create a control by using the tools in the Controls group**

Some controls are created automatically, such as the bound text box control that is created when you add a field from the **Field List** pane to your report. Many other controls can be created in Design view by using the tools in the **Controls** group on the **Design** tab.

1) Click the tool for the type of control that you want to add.
   a) For example, to create a check box, click the **Check Box** tool.

2) Click in the report design grid where you want to position the upper-left corner of the control.
   a) Click once to create a default-sized control, or click the tool and then drag in the report design grid to create a control of the size that you want.

3) If you don’t position the control perfectly on the first try, you can move it by using the following procedure:
   a) Click the control to select it.
   b) Position the mouse pointer over the edge of the control until the pointer turns into a four-headed arrow.
   c) Drag the control to the location that you want.

This procedure creates an "unbound" control. If the control is the type that can display data (a text box or check box, for example), you need to enter a field name or expression in the **Control Source** property for the control before it will display any data.

**Display the property sheet**

To display the property sheet in Design view, do one of the following:

- On the **Design** tab, in the **Show/Hide** group, click **Property Sheet**.
- Press F4.

**Save your work**

After you save your report design, you can run the report as often as you need to. The report's design stays the same, but you get current data every time you print the report. If your reporting needs change, you can modify the report design or create a new, similar report based on the original.

**Save your report design**

1) Click the **Microsoft Office Button** and then click Save, or press CTRL+S.
2) If the report is untitled, type a name in the **Report Name** box, and then click **OK**.
Save your report design under a new name

1) Click the Microsoft Office Button , and then click Save As .
2) In the Save As dialog box, type a name in the Save Report to box, select Report in the As box, and then click OK.

Viewing, printing, and distributing your report

You can print a report from Print Preview, Layout view, Design view, Report view, or from the Navigation Pane. Before you print, you should double check page settings, such as margins and page orientation. Access saves the page settings with the report, so you need to set them only once. You can save the settings later, if your needs change.

There are several ways to view your report. Which method you choose depends on what you want to do with the report and its data:

- If you want to make temporary changes to which data appears on the report before you print it, or if you want to copy data from the report to the clipboard, use Report view.
- If you want to be able to change the design of the report while looking at the data, use Layout view.
- If you simply want to see what the report will look like when it is printed, use Print Preview.

Note: If your report is formatted with multiple columns, you can only see the column layout in Print Preview. Layout view and Report view display the report as a single column.

Switch between views

Access provides a variety of methods for switching between views. If the report is already open, you can switch to another view by doing one of the following:

- Right-click the report in the Navigation Pane, and then click the view you want on the shortcut menu.
- Right-click the report's document tab or title bar, and then click the view you want on the shortcut menu.
- On the Home tab, in the View group, click the View button to toggle between available views. Alternatively, you can click the arrow under View, and then select one of the available views from the menu. Print Preview is not available on this menu.
- Right-click in a blank area of the report itself, and then click the view you want. If the report is open in Design view, you must right-click outside of the design grid.
- Click one of the small view icons on the Access status bar.

View your report in Report view

Report view is the default view that is used when you double-click a report in the Navigation Pane. If the report is not open, double-click the report in the Navigation Pane to see it in Report view.

If the report is already open, right-click the report name in the Navigation Pane and then click Report View.

Work with your data in Report view

In Report view, you can select text and copy it to the clipboard. To select entire rows, click and drag in the margin next to the rows that you want to select. You can then copy these rows to the clipboard by doing one of the following:

- On the Home tab, in the Clipboard group, click Copy .
- Right-click the selected rows and then click Copy.
- Keyboard shortcut: Press CTRL+C.
Print a report quickly
If you want to print all the pages in the report without making any changes to the format of the report such as margins, headers, footers, and orientation (portrait or landscape) you can use the Quick Print option.

1) If the report is not open, in the Navigation Pane, right-click the report and click Print.

- or -

2) Make sure that the Quick Print button is available in the Quick Access Toolbar. To add the button to the toolbar, click the down-arrow at the end of the toolbar and click Quick Print.
   a) On the Quick Access Toolbar, click Quick Print.

Print select pages from a report
In a report, you can limit what you print only by selecting a range of pages.

1) Click the Microsoft Office Button, and then click Print.
2) To print only some of the data in the report, under Print Range, click Pages, and then enter a value in the From and the To boxes.
   a) For example, to print just page 5 of a report, type 5 in both the From and the To boxes.
3) If you own the necessary permissions to change the design of a report, you can make additional changes to the way that your report prints by changing the print layout in the Page Setup dialog box (click Setup to display the Page Setup dialog box).

Start Print Preview
When you want to see how your report will appear when printed, use Print Preview. If you preview a report that was created in Office Access 2007, the record navigation buttons appear in the default location, at the bottom of the Access window.

In Print Preview, you can zoom in to see details or zoom out to see how well the data is positioned on the page. With the cursor positioned over the report, click once. To reverse the effect of the zoom, click again. You can also use the zoom control on the Access status bar to zoom further in or out.

1) If the report is not open, in the Navigation Pane, right-click the report that you want to preview, and then click Print Preview on the shortcut menu.
   - or -

2) If the report is open, right-click the document tab for the report and click Print Preview.
3) Click the record navigation buttons to move among the pages in the report.

   1 Click to display the first page.
   2 Click to display the previous page.
   3 Click to display the next page.
   4 Click to display the last page.
   5 Type a page number in this box and then press ENTER to jump to a specific page.
**Preview multiple pages**

1) If the report is open, right-click the document tab for the report and click **Print Preview**.
2) On the **Print Preview** tab, in the **Preview** group, click **Two Pages** to preview your report two pages at a time.
   -or-
3) In the **Zoom** group, click **More Pages**, and then select an option.
4) Click the record navigation buttons to move among the pages in the report.
5) To revert to previewing a single page, in the **Preview** group, click **One Page**.

**Close Print Preview**

To close Print Preview, do one of the following:

- On the **Print Preview** tab, in the **Close Preview** group, click **Close Print Preview**.
- Right-click the report in the Navigation Pane and then click **Layout View** or **Design View** on the shortcut menu.

**Change the page setup**

The **Page Setup** dialog box can be used to change a variety of print options, including the top and bottom margins and whether Access prints just the data in your report. Access provides two ways to display the **Page Setup** dialog box. You can start it from within the **Print** dialog box, or you can start it from the **Print Preview** tab, which appears when you start Print Preview.

**Start the Page Setup dialog box from the Print dialog box**

1) In the Navigation Pane, select the report that you want to change.
   a) You do not need to open the report, although you can if you need to ensure that the data you are about to print is current.
2) Click the **Microsoft Office Button** , and then click **Print**.
   a) The **Print** dialog box appears.
3) Click **Setup** to display the **Page Setup** dialog box.
4) Set or change the options in the dialog box, as needed.
   a) For help with an option, click the **Help** button, and then click the field or control for which you need help.

**Change the page settings from Print Preview**

1) Open the report in **Print Preview**.
   a) You can change page settings in any view, but Print Preview is best because you can see the effects of any changes immediately.
2) On the **Page Layout** tab, in the **Page** group, click an option:
   a) **Size** allows you to select from a number of paper sizes, or to enter a custom paper size.
   b) **Portrait** orients the page vertically.
   c) **Landscape** orients the page horizontally.
   d) **Margins** allows you to select from several predefined margin widths, or you can click **Advanced** to enter custom margin widths by using the **Page Setup** dialog box.
   e) **Show Margins** toggles the display of margins on and off (Layout view only).
f) **Columns** displays the **Page Setup** dialog box. Enter the number of columns you want, set your desired column size, and then click **OK**.

g) **Print Data Only** suppresses the printing of any labels you have placed on your report. Only the controls that are bound to data in the underlying table or query will be printed. This feature can be helpful on reports that you occasionally print on pre-printed forms. You can suppress the printing of labels in those situations, and then enable the printing of labels when you are printing the report on blank paper.

**Note:** To use more detailed page settings, click the **Page Setup** button at the lower right corner of the **Page Layout** group to display the **Page Setup** dialog box. You can use the **Page Setup** dialog box to adjust all the settings that are available on the **Page Layout** tab, and also to select a specific printer for the report.

**Distribute a report electronically**
You can use Microsoft Office Access to electronically distribute your Access reports. For example, you can use the **E-mail** command on the Microsoft Office Button menu to quickly export and send the report as an attachment in an e-mail message. Or, you can export the report as a file, and then distribute the file in several different ways. By using electronic distribution methods, you can quickly get important information to those who need it. In addition, you can use the files to create backups and archives of reports, and you can also reduce paper usage in situations where printed copies of reports are not necessary.

**Understand the file formats to which you can export a report**
You can export a report as several different file formats. However, not all of these file formats preserve the layout and formatting of the original report. For example, if you export a report as an HTML file (*.htm or *.html), a Rich Text Format file (*.rtf), or a text file (*.txt), the resulting file will not contain all of the visual elements that were present in the original report, such as graphics, colors, lines, or borders. However, certain file formats do preserve the layout and formatting of the original report. These formats include the snapshot format (*.snp), the Portable Document Format format (*.pdf), and the XML Paper Specification format (*.xps).

The following table lists all of the available formats for exporting a report, and the programs that you and your recipients can use to open the resulting files.

<table>
<thead>
<tr>
<th>Format</th>
<th>File extension(s)</th>
<th>Programs that are used to open the file</th>
</tr>
</thead>
<tbody>
<tr>
<td>HTML</td>
<td>*.htm; *.html</td>
<td>Internet browsers, such as Microsoft Internet Explorer.</td>
</tr>
<tr>
<td>PDF</td>
<td>*.pdf</td>
<td>PDF readers, available as free, third-party downloads.</td>
</tr>
<tr>
<td>Rich Text</td>
<td>*.rtf</td>
<td>Word processing programs, such as Microsoft Office Word and WordPad.</td>
</tr>
<tr>
<td>Snapshot</td>
<td>*.snp</td>
<td>Microsoft Snapshot Viewer, available from the Microsoft Download Center.</td>
</tr>
<tr>
<td>Text</td>
<td>*.txt</td>
<td>Word processing and text editing programs, such as Word and Notepad.</td>
</tr>
</tbody>
</table>

**Note:** The **PDF Format** (*.pdf) and **XPS Format** (*.xps) options are available after you install an add-in.
**Distribute a report by using the E-mail command**

One of the fastest ways to distribute a report in Office Access 2007 is by using the **E-mail** command on the Microsoft Office Button menu. With just a few mouse clicks, Access exports the report to the file format that you want, and then creates a new e-mail message with the file attached to it.

1) In the Navigation Pane, select the report that you want to send in an e-mail message.

2) Click the **Microsoft Office Button**  
   and then click **E-mail**.

3) In the **Send Object As** dialog box, select the output format that you want to use, and then click **OK**.
   
   **Remember that **Snapshot Format (*.snp)**, **PDF Format (*.pdf)**, and **XPS Format (*.xps)** are the only options that will preserve the layout and formatting of your original report.

   a) Office Outlook 2007 opens a new e-mail message with a file attachment of the type that you specified.

4) Type the recipients' e-mail addresses in the **To** box, a subject in the **Subject** box, and a message in the message area.

   **Tip:** By default, the file that you send by using this method is not saved on your computer. If you want to save a copy of the file on your computer, right-click the attachment in the **Attached** box, and then click **Save As** on the shortcut menu.

5) Click **Send**.

**Distribute a report by using other methods**

If you do not want to use the **E-mail** command to distribute your report, you can first export the report to the file format that you want, and then distribute it in the same way that you distribute any other file. For example, you could copy the file to a removable media such as a CD, floppy disk, or USB drive, and then distribute it to your recipients. Alternatively, you might copy the file to a shared network folder or a document library on a Microsoft Windows SharePoint Services site, and then tell your recipients the location of the file.

**Export a report as a snapshot file**

To view a snapshot file, the Microsoft Snapshot Viewer program must be installed on you and your recipients' computers. In earlier versions of Access, the Snapshot Viewer was installed with Access. However, **the Snapshot Viewer is not installed with Office Access 2007**. To view a snapshot file, you must download and install the free Microsoft Snapshot Viewer program from the Microsoft Download Center. Because an Office Access 2007 license is not required to download the Snapshot Viewer program, users who do not have Access 2007 installed on their computers can also download the Snapshot Viewer and use it to view the snapshot files that you create.

You can find the download page by navigating to **www.microsoft.com** and typing “snapshot viewer” in the search field. When the Search Results page appears, click the “Download details: Snapshot Viewer for Microsoft Access” link.

After the Snapshot viewer is installed, you can export the report as a snapshot file by doing the following:

1) In the Navigation Pane, click the report that you want to export.

2) On the **External Data** tab, in the **Export** group, click **More**, and then click **Snapshot Viewer**.

3) On the first page of the Export - Snapshot Viewer Wizard, type a file name in the **File name** box, or click **Browse** to browse to a different location in which to save the file.

4) If you want to view the snapshot immediately after it is created, under **Specify export options**, select the **Open the destination file after the export operation is complete** check box.

5) Click **OK**.
Export a report as a *.pdf or *.xps file
You must first install an add-in before you can export a report to a *.pdf or *.xps format file.

After you install the add-in, use the following procedure to export a report as a *.pdf or *.xps file:

1) In the Navigation Pane, click the report that you want to export.
2) On the External Data tab, in the Export group, click PDF or XPS.
3) In the Publish as PDF or XPS dialog box, in the Save as type box, select the file type that you want to export the report as.
4) To change the name that the report is saved as, type a new file name in the File name box.
5) To open the report immediately after you export it, select the Open file after publishing check box. If you do not have a program installed on your computer that is capable of opening the file type, this option is not available.
6) Under Optimize for, do one of the following:
   a) To optimize the report for a larger, higher-resolution file (recommended for printing), select Standard.
   b) To optimize the report for a smaller, lower-resolution file (recommended for publishing online), select Minimum size.
7) Click Publish.
8) To save the steps of the operation that you just performed so that you can quickly reproduce the same operation at a later time click the Save export steps check box, and then type a name and description for the steps.

Create a grouped or summary report
Information is often easier to understand when it is divided into groups. For example, a report that groups sales by region can highlight trends that otherwise might go unnoticed. In addition, placing totals at the end of each group in your report can replace a lot of manual interaction with a calculator.

Microsoft Office Access 2007 makes working with grouped reports easy. You can create a basic grouped report by using the Report Wizard, you can add grouping and sorting to an existing report, or you can revise grouping and sorting options that have already been defined.

About grouping and sorting
When you print a report, you usually want to organize the records in a particular order. For example, if you’re printing a list of suppliers, you might want to sort the records alphabetically by company name. For many reports, sorting the records isn't enough. You may also want to divide them into groups.

A group is a collection of records, along with any introductory and summary information displayed with the records, such as a header. A group consists of a group header, nested groups (if any), detail records, and a group footer.

You can see how grouping works by comparing the List of Products by Category report (shown in the illustration) to the datasheet for its underlying query, Product List. Both the report and the query sort products by category, but the report also prints the name of each category on a separate line at the beginning of each group (in the group header) and the number of products for each category on a separate line at the end of each group (in the group footer).
The category name appears in every row in the datasheet.

The category name appears once for each group in the report, in the group header.

The total for the category appears at the end of each group, in the group footer.

The records appear as one large group in the datasheet.

The records for each category appear as a separate section in the report, preceded by a group header and followed by a group footer.

You can group on any fields and expressions you sort on (up to 10). You can group on the same field or expression more than once. When you group on more than one field or expression, Office Access 2007 nests the groups according to their group level. The first field you group on is the first and most significant group level; the second field you group on is the next group level; and so on.

You usually use a group header to display data that identifies the group in a separate section at the beginning of the group. You usually use a group footer to summarize the data in the group in a separate section at the end of the group.

**Add grouping, sorting, and totals by using the Group, Sort, and Total pane**

Working in the Group, Sort, and Total pane gives you the most flexibility when you want to add or modify groups, sort orders, or totals options on a report. Again, Layout view is the preferred view in which to work because it is much easier to see how your changes affect the display of the data.

1) Display the Group, Sort, and Total pane:

   a) In Layout view:
      
      - On the Format tab, in the Grouping & Totals group, click Group & Sort.

     b) In Design view:
      
      - On the Design tab, in the Grouping & Totals group, click Group & Sort.

2) To add a new sorting or grouping level, click Add a group or Add a sort.

   a) A new line is added to the Group, Sort, and Total pane, and a list of available fields is displayed.
3) You can click one of these field names or you can click expression below the list of fields to enter an expression. Once you choose a field or enter an expression, Access adds the grouping level to the report. If you are in Layout view, the display changes immediately to show the grouping or sort order.

Notes:
- If there are already several sorting or grouping levels defined, you may need to scroll down in the Group, Sort, and Total pane before you can see the Add a group and Add a sort buttons.
- You can define up to 10 grouping and sorting levels in a report.

Change grouping options
Each sorting or grouping level has a number of options that can be set to obtain the results you want.

- To display all the options for a grouping or sorting level, click More on the level that you want to change.

- To hide the options, click Less.

Sort order: You can change the sort order by clicking the sort order drop-down list, then clicking the option you want.

Group interval: This setting determines how the records are grouped together. For example, you can group on the first character of a text field so that all that start with "A" are grouped together, all that start with "B" are grouped together, and so on. For a date field, you can group by day, week, month, quarter, or you can enter a custom interval.

Totals: To add totals, click this option. You can add totals on multiple fields, and you can do multiple types of totals on the same field.

- Click the Total On drop-down arrow and select the field you want to have summarized.
- Click the Type drop-down arrow and select the type of calculation to perform.
- Select Show Grand Total to add a grand total to the end of the report (in the report footer).
- Select Show group totals as % of Grand Total to add a control to the group footer that calculates the percentage of the grand total for each group.
- Select Show in group header or Show in group footer to display the total in the desired location.

Once all the options have been chosen for a field, you can repeat the process and summarize another field by selecting the other field from the Total On drop-down list. Otherwise, click outside the Totals pop-up window to close it.
Title: This allows you to change the title of the field being summarized. This is used for the column heading and for labeling summary fields in headers and footers.

To add or modify the title:

1) Click the blue text following with title.
   a) The Zoom dialog box appears.
2) Type the new title in the dialog box, and then click OK.

With/without a header section: Use this setting to add or remove the header section that precedes each group. When adding a header section, Access moves the grouping field to the header for you. When you remove a header section that contains controls other than the grouping field, Access asks for confirmation to delete the controls.

With/without a footer section: Use this setting to add or remove the footer section that follows each group. When you remove a footer section that contains controls, Access asks for confirmation to delete the controls.

Keep group together: This setting determines how groups are laid out on the page when the report is printed. You may want to keep groups together as much as possible to reduce the amount of page turning that is needed to see the entire group. However, this usually increases the amount of paper needed to print the report, because most pages will have some blank space at the bottom.

- Do not keep group together on one page: Use this option if you are not concerned about groups being broken up by page breaks. For example, a group of 30 items may have 10 items on the bottom of one page and the remaining 20 items at the top of the next page.
- Keep whole group together on one page: This option helps minimize the number of page breaks in a group. If a group cannot fit in the remaining space on a page, Access leaves that space blank and begins the group on the next page instead. Large groups may still span multiple pages, but this option minimizes the number of page breaks within the group as much as possible.
- Keep header and first record together on one page: For groups with group headers, this ensures that the group header will not print by itself at the bottom of a page. If Access determines that there is not enough room for at least one row of data to be printed after the header, the group begins on the following page.

Change the priority of grouping and sorting levels
To change the priority of a grouping or sorting level, click the row in the Group, Sort, and Total pane and then click the up arrow or the down arrow on the right side of the row.

Delete grouping and sorting levels
To delete a grouping or sorting level, click the row you want to delete in the Group, Sort, and Total pane, and then press DELETE on your keyboard or click the Delete button on the right side of the row. When you delete a grouping level, if the grouping field was in the group header or footer, Access moves it to the report’s Detail section. Any other controls that were in the group header or group footer are deleted.

Add grouping, sorting, and totals in Layout view
You can perform simple sorting, grouping and totaling operations by right-clicking fields in Layout view and then choosing the operation you want from the shortcut menu.

Note: Although the instructions in this section do not use the Group, Sort, and Total pane directly, it is a good idea to open the pane and observe how it changes as you work. You will get a better idea of what Access is doing and, as you get more comfortable working with the Group, Sort, and Total pane, you can use it to make additional adjustments to your report. To display the Group, Sort, and Total pane:

- On the Format tab, in the Grouping & Totals group, click Group & Sort. 

Create Reports in Access 2007 Training Session Handout
Topics came directly from Microsoft Access Help.
Sort on a single field
1) Right-click any value in the field that you want to sort.
2) On the shortcut menu, click the sort option you want.
   a) For example, to sort a text field in ascending order, click Sort A to Z. To sort a numeric field in
descending order, click Sort Largest to Smallest.
3) Access sorts the report as you specified.
   a) If the Group, Sort, and Total pane is open, you can see that a new Sort by line for the field has been
added.

Note: When you apply sorting by right-clicking a field in Layout view, you can only sort one field at a time.
Applying sorting to another field removes the sorting on the first field. This differs from the sorting behavior
in forms, where multiple sort orders can be established by right-clicking each field in turn and the choosing
the sort order you want.

Group on a field
1) Right-click any value in the field on which you want to group.
2) On the shortcut menu, click Group On.
3) Access adds the grouping level and creates a group header for it.

Build a new grouped report by using the Report Wizard
The Report Wizard presents you with a series of questions, and then generates a report based on your answers.
Among those questions is one that asks for the field or fields to use to group your report. After the report is
created, you can use it as-is or modify it to better suit your needs.

Start the Report Wizard
   2) Click the Tables/Queries drop-down list and choose the table or
query that contains the fields you want on your report.
3) Double-click fields in the Available Fields list to choose them.
   a) Access moves them to the Selected Fields list. Alternatively,
you can click the buttons located between the Available Fields
box and the Selected Fields box to add or remove the selected
field or to add all or remove all of the fields.
4) If there are fields in another table or query that you also want to put
on your report, click the Tables/Queries drop-down list again and
choose the other table or query, and continue to add fields.
5) After you've finished adding fields, click Next.
**Group records in the Report Wizard**

When you include more than one table in a report, the wizard examines the relationships between the tables and determines how you might want to view the information.

1) On the page of the Report Wizard that asks **Do you want to add any grouping levels?**, click one of the field names in the list, and then click **Next**.
2) To add grouping levels, double-click any of the field names in the list to add them to your report.
   a) You can also remove a grouping level by double-clicking it in the page display on the right side of the dialog box. Use the arrow buttons to add and remove grouping levels, and adjust the priority of a grouping level by selecting it and clicking the up or down priority buttons. Access adds each grouping level and shows it nested within its parent grouping level.
3) Click **Grouping Options** to display the **Grouping Intervals** dialog box.
   a) Optionally, for each group-level field, choose a grouping interval.
   b) The grouping interval lets you customize how records are grouped. In the illustration, records are grouped on the ShippedDate field, which is a Date/Time data type. The Report Wizard offers choices appropriate to the field type in the **Grouping intervals** list.
4) After selecting a grouping interval, click **OK**.
5) Click **Next** to navigate to the next page of the wizard.

**Sort and summarize records**

You can sort records by up to four fields, in either ascending or descending order.

1) Click the first drop-down list and choose a field on which to sort.
   a) You can click the button to the right of the list to toggle between ascending and descending order (**Ascending** is the default). Optionally, click the second, third, and fourth drop-down lists to choose additional sort fields.
2) Click **Summary Options** if you want to summarize any of the numeric fields.
   a) Note that the **Summary Options** button will only be visible if you have one or more numeric fields in the Detail section your report. The wizard displays the available numeric fields.
3) Select the check box under your choice of **Sum**, **Avg**, **Min** or **Max** to include those calculations in the group footer.
   
a) You can also choose to show the details and summary or the summary only. In the latter case, totals for each ShippedDate value are shown (if you selected the check box for **Sum**, for example), but the order detail is omitted. You can also choose to show percent of total calculations for sums.

4) Click **OK**.

5) Follow the directions on the remaining pages of the Report Wizard. On the last page, you can edit the title of the report. This title will be displayed on the first page of the report, and Access will also save the report, using the title as the document name. You can edit both the title and the document name later.

6) Click **Finish**. Access automatically saves the report and displays it in Print Preview.

**Make a group header appear at the top of each page**
For groups that span multiple pages, it is helpful to have the group header appear at the top of each page so that you can easily see which group the data are in. You can select a group header in Layout view, but it is easier to do this in Design view.

1) Double-click the group header section selector (the horizontal bar above the group header section).
2) On the **Format** tab of the property sheet, set the **Repeat Section** property to **Yes**.

**Create a grouping effect without using headers**
You can achieve a grouping effect on your report without the use of headers. Removing headers creates a more compact report because less vertical space is used by the header lines.

The general procedure involves removing the header for each group, which moves each grouping field into the Detail section of the report. To restore the visual grouping effect, you set the **Hide Duplicates** property of each grouping field to **Yes**.

**Example:** Consider this typical grouped report that uses group headers:

As you can see, each company name takes up an entire line, as does each order ID.

The instructions below show you how to edit the report so that the groups do not take up as much space.

1) Open the report in Layout view by right-clicking it in the Navigation Pane, and then clicking **Layout View**.

2) On the **Format** tab, in the **Grouping & Totals** group, click **Group & Sort**.

   **Note:** It is a good idea to start with the lowest-level group and work your way up; otherwise, the display of the report can become confusing while you are working.
3) Click the lowest grouping level in the list, and then click More.
4) From the header section drop-down list, select **without a header section**.

When you remove a header, Access preserves the text box for the grouping field by moving it to the Detail section. However, any other controls in the group header might be deleted. Access warns you if any controls are going to be deleted as a result of this action. If there are controls in the group header that you want to preserve, be sure to move them to another report section before performing this step. You will need to switch to Design view to move the controls to other sections.

The resulting report is shown in the illustration. Notice that the first OrderID is on the same line as the first detail record, instead of on its own line.

Unfortunately, the OrderID repeats on every detail line, and this makes it hard to see exactly how many orders there are. At this point, setting the text box control's **Hide Duplicates** property is useful.

Follow these steps to set the **Hide Duplicates** property:

1) Select one of the repeating values.
2) If the property sheet is not currently displayed, press **F4** to display it.
3) On the **Format** tab of the property sheet, click the drop-down list for **Hide Duplicates** and then click **Yes**.
4) The duplicate order IDs are hidden. Note that you can see how many orders there are, and how many products there are per order.
5) For this example, we repeat step 4 for the Company Name grouping level. The final report looks like the illustration:

The Company Name value is now on the same line as the first detail record, and the **Hide Duplicates** property prevents the Company Name value from repeating on every line. For a long report that uses several grouping levels, this can result in a significant paper savings.

**Create a summary report (without record details)**

If you want to show only totals (that is, just the information in header and footer rows), on the **Format** tab, (or on the **Design** tab in Design view), in the **Grouping & Totals** group, click **Hide Details**. Doing this hides the records at the next lower level of grouping, resulting in a much more compact presentation of the summary data. Although the records are hidden, the controls in the hidden section are not deleted. Click **Hide Details** again to restore the Detail rows to the report.

**Modify a report**

This topic describes the techniques you can use to modify an existing report. Microsoft Office Access 2007 provides two views that you can use to make changes to your report: Layout view and Design view. Your choice of which view to use depends on what specific task you are trying to accomplish. You might end up using both views to make your changes.
Understand Layout view

Layout view is the most intuitive view to use for report modification, and can be used for nearly all the changes you would want to make to a report in Office Access 2007. In Layout view, the report is actually running, so you can see your data much as it will appear when printed. However, you can also make changes to the report design in this view. Because you can see the data while you are modifying the report, it's a very useful view for setting column widths, add grouping levels, or performing almost any other task that affects the appearance and readability of the report.

The report you see in Layout view does not look exactly the same as the printed report. For example, there are no page breaks in Layout view. Also, if you have used Page Setup for format your report with columns, the columns are not displayed in Layout view. However, Layout view gives you a very close approximation of the printed report. If you want to see how the report will look when printed, use Print Preview.

Certain tasks cannot be performed in Layout view, and require you to switch to Design view. In certain situations, Access will display a message telling you that you must switch to Design view to make a particular change.

To switch to Layout view:
- Right-click the report name in the Navigation Pane / Layout View.

Modify your report in Layout view

This section describes some of the common report modifications that you can perform in Layout view.

Add a field

1) On the Format tab, in the Controls group, click Add Existing Fields.
   a) The list of available fields is displayed. If there are fields available in other tables, these will be displayed under Fields available in other tables:
2) Drag a field from the Field List onto the report. As you move the field, a highlighted area will indicate where the field will be placed when you release the mouse button.

Note: To add multiple fields at once, hold down the CTRL key and click each field in the Field List that you want. Then, release the CTRL key and drag the fields onto the report. The fields will be placed adjacent to each other.

Change column or field width

1) Click an item in the column that you want to adjust.
   a) A border is drawn around the item to indicate that the field is selected.
2) Drag the right or left edge of the border until the column is the width you want.

Change row or field height

1) Click an item in the row that you want to adjust.
   a) A border is drawn around the item to indicate that the field is selected.
2) Drag the top or bottom edge of the border until the row is the height you want.

Understand Design view

Design view gives you a more detailed view of the structure of your report. You can see the header and footer bands for the report, page, and groups. The report is not actually running in Design view, so you cannot see the underlying data while working; however, there are certain tasks you can perform more easily in Design view than in Layout view. You can:
- Add a wider variety of controls to your report, such as labels, images, lines, and rectangles.
- Edit text box control sources in the text boxes themselves, without using the property sheet.
- Change certain properties that are not available in Layout view.

To switch to Design view, right-click the report name in the Navigation Pane and then click **Design View**.

You can use the property sheet to modify the properties for the report itself and the controls and sections it contains. To display the property sheet, press **F4**.

You can use the **Field List** pane to add fields from the underlying table or query to your report design by dragging them from the **Field List** pane to the report.

**Add a text box control to a report**
The text box is the standard control used for viewing and editing data on reports. Many different types of data can be displayed in text boxes, and you can also use them to perform calculations.

**Add a bound text box to a report by dragging a field from the Field List pane**
A bound text box displays data from a field in a table or query. A quick way to create a bound text box is by dragging a field from the **Field List** pane onto your report. Access automatically creates a text box for fields of the following data types:
- Text
- Memo
- Number
- Date/Time
- Currency
- Hyperlink

Dragging fields of other data types creates different types of controls. For example, if you drag a Yes/No field from the **Field List** pane to a report, Access creates a check box. If you drag an OLE Object field to a report, Access creates a bound object frame.

1) Open the report in Layout view or Design view by right-clicking the report in the Navigation Pane, and then clicking the view you want.
2) On the **Format** tab, in the **Controls** group, click **Add Existing Fields**.
3) In the **Field List** pane, expand the table containing the field that you want to be bound to your text box.
4) Drag the field from the **Field List** pane to the report.

You can also add a bound text box to a report by first adding an unbound text box, and then setting the **Control Source** property of the text box to the field you want to bind it to.

**Add an unbound text box**
An unbound text box is not connected to a field in a table or query. You can use an unbound text box to display the results of a calculation or to accept input that you don't want to store directly in a table. It is easiest to add an unbound text box in Design view.

1) Open the report in Design view.
2) On the **Design** tab, in the **Controls** group, click **Text Box**.
3) Position the pointer where you want the text box to be placed on the report, and then click to insert the text box.

**Note:** Access also places a label to the left of the text box, so leave some room to the left of the pointer for the label. You can reposition the label and the text box later. You can also delete the label by clicking it and then pressing **DELETE**.
Another way to create an unbound text box is by first creating a bound text box by dragging a field from the Field List pane onto the report, and then deleting the value in its Control Source property. If you do this in Design view, the text box will display "Unbound" instead of the field name. In Layout view, the text box will no longer display data — in fact, it will be blank.

**Understand text box properties**

Regardless of how you create a text box, certain properties need to be set so that the text box works and appears the way that you want. The following list shows a few of the more important and commonly used text box properties:

- **Name**: You should give your text box a short, meaningful name so that you can easily tell what data it contains. This makes it easy to refer to the text box in expressions that you might use in other text boxes. Some database developers prefer to add a prefix, such as `txt`, to text box names so that they can easily distinguish text boxes from other types of controls — for example, `txtFirstName` or `txtAddress`. When you create a bound text box by dragging a field from the Field List pane, Access uses the field name as the text box name. This usually works well, but if you plan to edit the Control Source property and create an expression, it is a good idea to first change the text box name so that it is different from the field name.

- **Control Source**: This property determines whether the text box is bound, unbound, or calculated.
  - If the value in the Control Source property box is the name of a field in a table, the text box is bound to that field.
  - If the value in Control Source is blank, the text box is unbound.
  - If the value in Control Source is an expression, the text box is a calculated text box.

- **Text Format**: If the text box is bound to a Memo field, you can set the value in the Text Format property box to Rich Text. Doing this allows you to apply multiple formatting styles to the text contained in the text box. For example, you can apply bold formatting to one word and underlining to another.

- **Can Grow**: This property is particularly helpful on reports for text boxes that are bound to Text or Memo fields. The default setting is No. If there is too much text to display in the text box, the text is truncated (cut off). However, if you set the value of the Can Grow property box to Yes, the text box automatically adjusts its vertical size to print or preview all the data that it contains.

**Change the record source of the report**

1) If the property sheet is not displayed, press F4 to display it.
2) In the drop-down list at the top of the property sheet, click Report.
3) In the property sheet, click the Data tab.
4) In the Record Source drop-down list, select the table or query that you want to use for a record source, or click `...` to display the Query Builder.

**Note**: If the report is currently based on a table, Access asks if you want to create a query based on the table. Click Yes to display the Query Builder and create the query, or click No to cancel the operation. If you choose to create a query, the new query will become the record source of the report. It will be created as an "embedded" query — that is, a query that is stored in the report's Record Source property, rather than as a separate query object.

**Add report or page header and footer sections**

Headers and footers are report sections that you can use to display information that is common to the entire report, or to each page of a report. For example, you can add a Page Footer section to display a page number at the bottom of each page, or you can add a Report Header section to display a title for the entire report.
1) In the Navigation Pane, right-click the report that you want to change, and then click **Design View** on the shortcut menu.

2) Verify which sections are already on the report. The sections are separated by shaded horizontal bars called **section selectors**. The label on each section selector indicates what the section directly below it is.

3) To add page header and footer sections or report header and footer sections to your report, right-click any section selector and then click **Page Header/Footer** or **Report Header/Footer** on the shortcut menu.

   **Note:** If the section is already present on the report, Access warns you that it will delete the existing section and the controls it contains.

4) You can now move existing controls or add new controls to the new sections.

   Office Access 2007 always adds page and report header and footer sections in pairs. That is, you cannot add a page or report header section without also adding the corresponding footer section. If you do not need both sections, you cannot delete a section, but you can resize the unused section to a height of zero (0) to avoid adding extra vertical spacing to your report. Position the pointer at the bottom of the unused section until it turns into a double-headed arrow \( \Rightarrow \), and then drag upward until the section is hidden. If there are any controls in the section, you must delete them before you can fully hide the section.

**Remove report or page header and footer sections**

1) In the Navigation Pane, right-click the report that you want to change, and then click **Design View** on the shortcut menu.

2) Right-click any section selector and then click **Page Header/Footer** or **Report Header/Footer** on the shortcut menu.

   If you are removing a header and footer pair and those sections contain controls, Office Access 2007 warns you that deleting the sections will also delete the controls and that you will not be able to undo the action. Click **Yes** to remove the sections and delete the controls, or click **No** to cancel the operation.

**Delete a field or column**

1) Click the field or column to be deleted, or click its label or column heading.

   a) Access draws a border around the item to indicate that it is selected.

2) Press **DELETE**.

**Change the formatting of a field**

1) Select the field that you want to format.

2) On the **Format** tab, use the tools in the **Font** group to apply the formatting you want.

**Wrap text in a field**

1) If the property sheet is not displayed, right-click the field in which you want the text to wrap, and click **Properties**.

   a) Otherwise, just click the field to select it.

2) On the **Format** tab of the property sheet, set the **CanGrow** property to **Yes**.
Add a title to a report
1) On the **Format** tab, in the **Controls** group, click **Title**.
   a) A new label is added to the report header, and the report name is entered for you as the report title.
2) When the label is created, the text in the label is selected for you so that if you want to change the text, you can just begin typing the title you want.
3) Press **ENTER** when you have finished.

**Edit the report title**
1) Double-click the label containing the report title to place the cursor in the label.
2) Type the text you want to use as the report title, and press **ENTER** when you have finished.

Add page numbers
1) On the **Format** tab, in the **Controls** group, click **Page Numbers**.
   a) The **Page Numbers** dialog box is displayed.
2) Choose the format, position, and alignment you want for the page numbers.
3) Clear the **Show Number of First Page** check box if you do not want a number on the first page.
4) Click **OK**.

Add the date or time
1) On the **Format** tab, in the **Controls** group, click **Date and Time**.
   a) The **Date and Time** dialog box is displayed.
2) Clear the **Include Date** check box if you do not want to include the date.
   a) If you want to include the date, click the date format you want.
3) Clear the **Include Time** check box if you do not want to include the time.
   a) If you want to include the time, click the time format you want.
4) A sample of the date and time, in the formats you have chosen, appears in the **Sample** area of the dialog box.
5) Click **OK**.
Add a total or other aggregate to a report
In any report that contains numbers, you can use totals, averages, percentages, or running sums to make the data more understandable.

Types of aggregates that you can add to a report

<table>
<thead>
<tr>
<th>Calculation</th>
<th>Description</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>The sum of all the numbers in the column.</td>
<td>Sum()</td>
</tr>
<tr>
<td>Average</td>
<td>The average value of all the numbers in the column.</td>
<td>Avg()</td>
</tr>
<tr>
<td>Count</td>
<td>The count of items in the column.</td>
<td>Count()</td>
</tr>
<tr>
<td>Maximum</td>
<td>The highest numeric or alphabetic value in the column.</td>
<td>Max()</td>
</tr>
<tr>
<td>Minimum</td>
<td>The lowest numeric or alphabetic value in the column.</td>
<td>Min()</td>
</tr>
<tr>
<td>Standard Deviation</td>
<td>An estimate of the standard deviation across the set of values in the column.</td>
<td>StDev()</td>
</tr>
<tr>
<td>Variance</td>
<td>An estimate of the variance across the set of values in the column.</td>
<td>Var()</td>
</tr>
</tbody>
</table>

Add a total or other aggregate in Layout view
Layout view provides you with the quickest way to add totals, averages, and other aggregates to your report.

1) In the Navigation Pane, right-click the report and then click Layout View ☐.  
2) Click the field you want to summarize.  
3) On the Format tab, in the Grouping & Totals group, click Totals Σ.  
4) Click the type of aggregate that you want to add for the field.  

Office Access 2007 adds a text box to the Report Footer section and sets its Control Source property to an expression that performs the calculation you want. If there are any grouping levels in your report, Access also adds a text box that performs the same calculation to each Group Footer section.

Add a total or other aggregate in Design view
Design view gives you a bit more control over the placement and appearance of your totals. In grouped reports, you can put totals or other aggregates in the header or footer of each group. Report-wide aggregates can be placed in the Report Header or Report Footer section.

1) In the Navigation Pane, right-click the report and then click Design View ☞.  
2) Click the field you want to summarize.  
3) On the Design tab, in the Grouping & Totals group, click Totals Σ.  
4) Click the type of aggregate that you want to add for the field.  

Office Access 2007 adds a text box to the Report Footer section and sets its Control Source property to an expression that performs the calculation you want. If there are any grouping levels in your report, Access also adds a text box that performs the same calculation to each Group Footer section.
Create a calculated control
You can use calculated controls to display the results of a calculation. For example, if you have a report that displays the number of items sold and the price of each unit, you can add a calculated text box that multiplies those two fields to display the total price. The **Control Source** property of the calculated text box contains an expression that multiplies two fields (the number of items times the unit price) to obtain the result.

This procedure helps you create a calculated control without using a control wizard.

1) Right-click the report in the Navigation Pane, and then click **Design View**.
2) On the **Design** tab, in the **Controls** group, click the tool for the type of control you want to create.
3) Position the pointer where you want the control to be placed on the report, and then click on the report to insert the control.
4) If a control wizard starts, click **Cancel** to close it.
5) Select the control, press **F4** to display the property sheet, and then type an expression in the **Control Source** property box.
   a) To use the Expression Builder to create the expression, click next to the **Control Source** property box.
6) Switch to Report view and verify that the calculated control works as you expect.

**Notes:**
- Precede each expression with the **=** operator.
  - For example: `=[UnitPrice]*.75`.
- If you need more room to type an expression in the **Control Source** property box, press **SHIFT+F2** to open the **Zoom** box.
- If your report is based on a query, you might want to put the expression in the query instead of in a calculated control. Doing this can improve performance and, if you are going to calculate totals for groups of records, it is easier to use the name of a calculated field in an aggregate function.
- When you sort on a calculated control in a report, ensure that the **Format** property of the control is set appropriately. Otherwise, calculated numeric or date values might sort alphabetically instead of numerically.

Change a bound control to a calculated control
A good way to create a calculated control is by first creating a bound control (for example, by dragging a field from the **Field List** pane to your report), and then editing the bound control's **Control Source** property to create an expression. This works well, as long as you ensure that the name of the control does not conflict with any of the field names contained in the expression.

Assuming you have already created your bound control, use the following procedure to change it to a calculated control and avoid any name conflicts.

1) Right-click the report in the Navigation Pane, and then click **Design View**.
2) Click the field you want to change, and then press **F4** to open the property sheet.
3) On the **All** tab of the property sheet, if the **Name** property matches the **Control Source** property, edit the **Name** property so that the two properties do not match. Ensure that the name you enter is not the name of another field in your database.
4) Edit the string in the **Control Source** property box so that it contains the expression you want.
5) **Save** your changes, and switch to Layout view and verify that the calculated control works as you expect.
If the control does not display the data you want (for example, if Access displays #Name? in the control), check the record source of the report to ensure that all the fields you used in the expression are available. If the record source is a query, you might need to add one or more fields to the query before the expression will work.

**Learn which types of controls can be used as calculated controls**

Text boxes are the most popular choice for a calculated control because they can display so many different types of data. However, any control that has a Control Source property can be used as a calculated control. In many cases, it doesn't make sense to use a certain control type as a calculated control, because you can't update that control the way you can update a bound or unbound control. For example, if you place a check box control on a report and then enter an expression in the Control Source property of the check box, you can no longer select or clear the check box by clicking it. The check box appears selected or cleared, based on the results of the expression. If you click the check box, Access displays an alert on the Access status bar:

*Control can't be edited; it's bound to the expression your expression.*

On a report, however, it may be useful to base a check box control on the results of a calculation, because controls on reports are used only to display information.

**Add a calculated text box**

1) Open the report in Design view by right-clicking the report in the Navigation Pane, and then clicking Design View.

2) On the Design tab, in the Controls group, click Text Box .

3) Position the pointer where you want the text box to be placed on the report, and then click to insert the text box.

4) Do one of the following:
   a) Place the cursor in the text box, and then type an expression that calculates a total.
   b) Select the text box, press F4 to display the property sheet, and type the expression in the Control Source property box.

5) Save the report and then switch to Report view to check the results.