Creating Reports in Access 2010

Table of Contents

INTRODUCTION TO REPORTS .......................................................................................... 2
PARTS OF A REPORT ........................................................................................................ 3
UNDERSTAND CONTROLS ............................................................................................. 3
CREATE A SIMPLE REPORT .......................................................................................... 4
STEP 1: CHOOSE A RECORD SOURCE ......................................................................... 4
   Different types of record sources ................................................................................ 5
   Table ............................................................................................................................ 5
   Named query .............................................................................................................. 5
   Embedded query ...................................................................................................... 5
STEP 2: CHOOSE A REPORT TOOL ................................................................................ 6
   Convert a record source to an embedded query ......................................................... 7
      Method 1: Click the Build button ........................................................................... 7
      Method 2: Add a field from a related table by using the field list ......................... 8
      Method 3: Copy and paste SQL from a named query ........................................... 8
      Method 4: Copy and paste SQL from another report ........................................... 8
   Edit an embedded query ......................................................................................... 9
   Save an embedded query as a named query ............................................................. 9
STEP 3: CREATE THE REPORT ..................................................................................... 9
   Create a report by using the Report tool ................................................................. 10
   Create a report by using the Blank Report tool ...................................................... 10
   Create a report in Report Design view ................................................................... 10
   Create a report by using the Report Wizard ......................................................... 11
   Create labels by using the Label Wizard ............................................................... 11
DISPLAY THE PROPERTY SHEET ............................................................................ 11
ADD CONTROLS TO THE REPORT ........................................................................... 11
ADD IMAGES ............................................................................................................... 12
   Add an image ........................................................................................................... 12
   Add a background image ....................................................................................... 12
PREVIEW AND PRINT A REPORT ............................................................................... 12
   Preview a report .................................................................................................... 12
   Print a report ......................................................................................................... 13
CREATE A GROUPED OR SUMMARY REPORT ........................................................... 13
BUILD A NEW GROUPED REPORT BY USING THE REPORT WIZARD .................. 13
   Start the Report Wizard ........................................................................................ 13
   Group records in the Report Wizard ................................................................. 14
   Sort and summarize records .............................................................................. 15
ADD OR MODIFY GROUPING AND SORTING IN AN EXISTING REPORT .......................................................... 16
Add grouping, sorting, and totals .......................................................... 16
Sort on a single field ........................................................................ 16
Sort on multiple fields ..................................................................... 16
Group on a field ................................................................................ 16
Add a total to a field ......................................................................... 16
Add grouping, sorting, and totals by using the Group, Sort, and Total pane ......................................................... 16
Display the Group, Sort, and Total pane ........................................... 17
Change grouping options .................................................................. 17
Change the priority of grouping and sorting levels ......................... 18
Delete grouping and sorting levels ..................................................... 19
Create a summary report (without record details) .............................. 19

CREATE AN EXPRESSION ........................................................................................................................... 19

OVERVIEW OF TABLES .................................................................................................................................. 19

OVERVIEW OF THE EXPRESSION BUILDER ................................................................................................. 20
New features in the Access 2010 Expression Builder ......................... 20

USE EXPRESSIONS IN REPORT CONTROLS .................................................................................................. 21
Enter an expression in a text box control ............................................ 22
Add an expression to an existing group or sort .................................... 23

Introduction to reports
When you use a database, you typically use reports to view, format, and summarize data. For instance, you might create a list-type report to display phone numbers for all your contacts, or a summary report to total up the sales for your company across different regions and time periods.

This handout provides an overview of reports in Microsoft Access 2010, and introduces new or changed report features. It also explains how to create a report, how to sort, group, and summarize data, and how to preview and print a report.

A report is a database object that you use to display and summarize data. Reports provide a way to distribute or archive snapshots of your data, either by being printed out, converted to PDF or XPS files, or exported to other file formats.

Reports can provide details about individual records, summaries across many records, or both. You can also use Access reports to create labels for mailings or other purposes.

It is possible to create “unbound” reports that do not display data, but for the purposes of this handout, we’ll assume that a report is bound to a data source such as a table or query.
Parts of a report
In Access, the design of a report is divided into sections. In a client database, you can view your report in Design view to see its sections. In Layout view, the sections are not as obvious, but they are still there, and can be selected by using the drop-down list in the Selection group on the Format tab. To create useful reports, you need to understand how each section works. For example, the section in which you choose to place a calculated control determines how Access calculates the results. The following list is a summary of the section types and their uses:

- **Report Header**: This section is printed just once, at the beginning of the report. Use the report header for information that might normally appear on a cover page, such as a logo, a title, or a date. When you place a calculated control that uses the Sum aggregate function in the report header, the sum calculated is for the entire report. The report header is printed before the page header.

- **Page Header**: This section is printed at the top of every page. For example, use a page header to repeat the report title on every page.

- **Group Header**: This section is printed at the beginning of each new group of records. Use the group header to print the group name. For example, in a report that is grouped by product, use the group header to print the product name. When you place a calculated control that uses the Sum aggregate function in the group header, the sum is for the current group. You can have multiple group header sections on a report, depending on how many grouping levels you have added.

- **Detail**: This section is printed once for every row in the record source. This is where you place the controls that make up the main body of the report.

- **Group Footer**: This section is printed at the end of each group of records. Use a group footer to print summary information for a group. You can have multiple group footer sections on a report, depending on how many grouping levels you have added.

- **Page Footer**: This section is printed at the end of every page. Use a page footer to print page numbers or per-page information.

- **Report Footer**: This section is printed just once, at the end of the report. Use the report footer to print report totals or other summary information for the entire report.

**Note**: In Design view, the report footer appears below the page footer. However, in all other views (Layout view, for example, or when the report is printed or previewed), the report footer appears above the page footer, just after the last group footer or detail line on the final page.

Understand controls
Controls are objects that display data, perform actions, and let you view and work with information that enhances the user interface, such as labels and images. Access supports three types of controls: bound, unbound, and calculated:

- **Bound control**: A control whose source of data is a field in a table or query is a bound control. You use bound controls to display values from fields in your database. The values can be text, dates, numbers, Yes/No values, pictures, or graphs. A text box is the most common type of bound control. For example, a text box that displays an employee's last name might get this information from the Last Name field in the Employees table.
• **Unbound control**: A control that doesn't have a source of data (a field or expression) is an unbound control. You use unbound controls to display information, lines, rectangles, and pictures. For example, a label that displays the title of a report is an unbound control.

• **Calculated control**: A control whose source of data is an expression rather than a field is a calculated control. You specify the value that you want in the control by defining an *expression* as the source of data for the control. An expression is a combination of operators (such as = and +), control names, field names, functions that return a single value, and constant values. For example, the following expression calculates the price of an item with a 25 percent discount by multiplying the value in the Unit Price field by a constant value (0.75).

  \[ \texttt{= [Unit Price] \times 0.75} \]

  An expression can use data from a field in the report's underlying table or query, or from a control in the report.

When you create a report, it is probably most efficient to add and arrange all the bound controls first, especially if they make up the majority of the controls on the report. You can then add the unbound and calculated controls that complete the design by using the tools in the **Controls** group on the **Design** tab.

You bind a control to a field by identifying the field from which the control gets its data. You can create a control that is bound to the selected field by dragging the field from the **Field List** pane to the report. The **Field List** pane displays the fields of the report's underlying table or query. To display the **Field List** pane, on the **Design** tab, in the **Controls** group, click **Add Existing Field**.

Alternatively, you can bind a field to a control by typing the field name in the control itself or in the box for the **ControlSource** value in the control's property sheet. The property sheet defines the characteristics of the control, such as its name, the source of its data, and its format.

Using the **Field List** pane is the best way to create a control for two reasons:

• A bound control has an attached label, and the label takes the name of the field (or the caption defined for that field in the underlying table or query) as its caption by default, so you don't have to type the caption yourself.

• A bound control inherits many of the same settings as the field in the underlying table or query (such as for the **Format**, **DecimalPlaces**, and **InputMask** properties). Therefore, you can be sure that these properties for the field remain the same whenever you create a control that is bound to that field.

If you already created an unbound control and want to bind it to a field, set the control's **ControlSource** property to the name of the field.

### Create a simple report

You can create a variety of different reports in Microsoft Access 2010, ranging from the simple to the complex. This section describes the different tools available for creating reports, and for which situations each one is recommended.

### Step 1: Choose a record source

The record source of a report determines which fields from your database can be displayed on the report. In a relational database, related data is usually spread out across multiple tables. For example, information about customers is stored in one table, and information about each customer’s orders is stored in another table.
Reports give you a flexible way to “reassemble” the data and display it in just the way you want. However, you must make sure the record source contains all the data you need before the report can display it.

A report consists of information that is pulled from tables or queries, as well as information that is stored with the report design, such as labels, headings, and graphics. The tables or queries that provide the underlying data are also known as the report's record source. If the fields that you want to include all exist in a single table, use that table as the record source. If the fields are contained in more than one table, you need to use one or more queries as the record source. Those queries may already exist in your database, or you may need to create new queries specifically to fit the needs of your report.

The record source of a report can be a table, a named query, or an embedded query. The record source must contain all of the rows and columns of data you want to display on the report.

1) If the data you want is contained in an existing table or query, select the table or query in the Navigation Pane, and then continue to Step 2: Choose a report tool.

2) If the record source does not yet exist, do one of the following:
   a) Continue to Step 2: Choose a report tool and use the Blank Report tool, or
   b) Create the table(s) or query that contains the data you want to use, select it in the Navigation Pane, and then continue to Step 2: Choose a report tool.

**Different types of record sources**

**Table**
If all of the fields you need are in a single table, you can use that table as the record source of the report. If the fields you need are contained in two or more tables, you will need to make sure that the tables can be joined logically on some kind of common value, and then create a named query or an embedded query to use as the record source.

**Named query**
A named query is one that has been saved and is visible in the Navigation Pane, under Queries. You can use a named query as a record source for multiple reports. However, that making future modifications to the query will affect all reports that are bound to it. This can lead to maintenance problems later on. In addition, it’s relatively easy to delete a named query, which breaks any reports that are bound to it.

**Embedded query**
An embedded query is an SQL statement that is stored in the Record Source property of the report. Since an embedded query is not a separate object that is displayed in the Navigation Pane, it’s less likely that you’ll break the report by accidentally deleting or modifying its query. Creating an embedded query is recommended if you want the query to be dedicated only to the report you are creating (in other words, you won’t want to share the query with any other objects).

Embedded queries are created by default when you use the Report Design, Blank Report, or Labels tools. Embedded queries are also created by the Report Wizard, provided that you select data from more than one table for your report. If you only select data from one table, the Report Wizard binds the report directly to that table.
You can also create an embedded query by copying the SQL statement from a named query that is open in SQL View, and then pasting the SQL statement into the Record Source property of a report. To open a named query in SQL View:

1) Right-click the query in the Navigation Pane, and then click Design View.
2) On the Design tab, in the Results group, click View, and then click SQL View.

Step 2: Choose a report tool
The report tools are located on the Create tab of the ribbon, in the Reports group. The following table briefly describes what each tool does. Depending on how you use the tools; each one creates one of three record source types.

<table>
<thead>
<tr>
<th>Button image</th>
<th>Tool</th>
<th>Description</th>
<th>Default record source type</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Report" /></td>
<td>Report</td>
<td>Creates a simple, tabular report containing all of the fields in the record source you selected in the Navigation Pane.</td>
<td>Table or named query, which you must select in the Navigation Pane prior to clicking the tool.</td>
</tr>
<tr>
<td><img src="image" alt="Report Design" /></td>
<td>Report Design</td>
<td>Opens a blank report in Design view, to which you can add just the fields and controls you want.</td>
<td>Embedded query, if you drag fields from the Field List task pane to the report. You can also select a table or named query from the Record Source drop-down list in the Property Sheet.</td>
</tr>
<tr>
<td><img src="image" alt="Blank Report" /></td>
<td>Blank Report</td>
<td>Opens a blank report in Layout view, and displays the Field List task pane. As you drag fields from the Field List to the report, Access creates an embedded query and stores it in the Record Source property of the report.</td>
<td>Embedded query, if you drag fields from the Field List task pane to the report. You can also select a table or named query from the Record Source drop-down list in the Property Sheet.</td>
</tr>
<tr>
<td><img src="image" alt="Report Wizard" /></td>
<td>Report Wizard</td>
<td>Displays a multiple-step wizard that lets you specify fields, grouping/sorting levels, and layout options. The wizard creates a report based on the selections you make.</td>
<td>Embedded query, if you select fields from more than one table. If you only select fields from a single table, Access uses that table as the record source.</td>
</tr>
<tr>
<td><img src="image" alt="Labels" /></td>
<td>Labels</td>
<td>Displays a wizard that lets you select standard or custom label sizes, as well as which fields you want to display, and how you want them sorted. The wizard creates the label report based on the selections you make.</td>
<td>Table or named query, which you must select prior to clicking the tool.</td>
</tr>
</tbody>
</table>
Convert a record source to an embedded query

Any report that is bound to a table or named query can be modified so that it is bound to an embedded query instead. This can make a database easier to maintain by making reports more self-contained, and less dependent on other objects. Depending on your current record source type, use one of the following methods to convert it to an embedded query:

Method 1: Click the Build button
If the Record Source property is a table name, you can quickly create an embedded query by clicking the Build button in the Record Source property box.

1) In the Navigation Pane, right-click the report you want to modify, and then click Layout View.
2) Right-click anywhere on the report, and then click Report Properties.
3) On the All tab, click in the Record Source property box, and then click the Build button.
4) Access asks if you want to create a query based on the table. Click Yes to continue.
   a) Access opens the Query Builder and adds the table that was originally in the Control Source property
5) Add fields to the query grid by double-clicking each field name that you want on the report. This must be done for all fields that you want to be displayed on the report.
   a) To add fields from related tables or queries:
      • On the Design tab, in the Query Setup group, click Show Table.
      • In the Show Table dialog box, select the table or query that you want to add, and then click Add.
      • Click Finish to close the Show Table dialog box.
      • Make sure the tables and queries you add are joined in a logical way. For example, the ID field of the Customer table would likely have a join line connecting it to the CustomerID field of the Orders table. You can create join lines by dragging a field name from one table or query to a field name in another table or query.
      • Add fields to the query grid by double-clicking each field name that you want on the report. This must be done for all fields that you want to be displayed on the report.
6) To test your query:
   a) On the Design tab, in the Results group, click View, and then click Datasheet View.
   b) To return to Design view, on the Design tab, in the Results group, click View, and then click Design View.
7) When you are satisfied that the data returned by the query is the data you want on your report, on the Design tab, in the Close group, click Close.
8) Click Yes to save the changes made to the SQL statement and update the property.

Note: If the new query does not contain all the fields that were used on the report, Access will prompt you for a parameter value for each missing field. You can either delete the reference to the field on the report, or use the procedure under Edit an embedded query to add the missing fields to the query.
Method 2: Add a field from a related table by using the field list
1) In the Navigation Pane, right-click the report you want to modify, and then click Layout View.
2) If the Field List task pane is not already displayed, on the Design tab, in the Tools group, click Add Existing Fields.
3) If Show all tables is displayed at the top of the field list, click it to display fields in related tables and other tables.
4) Under Fields available in related tables, expand a table, and drag one of its fields to the report.
   a) Access changes the record source to an embedded query that contains the field you added. You can continue adding fields in this manner, or edit the embedded query by using the procedure in Edit an embedded query.

Method 3: Copy and paste SQL from a named query
1) In the Navigation Pane, right-click the query that contains the SQL statement you want to copy, and then click Design View.
2) On the Home tab, in the Views group, click View, and then click SQL View.
3) Copy the text in the SQL pane, and then close the query without saving.
4) In the Navigation Pane, right-click the report to which you want to add the embedded query, and then click Layout View.
5) If the property sheet is not already displayed, press F4 to display it.
6) On the All tab, select the text that is in the Record Source property, and then press CTRL+V to paste the SQL into the property box.

Note: If the new query does not contain all the fields that were used on the report, Access will prompt you for a parameter value for each missing field. You can either delete the reference to the field on the report, or use the procedure under Edit an embedded query to add the missing fields to the query.

Method 4: Copy and paste SQL from another report
You can copy an embedded query directly from the Record Source property of one object to another.
1) In the Navigation Pane, right-click the report that contains the embedded SQL statement you want to copy, and then click Layout View.
2) Right-click anywhere on the report, and then click Report Properties.
3) On the All tab, select the entire SQL statement text in the Record Source property box, and then press CTRL+C to copy it.
4) Close the report without saving.
5) In the Navigation Pane, right-click the report to which you want to add the embedded query, and then click Layout View.
6) Right-click anywhere on the report, and then click Report Properties.
7) On the All tab, select the text that is in the Record Source property, and then press CTRL+V to paste the SQL into the property.

Note: If the new query does not contain all the fields that were used on the report, Access will prompt you for a parameter value for each missing field. You can either delete the reference to the field on the report, or use the procedure under Edit an embedded query to add the missing fields to the query.
Edit an embedded query
As your database grows, you might need to modify the record source of a report, for example, to add more fields to a report. Use this procedure to open the record source in the Query Builder:

1) In the Navigation Pane, right-click the report that contains the embedded query that you want to edit, and then click Layout View.
2) Right-click anywhere on the report, and then click Report Properties.
3) On the All tab, click in the Record Source property box, and then click the Build button.
   a) Access opens the query in the Query Builder.
4) Edit the query as needed, and then on the Design tab, in the Close group, click Close.
5) Click Yes to save the changes and update the property.
   a) Access closes the Query Builder. Any changes you made in the Query Builder will be reflected in the SQL statement in the Record Source property.

Save an embedded query as a named query
You might decide that the embedded query that is serving as the record source for a report might also be useful for some other purpose. In that case, you can save it as a named query which will then be available for use by other objects.

1) In the Navigation Pane, right-click the report that contains the embedded query, and then click Layout View.
2) Right-click anywhere on the report, and then click Report Properties.
3) On the All tab, click in the Record Source property box, and then click the Build button.
   a) Access opens the query in the Query Builder.
4) In the Save As dialog box, type a query name in the top box, and then click OK.
   a) Access saves the query as a named query in the Navigation Pane.
6) On the Design tab, in the Close group, click Close.
   a) Access asks if you want to save the changes made to the embedded query, even if you didn’t make any changes. In most cases, you should just click No to close the Query Builder. However, if you did make changes that you want to be reflected in the report’s embedded query, click Yes.

Step 3: Create the report
1) Click the button for the tool you want to use. If a wizard appears, follow the steps in the wizard and click Finish on the last page.
   a) Access displays the report in Layout view.
2) Format the report until it looks the way you want:
   a) Resize fields and labels by selecting them and then dragging the edges until they are the size you want.
   b) Move a field by selecting it (and its label, if present), and then dragging it to the new location.
   c) Right-click a field and use the commands on the shortcut menu to delete or select fields, and perform other formatting tasks.
Create a report by using the Report tool

The Report tool provides the fastest way for you to create a report, because it generates a report immediately without prompting you for information. The report displays all the fields from the underlying table or query. The Report tool may not create the final, polished product that you ultimately want, but it is quite useful as a means to quickly look at the underlying data. You can then save the report and modify it so that it better serves your purposes.

1) In the Navigation Pane, select the table or query that will serve as the record source for the report.
2) On the Create tab, in the Reports group, click Report.
   a) Access builds the report and displays it in Layout view.

After viewing the report, you can save it and then close both the report and the underlying table or query that you used as a record source. The next time that you open the report, Access will display the most recent data from your record source.

Create a report by using the Blank Report tool

If you want to be more selective about the data that is displayed on the report, you can use the Blank Report tool to build a report from scratch. This can be a very quick way to build a report, especially if you plan to display only a few fields. The following procedure explains how to use the Blank Report tool:

1) On the Create tab, in the Reports group, click Blank Report
   a) A blank report is displayed in Layout view, and the Field List task pane is displayed on the right side of the Access window.
2) In the Field List task pane, if no tables are displayed, click Show all tables.
3) Click the plus sign (+) next to the table or tables containing the fields that you want to see on the report.
4) Drag each field onto the report one at a time, or hold down CTRL and select several fields, and then drag them onto the report at the same time.
5) Use the tools in the Header / Footer group on the Design tab to add a logo, title, page numbers, or the date and time to the report.

Create a report in Report Design view

In Design view, you can more easily see which controls are in which section of the report. You can position controls individually without using layouts.

1) On the Create tab, in the Reports group, click Report Design.
2) In the Field List task pane, if no tables are displayed, click Show all tables.
3) Click the plus sign (+) next to the table or tables containing the fields that you want to see on the report.
4) Drag each field onto the report one at a time, or hold down CTRL and select several fields, and then drag them onto the report at the same time.
5) Use the tools in the Header / Footer group on the Design tab to add a logo, title, page numbers, or the date and time to the report.
6) Add controls to layouts, or remove them from layouts, by using the commands on the Arrange tab, in the Table group.
**Create a report by using the Report Wizard**

You can use the Report Wizard to be more selective about what fields appear on your report. You can also specify how the data is grouped and sorted, and you can use fields from more than one table or query, provided you have specified the relationships between the tables and queries beforehand.

1) On the **Create** tab, in the **Reports** group, click **Report Wizard**.

2) Follow the directions on the Report Wizard pages. On the last page, click **Finish**.
   
   a) When you preview the report, you see the report as it will appear in print. You can also increase the magnification to zoom in on details.

**Note:** If you want to include fields from multiple tables and queries in your report, do not click **Next** or **Finish** after you select the fields from the first table or query on the first page of the Report Wizard. Instead, repeat the steps to select a table or query, and click any additional fields that you want to include in the report. Then, click **Next** or **Finish** to continue.

**Create labels by using the Label Wizard**

Use the Label Wizard to easily create labels for a wide variety of standard label sizes.

1) In the Navigation Pane, select the table or query that will serve as the record source for your labels.

2) On the **Create** tab, in the **Reports** group, click **Labels**.

3) Follow the directions on the pages of the Label Wizard. On the last page, click **Finish**.
   
   a) Access displays your labels in Print Preview so that you can see them as they will appear when they are printed. You can use the slider control on the Access status bar to zoom in on details.

   **Note:** Print Preview is the only view you can use to see multiple columns — the other views show the data in a single column.

**Display the property sheet**

- On the **Design** tab, in the **Tools** group, click **Property Sheet**, or, Press F4.

**Add controls to the report**

Some controls are created automatically, such as the bound text box control that is created when you add a field from the **Field List** pane to your report. Many other controls can be created in Layout view or Design view by using the tools in the **Controls** group on the **Design** tab.

**Note:** You can determine the name of each tool by placing the mouse pointer over the tool and then reading the tooltip that appears.

1) Click the tool for the type of control that you want to add.

2) Click on the report where you want the control to be located.
   
   a) If you don't position the control perfectly on the first try, you can move it by using the following procedure:

      - Click the control to select it.
      - Position the mouse pointer over the edge of the control until the pointer turns into a four-headed arrow.
      - Drag the control to the location that you want.
This procedure creates an "unbound" control. If the control is the type that can display data (a text box or check box, for example), you need to enter a field name or expression in the ControlSource property for the control before it will display any data.

**Add images**

Traditionally in Access, images have been bound to individual image controls on forms or reports. To change a commonly-used image that was used across multiple reports, each image control had to be edited manually. In Access 2010, however, you can now attach an image to a database once, and then use the image across multiple objects. Updating the single image updates it wherever it is used across the entire database.

**Add an image**

1) In the Navigation Pane, right-click the report to which you want to add the image, and then click **Layout View**.
2) Click on the report where you want to add the image.
3) On the **Design** tab, in the **Controls** group, click **Insert Image**.
4) Do one of the following:
   a) **Use an existing image**: If the image you want is already in the gallery, click it to add it to the report.
   b) **Upload a new image**: At the bottom of the gallery, click **Browse**. In the **Insert Picture** dialog box, navigate to the image you want to use, and then click **Open**.

**Add a background image**

1) In the Navigation Pane, right-click the report to which you want to add the background image, and then click **Layout View**.
2) On the **Format** tab, in the **Background** group, click **Background Image**.
3) Do one of the following:
   a) **Use an existing image**: If the image you want is already in the gallery, click it to add it to the report.
   b) **Upload a new image**: At the bottom of the gallery, click **Browse**. In the **Insert Picture** dialog box, navigate to the image you want to use, and then click **Open**.

**Preview and print a report**

**Preview a report**

1) Open the report you want to preview, or just select it in the Navigation Pane.
2) On the **File** tab, click **Print**, and then click **Print Preview**.
   a) Access opens the report in Print Preview. You can use the commands on the **Print Preview** tab to do any of the following:
      - Print the report
      - Adjust page size or layout
      - Zoom in or out, or view multiple pages at a time
      - Refresh the data on the report
      - Export the report to another file format
3) To return to the database workspace, on the **Print Preview** tab, in the **Close Preview** group, click **Close Print Preview**.
**Print a report**
In addition to printing from Print Preview, you can also print a report without previewing:

1) Open the report you want to preview, or just select it in the Navigation Pane.
2) On the **File** tab, click **Print**.
   a) To send the report directly to the default printer without setting printer options, click **Quick Print**.
   b) To open a dialog box where you can select a printer, specify the number of copies, and so on, click **Print**.

**Create a grouped or summary report**
Information is often easier to understand when it is divided into groups. For example, a report that groups sales by region can highlight trends that otherwise might go unnoticed. In addition, placing totals at the end of each group in your report can replace a lot of manual interaction with a calculator.

Microsoft Access 2010 makes working with grouped reports easy. You can create a basic grouped report by using the Report Wizard, you can add grouping and sorting to an existing report, or you can revise grouping and sorting options that have already been defined.

The fastest way to add grouping, sorting, or totals to a report is to right-click the field to which you want to apply the group, sort, or total, and then click the desired command on the shortcut menu.

You can also add grouping, sorting, or totals by using the Group, Sort, and Total pane while the report is open in Layout view or Design view:

**Build a new grouped report by using the Report Wizard**
The Report Wizard presents you with a series of questions, and then generates a report based on your answers. Among those questions is one that asks for the field or fields to use to group your report. After the report is created, you can use it as-is or modify it to better suit your needs. Before you begin with the Report Wizard, you need to decide upon a data source.

**Start the Report Wizard**
1) On the **Create** tab, in the **Reports** group, click **Report Wizard**.
   a) Access starts the **Report Wizard**.
2) Click the **Tables/Queries** drop-down list and choose the table or query that contains the fields you want on your report.
3) Double-click fields in the **Available Fields** list to choose them.
   a) Access moves them to the **Selected Fields** list. Alternatively, you can click the buttons located between the **Available Fields** box and the **Selected Fields** box to add or remove the selected field or to add all or remove all of the fields.
4) If there are fields in another table or query that you also want to put on your report, click the **Tables/Queries** drop-down list again and choose the other table or query, and continue to add fields.
5) After you've finished adding fields, click **Next**.
**Group records in the Report Wizard**

Grouping lets you organize and arrange records by group, such as by Region or SalesPerson. Groups can be nested so that you can easily identify the relationships among the groups and find the information you want quickly. You can also use grouping to calculate summary information, such as totals and percentages.

When you include more than one table in a report, the wizard examines the relationships between the tables and determines how you might want to view the information.

1) On the page of the Report Wizard that asks **Do you want to add any grouping levels?**, click one of the field names in the list, and then click **Next**.

2) To add grouping levels, double-click any of the field names in the list to add them to your report.
   a) You can also remove a grouping level by double-clicking it in the page display on the right side of the dialog box. Use the arrow buttons to add and remove grouping levels, and adjust the priority of a grouping level by selecting it and clicking the up or down priority buttons. Access adds each grouping level and shows it nested within its parent grouping level.

3) Click **Grouping Options** to display the **Grouping Intervals** dialog box.
   a) Optionally, for each group-level field, choose a grouping interval.
      - The grouping interval lets you customize how records are grouped. In the previous illustration, records are grouped on the ShippedDate field, which is a Date/Time data type. The Report Wizard offers choices appropriate to the field type in the **Grouping intervals** list. Thus, because ShippedDate is a Date/Time type, you can choose to group by actual value (**Normal**), **Year**, **Quarter**, **Month**, **Week**, **Day**, **Hour** and **Minute**. If the field were a Text data type, you could choose to group by the entire field (**Normal**), or perhaps by the first one to five characters. For a numeric data type, you can choose to group by value (**Normal**), or by range in selected increments.
   
   b) After selecting a grouping interval, click **OK**.

4) Click **Next** to navigate to the next page of the wizard.
**Sort and summarize records**

You can sort records by up to four fields, in either ascending or descending order.

1) Click the first drop-down list and choose a field on which to sort.
   a) You can click the button to the right of the list to toggle between ascending and descending order (**Ascending** is the default). Optionally, click the second, third, and fourth drop-down lists to choose additional sort fields.

2) Click **Summary Options** if you want to summarize any of the numeric fields.

   Note that the **Summary Options** button will only be visible if you have one or more numeric fields in the Detail section your report. The wizard displays the available numeric fields.

   a) Select the check box under your choice of **Sum**, **Avg**, **Min** or **Max** to include those calculations in the group footer.
   b) You can also choose to show the details and summary or the summary only. In the latter case, totals for each ShippedDate value are shown (if you selected the check box for **Sum**, for example), but the order detail is omitted. You can also choose to show percent of total calculations for sums.
   c) Click **OK**.

3) Follow the directions on the remaining pages of the Report Wizard. On the last page, you can edit the title of the report. This title will be displayed on the first page of the report, and Access will also save the report, using the title as the document name. You can edit both the title and the document name later.

4) Click **Finish**.

   a) Access automatically saves the report and displays it in Print Preview, which shows you the report as it will look when printed.

You can use the navigation buttons at the bottom of the preview pane to view the pages of the report sequentially or jump to any page in the report. Click one of the navigation buttons or type the page number that you want to see in the page number box, and then press ENTER.

In Print Preview, you can zoom in to see details or zoom out to see how well data is positioned on the page. With the mouse pointer positioned over the report, click once. To reverse the effect of the zoom, click again. You can also use the zoom control in the status bar.
Add or modify grouping and sorting in an existing report
If you have an existing report and you want to add sorting or grouping to it, or if you want to modify the report's existing sorting or grouping, this section helps you get started.

Add grouping, sorting, and totals
You can perform simple sorting, grouping and totaling operations by right-clicking fields in Layout view and then choosing the operation you want from the shortcut menu. To switch to Layout view, right-click the report in the Navigation Pane and then click Layout view.

Sort on a single field
1) Right-click any value in the field on which you want to sort.
2) On the shortcut menu, click the sort option you want. For example, to sort a text field in ascending order, click Sort A to Z. To sort a numeric field in descending order, click Sort Largest to Smallest.
   a) Access sorts the report as you specified. If the Group, Sort, and Total pane is open, you can see that a new Sort by line for the field has been added.

Sort on multiple fields
Note: When you apply sorting by right-clicking a field in Layout view, you can only sort one field at a time. Applying sorting to another field removes the sorting on the first field. This differs from the sorting behavior in forms, where multiple sort orders can be established by right-clicking each field in turn and choosing the sort order you want.

Group on a field
1) Right-click any value in the field on which you want to group.
2) On the shortcut menu, click Group On.
   a) Access adds the grouping level and creates a group header for it. If the Group, Sort, and Total pane is open, you can see that a new Group on line for the field is added.

Add a total to a field
This option lets you calculate a sum, average, count, or other aggregate for a field. A grand total is added to the end of the report, and group totals are added to any groups that exist on the report.
1) Right-click any value in the field that you want to total.
2) Click Total.
3) Click the operation you would like to perform: Sum, Average, Count Records (to count all records), Count Values (to count only the records with a value in this field), Max, Min, Standard Deviation, or Variance.
   a) Access adds a calculated text box control to the report footer, which creates a grand total. Also, if your report has any grouping levels, Access adds group footers (if not already present) and places the total in each footer.

Note: You can also add totals by clicking the field that you want totaled and then, on the Design tab, in the Grouping & Totals group, click Totals.

Add grouping, sorting, and totals by using the Group, Sort, and Total pane
Working in the Group, Sort, and Total pane gives you the most flexibility when you want to add or modify groups, sort orders, or totals options on a report. Again, Layout view is the preferred view in which to work because it is much easier to see how your changes affect the display of the data.
**Display the Group, Sort, and Total pane**

1) On the Design tab, in the Grouping & Totals group, click Group & Sort
   a) Access displays the Group, Sort, and Total pane.
2) To add a new sorting or grouping level, click Add a group or Add a sort.
   a) A new line is added to the Group, Sort, and Total pane, and a list of available fields is displayed.
   b) You can click one of these field names or you can click expression below the list of fields to enter an expression. Once you choose a field or enter an expression, Access adds the grouping level to the report. In Layout view, the display changes immediately to show the grouping or sort order.

**Notes:**
- If there are already several sorting or grouping levels defined, you may need to scroll down in the Group, Sort, and Total pane before you can see the Add a group and Add a sort buttons.
- You can define up to 10 grouping and sorting levels in a report.

**Change grouping options**

Each sorting or grouping level has a number of options that can be set to obtain the results you want.

1) To display all the options for a grouping or sorting level, click More on the level that you want to change.
   a) To hide the options, click Less.
- **Sort order:** You can change the sort order by clicking the sort order drop-down list, then clicking the option you want.
- **Group interval:** This setting determines how the records are grouped together. For example, you can group on the first character of a text field so that all that start with "A" are grouped together, all that start with "B" are grouped together, and so on. For a date field, you can group by day, week, month, quarter, or you can enter a custom interval.
- **Totals:** To add totals, click this option. You can add totals on multiple fields, and you can do multiple types of totals on the same field.
  - Click the Total On drop-down arrow and select the field you want to have summarized.
  - Click the Type drop-down arrow and select the type of calculation to perform.
Select **Show Grand Total** to add a grand total to the end of the report (in the report footer).

Select **Show group totals as % of Grand Total** to add a control to the group footer that calculates the percentage of the grand total for each group.

Select **Show in group header** or **Show in group footer** to display the total in the desired location.

Once all the options have been chosen for a field, you can repeat the process and summarize another field by selecting the other field from the **Total On** drop-down list. Otherwise, click outside the **Totals** pop-up window to close it.

**Title:** This allows you to change the title of the field being summarized. This is used for the column heading and for labeling summary fields in headers and footers.

**To add or modify the title:**
1) Click the blue text following **with title**.
   a) The **Zoom** dialog box appears.
2) Type the new title in the dialog box, and then click **OK**.

**With/without a header section:** Use this setting to add or remove the header section that precedes each group. When adding a header section, Access moves the grouping field to the header for you. When you remove a header section that contains controls other than the grouping field, Access asks for confirmation to delete the controls.

**With/without a footer section:** Use this setting to add or remove the footer section that follows each group. When you remove a footer section that contains controls, Access asks for confirmation to delete the controls.

**Keep group together:** This setting determines how groups are laid out on the page when the report is printed. You may want to keep groups together as much as possible to reduce the amount of page turning that is needed to see the entire group. However, this usually increases the amount of paper needed to print the report, because most pages will have some blank space at the bottom.

  o **Do not keep group together on one page:** Use this option if you are not concerned about groups being broken up by page breaks. For example, a group of 30 items may have 10 items on the bottom of one page and the remaining 20 items at the top of the next page.

  o **Keep whole group together on one page:** This option helps minimize the number of page breaks in a group. If a group cannot fit in the remaining space on a page, Access leaves that space blank and begins the group on the next page instead. Large groups may still span multiple pages, but this option minimizes the number of page breaks within the group as much as possible.

  o **Keep header and first record together on one page:** For groups with group headers, this ensures that the group header will not print by itself at the bottom of a page. If Access determines that there is not enough room for at least one row of data to be printed after the header, the group begins on the following page.

**Change the priority of grouping and sorting levels**
To change the priority of a grouping or sorting level, click the row in the **Group, Sort, and Total** pane and then click the up arrow or the down arrow on the right side of the row.
Delete grouping and sorting levels
To delete a grouping or sorting level, click the row you want to delete in the Group, Sort, and Total pane, and then press DELETE or click the Delete button on the right side of the row. When you delete a grouping level, if the grouping field was in the group header or footer, Access moves it to the report’s Detail section. Any other controls that were in the group header or group footer are deleted.

Create a summary report (without record details)
If you want to show only totals (that is, just the information in header and footer rows), on the Design tab, in the Grouping & Totals group, click Hide Details. Doing this hides the records at the next lower level of grouping, resulting in a much more compact presentation of the summary data. Although the records are hidden, the controls in the hidden section are not deleted. Click Hide Details again to restore the Detail rows to the report.

Create an expression
This section describes how to create and use expressions in Microsoft Office Access. You use expressions to perform many of the same tasks for which you use formulas in Microsoft Office Excel. This section shows you where to use expressions, depending on the specific task that you want to perform.

Overview of expressions
An expression is a combination of some or all of the following: built-in or user-defined functions, identifiers, operators, and constants. Each expression evaluates to a single value.

For example, the following expression contains all four of these elements:

=Sum([Purchase Price])*0.08

In this example, Sum() is a built-in function, [Purchase Price] is an identifier, * is a mathematical operator, and 0.08 is a constant. This expression can be used in a text box in a form footer or report footer to calculate sales tax for a group of items.

Expressions can be much more complex or much simpler than this example. For example, this Boolean expression (an expression that evaluates to either True or False) consists of only an operator and a constant:

>0

This expression returns True when it is compared to a number that is greater than 0, and returns False when it is compared to a number that is less than 0. You can use this expression in the Validation Rule property of a control or table field to ensure that only positive values are entered.
Overview of the Expression Builder

Expressions are used in many different contexts in Access, and are similar to formulas in Microsoft Office Excel. The Expression Builder provides easy access to the names of the fields and controls in your database, and to many of the built-in functions that are available to you when you write expressions. You can use as many or as few of these features as you want, depending on your own needs or preferences.

The following illustration calls out the major parts of the Expression Builder:

1 Instructions and Help link: Get information about the context in which you are entering the expression.
2 Expression box: Type your expression here, or add expression elements by double-clicking items in the element lists below.

Note: If you do not see the element lists (items 3, 4, and 5), click More >> to the right of the Expression box.
3 Expression Elements list: Click an element type to view its categories in the Expression Categories list.
4 Expression Categories list: Click a category to view its values in the Expression Values list. If there are no values in the Expression Values list, double-click the category item to add it to the Expression box.
5 Expression Values list: Double-click a value to add it to the Expression box.
6 Help and information about the selected expression value: If available, click the link to see a Help article about the selected expression value.
**New features in the Access 2010 Expression Builder**

In Access 2010, the Expression Builder has been redesigned to be easier to use. Here are some changes that you will notice in this version:

**IntelliSense**: As soon as you begin typing an identifier or function name, IntelliSense displays a drop-down list of possible values. You can continue typing, or you can double-click the correct value in the list to add it to the expression. Alternatively, you can use the up- and down-arrow keys to select the value you want, and then press TAB or ENTER to add it to your expression. For example, if you begin typing the word “Format”, the IntelliSense list displays all the functions that begin with “Format”.

**Tip**: To hide the IntelliSense drop-down list, press ESC. To show it again, press CTRL+SPACEBAR.

While the IntelliSense list is displayed, a short description, or Quick Tip, appears to the right of the currently selected item. The first item in the list is selected by default, but you can select any item in the list to view its Quick Tip. The Quick Tip can help you determine the purpose of a function, or what kind of control or property the item is. The illustration shows the IntelliSense list and a Quick Tip.

1. IntelliSense displays possible functions and other identifiers as you type an expression.
2. Quick Tips display a short description of the selected item.

- **Quick Info**: While you are typing a function in an expression, the Quick Info feature displays the syntax of the function, so that you know exactly which arguments are required for the function. Optional arguments are enclosed in square brackets ([ ]). While the Quick Info is displayed, you can click on the function name to open a Help topic for more information.

1. Quick Info displays the syntax of the function. Click the function name to open a Help topic about the function.
2. Optional arguments are enclosed in square brackets. The argument that you are currently typing is displayed in bold text.

**Important**: Do not confuse the square brackets that indicate optional arguments with the square brackets that enclose identifiers in the actual expression.
In addition to these new features, the Expression Builder dialog box itself has been redesigned:
  
  - You can click << Less or More >> to control how much of the Expression Builder dialog box is displayed.
  - When you resize the Expression Builder dialog box, the new size is retained for the duration of your Access session, keeping you from having to resize the dialog box each time you open it.
  - The row of operator buttons has been removed, resulting in a less cluttered dialog box.

**Use expressions in report controls**

When you use an expression as the data source for a control, you create a calculated control. For example, suppose that you have a report that displays multiple inventory records, and you want to create a total in the report footer that sums all the line items on the report.

To calculate the total, place a text box control in the report footer, and then set the **ControlSource** property of the text box to the following expression:

```plaintext
=Sum([table_field])
```

In this case, **table_field** is the name of the field that contains your subtotal values. That field can reside in a table or a query. The **Sum** function calculates the total for a set of values from your record source.

The following procedure shows how to enter an expression in a text box control.

**Enter an expression in a text box control**

1) In the Navigation Pane, right-click the report that you want to change, and then click **Layout View** or **Design View** on the shortcut menu.
2) Select the control into which you want to enter an expression.
3) If the Property Sheet is not already displayed, press F4 to display it.
4) To manually create an expression, on the **Data** tab in the property sheet, click the **ControlSource** property of the text box, and then type `=` followed by the rest of your expression. For example, to calculate the subtotal shown above, type `=Sum([table_field])`, making sure that you substitute the name of your field for **table_field**.
5) To create an expression by using the Expression Builder, click the **Build** button in the property box.

After completing your expression, the property sheet will resemble the following:
Add an expression to an existing group or sort

1) In the Navigation Pane, right-click the report that you want to change, and then click Layout View or Design View on the shortcut menu.

2) Click the group level or sort order that you want to change.

3) Click the down arrow next to Group on (for grouping levels) or Sort by (for sort orders).
   a) A list that contains the available fields appears.

4) At the bottom of the list that contains the fields, click expression to start the Expression Builder.

5) Type your expression in the expression box (the upper box) of the Expression Builder. Make sure that you begin your expression with the equal (=) operator.